aboutsummaryrefslogtreecommitdiff
path: root/graphics/openjump
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-10 18:22:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-10 18:22:25 +0000
commit5cfa2f497be1a9bfff61211e697a483f5ff52fb1 (patch)
tree8c1e7c98a0e588f3e2d2645f5e72b06023847a51 /graphics/openjump
parent5aebf8ded5c6953538f412306c9dd71f634f265e (diff)
downloadports-5cfa2f497be1a9bfff61211e697a483f5ff52fb1.tar.gz
ports-5cfa2f497be1a9bfff61211e697a483f5ff52fb1.zip
OpenJUMP is an open source GIS software written in Java. It is based on
JUMP GIS by Vivid Solutions. It's features include: * It is a Vector GIS that can read rasters as well. * OpenJUMP is known to work on Windows, Linux and Mac platforms, but should work on any operating system that runs Java 1.5 or later. * It is not just another free demo viewer, but you can edit, save, analyze etc. with JUMP / OpenJUMP. * It works, even with medium size datasets, and with professional touch. * It provides a GIS API with a flexible plugin structure, so that new features are relatively easy to develope around the sound mapping platform. * It utilises standards like GML, WMS and WFS. * It is already translated in English, Finnish, French, German, Italian, Portugese and Spanish. The translation in other languages is in progress. WWW: http://www.openjump.org/ PR: ports/134403 Submitted by: Wen Heping<wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=233620
Diffstat (limited to 'graphics/openjump')
-rw-r--r--graphics/openjump/Makefile49
-rw-r--r--graphics/openjump/distinfo3
-rw-r--r--graphics/openjump/pkg-descr18
-rw-r--r--graphics/openjump/pkg-plist58
4 files changed, 128 insertions, 0 deletions
diff --git a/graphics/openjump/Makefile b/graphics/openjump/Makefile
new file mode 100644
index 000000000000..29e92b9f95c8
--- /dev/null
+++ b/graphics/openjump/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: openjump
+# Date created: 08 May, 2009
+# Whom: Wen Heping<wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openjump
+PORTVERSION= 1.3
+CATEGORIES= graphics java geography
+MASTER_SITES= SF/jump-pilot
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= An open source GIS software written in Java
+
+TARGET_DIR= ${PREFIX}/${PORTNAME}
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+USE_ZIP= yes
+NO_BUILD= yes
+PORTDOCS= OJ_improvements_from_v1.2_to_v1.3.txt gpl2_license.txt \
+ Using_MrSIDPlugIn.txt apache_license.txt readme.txt
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${ECHO_CMD} "---> Installing JAR files"
+ ${MKDIR} ${TARGET_DIR}/lib
+ ${INSTALL_DATA} ${WRKSRC}/lib/*.jar ${TARGET_DIR}/lib
+ ${MKDIR} ${TARGET_DIR}/lib/ext
+ @cd ${WRKSRC}/lib/ext && ${COPYTREE_SHARE} . ${TARGET_DIR}/lib/ext
+ @${ECHO_MSG} "Installing startup script"
+ ${MKDIR} ${TARGET_DIR}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/openjump.sh ${TARGET_DIR}/bin/openjump
+ ${INSTALL_DATA} ${WRKSRC}/bin/workbench-properties.xml ${TARGET_DIR}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/bin/default-plugins.xml ${TARGET_DIR}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/bin/log4j.xml ${TARGET_DIR}/bin/
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "---> Installing documentation"
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.else
+ @${ECHO_MSG} "---> Skipping documentation"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/openjump/distinfo b/graphics/openjump/distinfo
new file mode 100644
index 000000000000..8ab0968e53ec
--- /dev/null
+++ b/graphics/openjump/distinfo
@@ -0,0 +1,3 @@
+MD5 (openjump-1.3.zip) = 71eafced5e08b641566f475b96996013
+SHA256 (openjump-1.3.zip) = 7e403e09be83329938b5a8a0f26f0977147cdce3829c58e5ca7e471a49874f1f
+SIZE (openjump-1.3.zip) = 12427236
diff --git a/graphics/openjump/pkg-descr b/graphics/openjump/pkg-descr
new file mode 100644
index 000000000000..ecc9ad80b0bf
--- /dev/null
+++ b/graphics/openjump/pkg-descr
@@ -0,0 +1,18 @@
+OpenJUMP is an open source GIS software written in Java. It is based on
+JUMP GIS by Vivid Solutions. It's features include:
+ * It is a Vector GIS that can read rasters as well.
+ * OpenJUMP is known to work on Windows, Linux and Mac platforms, but
+should work on any operating system that runs Java 1.5 or later.
+ * It is not just another free demo viewer, but you can edit, save,
+analyze etc. with JUMP / OpenJUMP.
+ * It works, even with medium size datasets, and with professional
+touch.
+ * It provides a GIS API with a flexible plugin structure, so that
+new features are relatively easy to develope around the sound mapping
+platform.
+ * It utilises standards like GML, WMS and WFS.
+ * It is already translated in English, Finnish, French, German,
+Italian, Portugese and Spanish. The translation in other languages is in
+progress.
+
+WWW: http://www.openjump.org/
diff --git a/graphics/openjump/pkg-plist b/graphics/openjump/pkg-plist
new file mode 100644
index 000000000000..c36f093ad5fc
--- /dev/null
+++ b/graphics/openjump/pkg-plist
@@ -0,0 +1,58 @@
+openjump/bin/openjump
+openjump/bin/workbench-properties.xml
+openjump/bin/default-plugins.xml
+openjump/bin/log4j.xml
+openjump/lib/bsh-2.0b4.jar
+openjump/lib/Jama-1.0.1.jar
+openjump/lib/jdom.jar
+openjump/lib/jts-1.10.jar
+openjump/lib/xercesImpl.jar
+openjump/lib/xml-apis.jar
+openjump/lib/Buoy.jar
+openjump/lib/batik-all.jar
+openjump/lib/ermapper.jar
+openjump/lib/jai_codec.jar
+openjump/lib/jai_core.jar
+openjump/lib/jmatharray-20070905.jar
+openjump/lib/jython.jar
+openjump/lib/log4j-1.2.8.jar
+openjump/lib/openjump-api-1.3.jar
+openjump/lib/openjump-workbench-1.3.jar
+openjump/lib/postgis_1_0_0.jar
+openjump/lib/postgresql-8.3-603.jdbc3.jar
+openjump/lib/xml-apis-ext.jar
+openjump/lib/ext/BeanTools/0-Help.bsh
+openjump/lib/ext/BeanTools/1-HelloWorld.bsh
+openjump/lib/ext/BeanTools/2-NewLayer.bsh
+openjump/lib/ext/BeanTools/3-Populate.bsh
+openjump/lib/ext/BeanTools/4-AddAttribute.bsh
+openjump/lib/ext/BeanTools/5-ChangeAttributeValue.bsh
+openjump/lib/ext/BeanTools/6-PushPinPoints.bsh
+openjump/lib/ext/BeanTools/7-AddXYAsAttributes.bsh
+openjump/lib/ext/BeanTools/RefreshScriptsMenu.bsh
+openjump/lib/ext/jython/AlignSelected.py
+openjump/lib/ext/jython/ArcTool.py
+openjump/lib/ext/jython/CircleTool.py
+openjump/lib/ext/jython/DistributeSelected.py
+openjump/lib/ext/jython/OvalTool.py
+openjump/lib/ext/jython/RightAngleTool.py
+openjump/lib/ext/jython/RoadTool.py
+openjump/lib/ext/jython/RotatedRectangleTool.py
+openjump/lib/ext/jython/SetASHSLabel.py
+openjump/lib/ext/jython/UnionSelected.py
+openjump/lib/ext/jython/images/DrawArc.gif
+openjump/lib/ext/jython/images/DrawCircle.gif
+openjump/lib/ext/jython/images/DrawCorner.gif
+openjump/lib/ext/jython/images/DrawOval.gif
+openjump/lib/ext/jython/images/DrawPoint.gif
+openjump/lib/ext/jython/images/DrawRoad.gif
+openjump/lib/ext/jython/images/DrawRotRect.gif
+openjump/lib/ext/jython/startup.py
+openjump/lib/ext/readme.txt
+@dirrm openjump/lib/ext/jython/images
+@dirrm openjump/lib/ext/jython
+@dirrm openjump/lib/ext/BeanTools
+@dirrm openjump/lib/ext
+@dirrm openjump/lib
+@dirrm openjump/bin
+@dirrm openjump