aboutsummaryrefslogtreecommitdiff
path: root/graphics/opennurbs
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-02-06 20:14:06 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-02-06 20:14:06 +0000
commit9dc654374362b2517355b697fc049b22c61d0952 (patch)
tree7e28767aa58b115a15e1a148129faf7f5a15745d /graphics/opennurbs
parentf42387a5bbdd9bb7fb81276be73aa4ef1f20d174 (diff)
downloadports-9dc654374362b2517355b697fc049b22c61d0952.tar.gz
ports-9dc654374362b2517355b697fc049b22c61d0952.zip
graphics/opennurbs: link opennurbs against system zlib
Linking opennurbs against system zlib fixes other ports, see 187506 PR: 197135, 187506 Submitted by: fernando.apesteguia@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=378553
Diffstat (limited to 'graphics/opennurbs')
-rw-r--r--graphics/opennurbs/Makefile7
-rw-r--r--graphics/opennurbs/pkg-plist7
2 files changed, 10 insertions, 4 deletions
diff --git a/graphics/opennurbs/Makefile b/graphics/opennurbs/Makefile
index a436b6d04d6c..548989c742b7 100644
--- a/graphics/opennurbs/Makefile
+++ b/graphics/opennurbs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opennurbs
PORTVERSION= 20121024
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://files.na.mcneel.com/opennurbs/5.0/2012-10-24/
MASTER_SITE_SUBDIR= ${PORTNAME}_${PORTVERSION}
@@ -31,6 +31,8 @@ pre-build:
${ICONV_CMD} -c -f utf-8 -t ascii ${WRKSRC}/opennurbs_version.h \
> ${WRKSRC}/opennurbs_version.h.tmp || ${TRUE}
${MV} ${WRKSRC}/opennurbs_version.h.tmp ${WRKSRC}/opennurbs_version.h
+ ${MV} ${WRKSRC}/zlib ${WRKSRC}/zlib_
+ ${CP} -R /usr/src/lib/libz ${WRKSRC}/zlib
do-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR} \
@@ -71,5 +73,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/*.h ${STAGEDIR}${PREFIX}/include/openNURBS/
${INSTALL_DATA} ${WRKSRC}/zlib/*.h \
${STAGEDIR}${PREFIX}/include/openNURBS/zlib
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
+ ${TOUCH} ${STAGEDIR}${PREFIX}/include/openNURBS/zlib/gzguts.h
+.endif
.include <bsd.port.post.mk>
diff --git a/graphics/opennurbs/pkg-plist b/graphics/opennurbs/pkg-plist
index 8b23a32f003f..46533dddfc4b 100644
--- a/graphics/opennurbs/pkg-plist
+++ b/graphics/opennurbs/pkg-plist
@@ -104,6 +104,7 @@ include/openNURBS/opennurbs_xform.h
include/openNURBS/opennurbs_zlib.h
include/openNURBS/zlib/crc32.h
include/openNURBS/zlib/deflate.h
+include/openNURBS/zlib/gzguts.h
include/openNURBS/zlib/inffast.h
include/openNURBS/zlib/inffixed.h
include/openNURBS/zlib/inflate.h
@@ -120,8 +121,6 @@ libexec/openNURBS/example_userdata
libexec/openNURBS/example_write
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bsd.openNURBS.mk
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples_linking_pragmas.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/opennurbs.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_brep/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_brep/example_brep.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_read/Makefile
@@ -129,8 +128,10 @@ libexec/openNURBS/example_write
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_roundtrip/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_roundtrip/example_roundtrip.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_userdata/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_userdata/example_userdata.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_userdata/example_ud.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_userdata/example_ud.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_userdata/example_userdata.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_write/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_write/example_write.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples_linking_pragmas.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/opennurbs.h