aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 15:56:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 15:56:53 +0000
commit30eeeaafeb1413d09b9b90089a06f45c13fe9e68 (patch)
treed80b21ec4831e1d546326138b2b26b29ac7df98b /graphics/osg/Makefile
parent97897171fda2526b1be239bc1b14c21ec6b0d8ee (diff)
Notes
Diffstat (limited to 'graphics/osg/Makefile')
-rw-r--r--graphics/osg/Makefile19
1 files changed, 3 insertions, 16 deletions
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index 35ed42ddc86e..bfc6e530d987 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -4,7 +4,7 @@
PORTNAME= osg
PORTVERSION= 3.4.1
DISTVERSIONPREFIX= OpenSceneGraph-
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MAINTAINER= amdmi3@FreeBSD.org
@@ -39,10 +39,8 @@ PLIST_SUB= OSG_VERSION=${PORTVERSION} \
PORTSCOUT= limitw:1,even
OPTIONS_DEFINE= CURL FFMPEG FREETYPE GDAL GIF GSTREAMER GTA INVENTOR \
- JASPER LIBLAS LUA NVTT OPENEXR PDF SDL \
+ JASPER LIBLAS LUA NVTT OPENEXR PDF QT5 SDL \
SVG VNC XINE XRANDR
-OPTIONS_RADIO= QT
-OPTIONS_RADIO_QT=QT4 QT5
OPTIONS_DEFAULT=FFMPEG FREETYPE GIF XRANDR
GDAL_DESC= GDAL support
@@ -50,7 +48,6 @@ GTA_DESC= GTA file format support
INVENTOR_DESC= SGI OpenInventor support
LIBLAS_DESC= liblas support
NVTT_DESC= Use NVidia texture tools
-QT_DESC= QT toolkit support
SDL_DESC= Use SDL (joystick support in present3d)
VNC_DESC= LibVNCServer support
@@ -101,11 +98,6 @@ PDF_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
PDF_USE= gnome=cairo
PDF_VARS= FORCE_REQUIRE+=Poppler-glib
PDF_VARS_OFF= FORCE_IGNORE+=Poppler-glib
-QT4_USES= qt:4
-QT4_USE= qt=corelib,gui,moc_build,opengl,qmake_build,rcc_build,uic_build
-QT4_CMAKE_ON= -DDESIRED_QT_VERSION=4
-QT4_VARS= FORCE_REQUIRE+=Qt4
-QT4_VARS_OFF= FORCE_IGNORE+=Qt4
QT5_USE= qt:5
QT5_USE= qt=buildtools_build,core,gui,opengl,qmake_build,webkit
QT5_CMAKE_ON= -DDESIRED_QT_VERSION=5
@@ -137,7 +129,7 @@ FORCE_REQUIRE= Threads OpenGL X11 JPEG PNG TIFF ZLIB # common & lightweight
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MQT4} || ${PORT_OPTIONS:MQT5}
+.if ${PORT_OPTIONS:MQT5}
CMAKE_ARGS+= -DOSG_USE_QT:BOOL=ON
PLIST_SUB+= QT=""
.else
@@ -145,11 +137,6 @@ CMAKE_ARGS+= -DOSG_USE_QT:BOOL=OFF
PLIST_SUB+= QT="@comment "
.endif
-.if ${PORT_OPTIONS:MQT4}
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-.endif
-
post-patch:
@${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'