aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Algorithm-Line-Bresenham
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-09-03 19:07:52 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-09-03 19:07:52 +0000
commitdf4defb79e52c1dabf5565c7a821081f879fea38 (patch)
tree09883cbecd40fdfe01adeb7aa181f79dfbc63e21 /graphics/p5-Algorithm-Line-Bresenham
parent2cecf25080a39835dc4009773834b0899e8b6560 (diff)
downloadports-df4defb79e52c1dabf5565c7a821081f879fea38.tar.gz
ports-df4defb79e52c1dabf5565c7a821081f879fea38.zip
New port: graphics/p5-Algorithm-Line-Bresenham
Bresenham is one of the canonical line drawing algorithms for pixellated grids. Given a start and an end-point, Bresenham calculates which points on the grid need to be filled to generate the line between them. WWW: https://metacpan.org/release/Algorithm-Line-Bresenham PR: 230968 Submitted by: Tomohiro Hosaka <bokutin@bokut.in>
Notes
Notes: svn path=/head/; revision=478912
Diffstat (limited to 'graphics/p5-Algorithm-Line-Bresenham')
-rw-r--r--graphics/p5-Algorithm-Line-Bresenham/Makefile20
-rw-r--r--graphics/p5-Algorithm-Line-Bresenham/distinfo3
-rw-r--r--graphics/p5-Algorithm-Line-Bresenham/pkg-descr6
-rw-r--r--graphics/p5-Algorithm-Line-Bresenham/pkg-plist2
4 files changed, 31 insertions, 0 deletions
diff --git a/graphics/p5-Algorithm-Line-Bresenham/Makefile b/graphics/p5-Algorithm-Line-Bresenham/Makefile
new file mode 100644
index 000000000000..0f28a33d2336
--- /dev/null
+++ b/graphics/p5-Algorithm-Line-Bresenham/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= Algorithm-Line-Bresenham
+PORTVERSION= 0.11
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR=CPAN:OSFAMERON
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bokutin@bokut.in
+COMMENT= Simple pixellated line-drawing algorithm
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+NO_ARCH= yes
+USES= perl5
+USE_PERL5= modbuild
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Algorithm-Line-Bresenham/distinfo b/graphics/p5-Algorithm-Line-Bresenham/distinfo
new file mode 100644
index 000000000000..a58230145ddc
--- /dev/null
+++ b/graphics/p5-Algorithm-Line-Bresenham/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532978101
+SHA256 (Algorithm-Line-Bresenham-0.11.tar.gz) = bf7247458f8d810ed2ca0b61b69896e8af9b31bc4fe69766c2a53c44797b3aee
+SIZE (Algorithm-Line-Bresenham-0.11.tar.gz) = 2914
diff --git a/graphics/p5-Algorithm-Line-Bresenham/pkg-descr b/graphics/p5-Algorithm-Line-Bresenham/pkg-descr
new file mode 100644
index 000000000000..b50d0007a60b
--- /dev/null
+++ b/graphics/p5-Algorithm-Line-Bresenham/pkg-descr
@@ -0,0 +1,6 @@
+Bresenham is one of the canonical line drawing algorithms for
+pixellated grids. Given a start and an end-point, Bresenham
+calculates which points on the grid need to be filled to generate
+the line between them.
+
+WWW: https://metacpan.org/release/Algorithm-Line-Bresenham
diff --git a/graphics/p5-Algorithm-Line-Bresenham/pkg-plist b/graphics/p5-Algorithm-Line-Bresenham/pkg-plist
new file mode 100644
index 000000000000..6897413eabbf
--- /dev/null
+++ b/graphics/p5-Algorithm-Line-Bresenham/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Algorithm/Line/Bresenham.pm
+%%PERL5_MAN3%%/Algorithm::Line::Bresenham.3.gz