aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Data-Google-Visualization-DataTable
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-21 14:39:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-21 14:39:08 +0000
commitad1e28ca76fdd00e081b764a0cbb3e02e5d988f5 (patch)
tree648085e8af57f180dceac1d84710d5a26cd0b067 /graphics/p5-Data-Google-Visualization-DataTable
parent234cb62d3959cbd6edaa666746a08e8eaa7319e2 (diff)
downloadports-ad1e28ca76fdd00e081b764a0cbb3e02e5d988f5.tar.gz
ports-ad1e28ca76fdd00e081b764a0cbb3e02e5d988f5.zip
Easily create Google DataTable objects for the Google Visulization API.
This module is attempts to hide the gory details of preparing your data before sending it to a JSON serializer - more specifically, hiding some of the hoops that have to be jump through for making sure your data serializes to the right data types. WWW: http://search.cpan.org/dist/Data-Google-Visualization-DataTable/ PR: 204061 Submitted by: jeremybbaggs@gmail.com Approved by: mat (mentor) Differential Revision: D4637
Notes
Notes: svn path=/head/; revision=404110
Diffstat (limited to 'graphics/p5-Data-Google-Visualization-DataTable')
-rw-r--r--graphics/p5-Data-Google-Visualization-DataTable/Makefile21
-rw-r--r--graphics/p5-Data-Google-Visualization-DataTable/distinfo2
-rw-r--r--graphics/p5-Data-Google-Visualization-DataTable/pkg-descr8
-rw-r--r--graphics/p5-Data-Google-Visualization-DataTable/pkg-plist3
4 files changed, 34 insertions, 0 deletions
diff --git a/graphics/p5-Data-Google-Visualization-DataTable/Makefile b/graphics/p5-Data-Google-Visualization-DataTable/Makefile
new file mode 100644
index 000000000000..a8b97d3cb36c
--- /dev/null
+++ b/graphics/p5-Data-Google-Visualization-DataTable/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= Data-Google-Visualization-DataTable
+PORTVERSION= 0.11
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jeremybbaggs@gmail.com
+COMMENT= Easily create Google DataTable objects for the Google Visulization API
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-JSON-XS>=2.0:${PORTSDIR}/converters/p5-JSON-XS
+RUN_DEPENDS= p5-JSON-XS>=2.0:${PORTSDIR}/converters/p5-JSON-XS
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Data-Google-Visualization-DataTable/distinfo b/graphics/p5-Data-Google-Visualization-DataTable/distinfo
new file mode 100644
index 000000000000..eb38b6893ad4
--- /dev/null
+++ b/graphics/p5-Data-Google-Visualization-DataTable/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Data-Google-Visualization-DataTable-0.11.tar.gz) = 1d3b9002dd781a1dd8a7959b1c55e0a22ac9b0623e09cbeb9ff38927a04f664d
+SIZE (Data-Google-Visualization-DataTable-0.11.tar.gz) = 21002
diff --git a/graphics/p5-Data-Google-Visualization-DataTable/pkg-descr b/graphics/p5-Data-Google-Visualization-DataTable/pkg-descr
new file mode 100644
index 000000000000..31cda3da1057
--- /dev/null
+++ b/graphics/p5-Data-Google-Visualization-DataTable/pkg-descr
@@ -0,0 +1,8 @@
+Easily create Google DataTable objects for the Google Visulization API.
+
+This module is attempts to hide the gory details of preparing your data
+before sending it to a JSON serializer - more specifically, hiding some
+of the hoops that have to be jump through for making sure your data
+serializes to the right data types.
+
+WWW: http://search.cpan.org/dist/Data-Google-Visualization-DataTable/
diff --git a/graphics/p5-Data-Google-Visualization-DataTable/pkg-plist b/graphics/p5-Data-Google-Visualization-DataTable/pkg-plist
new file mode 100644
index 000000000000..acb02be59cf6
--- /dev/null
+++ b/graphics/p5-Data-Google-Visualization-DataTable/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Data/Google/Visualization/DataTable.pm
+%%SITE_PERL%%/Data/Google/Visualization/DataTable.pm.orig
+%%PERL5_MAN3%%/Data::Google::Visualization::DataTable.3.gz