aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-GD-Graph3d
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2000-04-23 17:12:00 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2000-04-23 17:12:00 +0000
commit681eefb02c7a419feb651d370fdf554e617013e9 (patch)
tree756174f12ede943197796555e33cd746617f1595 /graphics/p5-GD-Graph3d
parentf0339e04b71b6e79f97bbaa53646379fb442fd94 (diff)
downloadports-681eefb02c7a419feb651d370fdf554e617013e9.tar.gz
ports-681eefb02c7a419feb651d370fdf554e617013e9.zip
GD-Graph3d extensions module provides 3D graphs for the GD::Graph module.
PR: ports/17896 Submitted by: Dmitry Sivachenko <dima@Chg.RU>
Notes
Notes: svn path=/head/; revision=27935
Diffstat (limited to 'graphics/p5-GD-Graph3d')
-rw-r--r--graphics/p5-GD-Graph3d/Makefile27
-rw-r--r--graphics/p5-GD-Graph3d/distinfo1
-rw-r--r--graphics/p5-GD-Graph3d/pkg-comment1
-rw-r--r--graphics/p5-GD-Graph3d/pkg-descr5
-rw-r--r--graphics/p5-GD-Graph3d/pkg-plist9
5 files changed, 43 insertions, 0 deletions
diff --git a/graphics/p5-GD-Graph3d/Makefile b/graphics/p5-GD-Graph3d/Makefile
new file mode 100644
index 000000000000..a8391fbc9682
--- /dev/null
+++ b/graphics/p5-GD-Graph3d/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-GD-Graph
+# Date created: 10 April 2000
+# Whom: Dmitry Sivachenko <dima@Chg.RU>
+#
+# $FreeBSD$
+#
+
+PORTNAME= p5-GD-Graph3d
+PORTVERSION= 0.40
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= GD
+DISTNAME= GDGraph3d-${PORTVERSION}
+
+MAINTAINER= dima@Chg.RU
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph
+
+USE_PERL5= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= GD::Graph::Graph3d.3
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-GD-Graph3d/distinfo b/graphics/p5-GD-Graph3d/distinfo
new file mode 100644
index 000000000000..12d51043a73d
--- /dev/null
+++ b/graphics/p5-GD-Graph3d/distinfo
@@ -0,0 +1 @@
+MD5 (GDGraph3d-0.40.tar.gz) = 008aa3cd02774ff5e8835de89a72f908
diff --git a/graphics/p5-GD-Graph3d/pkg-comment b/graphics/p5-GD-Graph3d/pkg-comment
new file mode 100644
index 000000000000..40bd856ba076
--- /dev/null
+++ b/graphics/p5-GD-Graph3d/pkg-comment
@@ -0,0 +1 @@
+Creates 3D charts with GD::Graph and GD
diff --git a/graphics/p5-GD-Graph3d/pkg-descr b/graphics/p5-GD-Graph3d/pkg-descr
new file mode 100644
index 000000000000..dc6f1b942ca9
--- /dev/null
+++ b/graphics/p5-GD-Graph3d/pkg-descr
@@ -0,0 +1,5 @@
+GD-Graph3d extensions module provides 3D graphs for the GD::Graph module.
+
+
+--dima
+dima@Chg.RU
diff --git a/graphics/p5-GD-Graph3d/pkg-plist b/graphics/p5-GD-Graph3d/pkg-plist
new file mode 100644
index 000000000000..c3eee9fc139e
--- /dev/null
+++ b/graphics/p5-GD-Graph3d/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/GD/Graph/Graph3d.pod
+lib/perl5/site_perl/%%PERL_VER%%/GD/Graph/axestype3d.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Graph/bars3d.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Graph/lines3d.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Graph/pie3d.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/Graph/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/GD/Graph 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/GD 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/Graph 2>/dev/null || true