aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Graphics-Primitive
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-08-30 22:12:29 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-08-30 22:12:29 +0000
commitbfe1c827d0b2a26011883770c75eb35439d66cd1 (patch)
tree58b8557c6642e6e492768b4bd22039316a7240e2 /graphics/p5-Graphics-Primitive
parentd4a8317da5195cd7069fd62b7ea25e58f27c1c9d (diff)
downloadports-bfe1c827d0b2a26011883770c75eb35439d66cd1.tar.gz
ports-bfe1c827d0b2a26011883770c75eb35439d66cd1.zip
Add p5-Graphics-Primitive, device and library agnostic graphic primitives.
Graphics::Primitive is library agnostic system for drawing things. The idea is to allow you to create and manipulate graphical components and then pass them off to a Driver for actual drawing. WWW: http://search.cpan.org/dist/Graphics-Primitive/
Notes
Notes: svn path=/head/; revision=219488
Diffstat (limited to 'graphics/p5-Graphics-Primitive')
-rw-r--r--graphics/p5-Graphics-Primitive/Makefile51
-rw-r--r--graphics/p5-Graphics-Primitive/distinfo3
-rw-r--r--graphics/p5-Graphics-Primitive/pkg-descr6
-rw-r--r--graphics/p5-Graphics-Primitive/pkg-plist29
4 files changed, 89 insertions, 0 deletions
diff --git a/graphics/p5-Graphics-Primitive/Makefile b/graphics/p5-Graphics-Primitive/Makefile
new file mode 100644
index 000000000000..96f840cbf991
--- /dev/null
+++ b/graphics/p5-Graphics-Primitive/Makefile
@@ -0,0 +1,51 @@
+# Ports collection makefile for: p5-Graphics-Primitive
+# Date created: 2008/08/30
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Graphics-Primitive
+PORTVERSION= 0.26
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/G/GP/GPHAT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Device and library agnostic graphic primitives
+
+BUILD_DEPENDS= p5-Moose>=0.25:${PORTSDIR}/devel/p5-Moose \
+ p5-Geometry-Primitive>=0:${PORTSDIR}/graphics/p5-Geometry-Primitive \
+ p5-MooseX-Clone>=0:${PORTSDIR}/devel/p5-MooseX-Clone \
+ p5-MooseX-AttributeHelpers>=0:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
+ p5-Module-Install>=0.64:${PORTSDIR}/devel/p5-Module-Install \
+ p5-Forest>=0:${PORTSDIR}/devel/p5-Forest \
+ p5-Text-Flow>=0:${PORTSDIR}/textproc/p5-Text-Flow
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Graphics::Primitive.3 \
+ Graphics::Primitive::Aligned.3 \
+ Graphics::Primitive::Border.3 \
+ Graphics::Primitive::Brush.3 \
+ Graphics::Primitive::Canvas.3 \
+ Graphics::Primitive::Component.3 \
+ Graphics::Primitive::ComponentList.3 \
+ Graphics::Primitive::Container.3 \
+ Graphics::Primitive::Driver.3 \
+ Graphics::Primitive::Font.3 \
+ Graphics::Primitive::Image.3 \
+ Graphics::Primitive::Insets.3 \
+ Graphics::Primitive::Operation.3 \
+ Graphics::Primitive::Operation::Fill.3 \
+ Graphics::Primitive::Operation::Stroke.3 \
+ Graphics::Primitive::Oriented.3 \
+ Graphics::Primitive::Paint.3 \
+ Graphics::Primitive::Paint::Gradient.3 \
+ Graphics::Primitive::Paint::Solid.3 \
+ Graphics::Primitive::Path.3 \
+ Graphics::Primitive::TextBox.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Graphics-Primitive/distinfo b/graphics/p5-Graphics-Primitive/distinfo
new file mode 100644
index 000000000000..5942adb377bc
--- /dev/null
+++ b/graphics/p5-Graphics-Primitive/distinfo
@@ -0,0 +1,3 @@
+MD5 (Graphics-Primitive-0.26.tar.gz) = be684930b2fa2e874fbe81de97a14547
+SHA256 (Graphics-Primitive-0.26.tar.gz) = 4a87e3018b3bf7792fe398cc26ea2d9bd3c6e1af7137107b1528e83e478d24bf
+SIZE (Graphics-Primitive-0.26.tar.gz) = 41483
diff --git a/graphics/p5-Graphics-Primitive/pkg-descr b/graphics/p5-Graphics-Primitive/pkg-descr
new file mode 100644
index 000000000000..eb010f40bff3
--- /dev/null
+++ b/graphics/p5-Graphics-Primitive/pkg-descr
@@ -0,0 +1,6 @@
+Graphics::Primitive is library agnostic system for drawing things.
+
+The idea is to allow you to create and manipulate graphical components and
+then pass them off to a Driver for actual drawing.
+
+WWW: http://search.cpan.org/dist/Graphics-Primitive/
diff --git a/graphics/p5-Graphics-Primitive/pkg-plist b/graphics/p5-Graphics-Primitive/pkg-plist
new file mode 100644
index 000000000000..87683b1fd8fb
--- /dev/null
+++ b/graphics/p5-Graphics-Primitive/pkg-plist
@@ -0,0 +1,29 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Primitive/.packlist
+%%SITE_PERL%%/Graphics/Primitive.pm
+%%SITE_PERL%%/Graphics/Primitive/Aligned.pm
+%%SITE_PERL%%/Graphics/Primitive/Border.pm
+%%SITE_PERL%%/Graphics/Primitive/Brush.pm
+%%SITE_PERL%%/Graphics/Primitive/Canvas.pm
+%%SITE_PERL%%/Graphics/Primitive/Component.pm
+%%SITE_PERL%%/Graphics/Primitive/ComponentList.pm
+%%SITE_PERL%%/Graphics/Primitive/Container.pm
+%%SITE_PERL%%/Graphics/Primitive/Driver.pm
+%%SITE_PERL%%/Graphics/Primitive/Font.pm
+%%SITE_PERL%%/Graphics/Primitive/Image.pm
+%%SITE_PERL%%/Graphics/Primitive/Insets.pm
+%%SITE_PERL%%/Graphics/Primitive/Operation
+%%SITE_PERL%%/Graphics/Primitive/Operation.pm
+%%SITE_PERL%%/Graphics/Primitive/Operation/Fill.pm
+%%SITE_PERL%%/Graphics/Primitive/Operation/Stroke.pm
+%%SITE_PERL%%/Graphics/Primitive/Oriented.pm
+%%SITE_PERL%%/Graphics/Primitive/Paint.pm
+%%SITE_PERL%%/Graphics/Primitive/Paint/Gradient.pm
+%%SITE_PERL%%/Graphics/Primitive/Paint/Solid.pm
+%%SITE_PERL%%/Graphics/Primitive/Path.pm
+%%SITE_PERL%%/Graphics/Primitive/TextBox.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Primitive
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics
+@dirrmtry %%SITE_PERL%%/Graphics/Primitive/Paint
+@dirrmtry %%SITE_PERL%%/Graphics/Primitive/Operation
+@dirrmtry %%SITE_PERL%%/Graphics/Primitive
+@dirrmtry %%SITE_PERL%%/Graphics