aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Image-Imlib2
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-07-01 14:10:32 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-07-01 14:10:32 +0000
commitf1f501be8599bc5b107fffbcd820559a28e59da6 (patch)
tree867900d7e2977fb180d5c4076f0ed0a5b2ab5095 /graphics/p5-Image-Imlib2
parent8a05cc7d643efe1c2707c09ffc1b1f1b139b07c8 (diff)
downloadports-f1f501be8599bc5b107fffbcd820559a28e59da6.tar.gz
ports-f1f501be8599bc5b107fffbcd820559a28e59da6.zip
Compensate for braindead xsubpp in 5.005_03. Now it actually
works correctly with older perls. While at it, assign maintainership to perl@, it should deal with this port better than ports@.
Notes
Notes: svn path=/head/; revision=112669
Diffstat (limited to 'graphics/p5-Image-Imlib2')
-rw-r--r--graphics/p5-Image-Imlib2/Makefile3
-rw-r--r--graphics/p5-Image-Imlib2/files/patch-Imlib2.xs62
2 files changed, 64 insertions, 1 deletions
diff --git a/graphics/p5-Image-Imlib2/Makefile b/graphics/p5-Image-Imlib2/Makefile
index abe2b493b692..ad5d07514978 100644
--- a/graphics/p5-Image-Imlib2/Makefile
+++ b/graphics/p5-Image-Imlib2/Makefile
@@ -7,12 +7,13 @@
PORTNAME= Image-Imlib2
PORTVERSION= 1.02
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Image
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to the Imlib2 image library
LIB_DEPENDS= Imlib2.2:${PORTSDIR}/graphics/imlib2
diff --git a/graphics/p5-Image-Imlib2/files/patch-Imlib2.xs b/graphics/p5-Image-Imlib2/files/patch-Imlib2.xs
new file mode 100644
index 000000000000..43f7736bcc9e
--- /dev/null
+++ b/graphics/p5-Image-Imlib2/files/patch-Imlib2.xs
@@ -0,0 +1,62 @@
+--- lib/Image/Imlib2.xs.orig Thu Jul 1 15:44:07 2004
++++ lib/Image/Imlib2.xs Thu Jul 1 15:45:10 2004
+@@ -473,7 +473,8 @@
+ imlib_image_draw_polygon(poly,closed);
+ }
+
+-void Imlib2_fill_color_range_rectangle(image, cr, x, y, width, height, angle)
++void
++Imlib2_fill_color_range_rectangle(image, cr, x, y, width, height, angle)
+ Image::Imlib2 image
+ Image::Imlib2::ColorRange cr
+ int x
+@@ -496,7 +497,8 @@
+ }
+
+
+-void Imlib2_image_orientate(image, steps)
++void
++Imlib2_image_orientate(image, steps)
+ Image::Imlib2 image
+ int steps
+
+@@ -509,7 +511,8 @@
+ imlib_image_orientate(steps);
+ }
+
+-void Imlib2_image_set_format(image, format)
++void
++Imlib2_image_set_format(image, format)
+ Image::Imlib2 image
+ char * format
+ PROTOTYPE: $$
+@@ -519,7 +522,8 @@
+ imlib_image_set_format(format);
+ }
+
+-Image::Imlib2 Imlib2_create_scaled_image(image, dw, dh)
++Image::Imlib2
++Imlib2_create_scaled_image(image, dw, dh)
+ Image::Imlib2 image
+ int dw
+ int dh
+@@ -625,7 +629,8 @@
+ OUTPUT:
+ RETVAL
+
+-void Imlib2_ColorRange_DESTROY(cr)
++void
++Imlib2_ColorRange_DESTROY(cr)
+ Image::Imlib2::ColorRange cr
+
+ PROTOTYPE: $
+@@ -639,7 +644,8 @@
+ imlib_context_set_color_range(oldcr);
+ }
+
+-void Imlib2_ColorRange_add_color(cr, d, r, g, b, a)
++void
++Imlib2_ColorRange_add_color(cr, d, r, g, b, a)
+ Image::Imlib2::ColorRange cr
+ int d
+ int r