aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Image-PNG-QRCode
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2018-07-27 17:47:35 +0000
committerDan Langille <dvl@FreeBSD.org>2018-07-27 17:47:35 +0000
commit065cb3258fe2f97f3c174822af606a5c596b2085 (patch)
treefef37423432ab455a8c8f8a258646bdef7d50a4d /graphics/p5-Image-PNG-QRCode
parent6a656e70f585fd385cffe6418dafb6fcefa56716 (diff)
downloadports-065cb3258fe2f97f3c174822af606a5c596b2085.tar.gz
ports-065cb3258fe2f97f3c174822af606a5c596b2085.zip
New port: graphics/p5-Image-PNG-QRCode
make a PNG image containing a QR code from text This module converts input text to a PNG image of a QR code containing the text. The PNG image can either be stored to a file or it can be a scalar. Image::PNG::Libpng requires "libpng" to be installed. "libpng" should already be installed on most Linux and Windows systems.
Notes
Notes: svn path=/head/; revision=475449
Diffstat (limited to 'graphics/p5-Image-PNG-QRCode')
-rw-r--r--graphics/p5-Image-PNG-QRCode/Makefile27
-rw-r--r--graphics/p5-Image-PNG-QRCode/distinfo3
-rw-r--r--graphics/p5-Image-PNG-QRCode/pkg-descr17
-rw-r--r--graphics/p5-Image-PNG-QRCode/pkg-plist5
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/p5-Image-PNG-QRCode/Makefile b/graphics/p5-Image-PNG-QRCode/Makefile
new file mode 100644
index 000000000000..e09367e1c7fe
--- /dev/null
+++ b/graphics/p5-Image-PNG-QRCode/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= Image-PNG-QRCode
+DISTVERSION= 0.09
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= Make a PNG image containing a QR code from text
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libpng.so:graphics/png
+
+RUN_DEPENDS+= p5-Carp>0:devel/p5-Carp
+RUN_DEPENDS+= p5-Exporter>0:devel/p5-Exporter
+RUN_DEPENDS+= p5-XSLoader>0:devel/p5-XSLoader
+
+USES= perl5
+USE_PERL5= configure
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|INC => $$vars->{inc}|INC => "-I${LOCALBASE}/include"|g' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-PNG-QRCode/distinfo b/graphics/p5-Image-PNG-QRCode/distinfo
new file mode 100644
index 000000000000..4814c59f8ae3
--- /dev/null
+++ b/graphics/p5-Image-PNG-QRCode/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532703987
+SHA256 (Image-PNG-QRCode-0.09.tar.gz) = 2016646694d707687fc282e5d07b8dd0b21bb468742ea3f4d33bbcdc9ba0962b
+SIZE (Image-PNG-QRCode-0.09.tar.gz) = 68632
diff --git a/graphics/p5-Image-PNG-QRCode/pkg-descr b/graphics/p5-Image-PNG-QRCode/pkg-descr
new file mode 100644
index 000000000000..58bcb74d6a86
--- /dev/null
+++ b/graphics/p5-Image-PNG-QRCode/pkg-descr
@@ -0,0 +1,17 @@
+This module converts input text to a PNG image of a QR code containing the
+text. The PNG image can either be stored to a file or it can be a scalar.
+
+Image::PNG::Libpng requires "libpng" to be installed. "libpng" should
+already be installed on most Linux and Windows systems.
+
+This example makes a data URL QR code:
+
+use Image::PNG::QRCode 'qrpng';
+use URI;
+my $data = 'abcdefghijklmnopqrstuvwxyz';
+my $u = URI->new ('data:');
+$u->media_type ('image/png');
+$u->data (qrpng (text => $data));
+print "<img src='$u'>\n";
+
+WWW: https://metacpan.org/pod/Image::PNG::QRCode
diff --git a/graphics/p5-Image-PNG-QRCode/pkg-plist b/graphics/p5-Image-PNG-QRCode/pkg-plist
new file mode 100644
index 000000000000..56fe7ee75eb8
--- /dev/null
+++ b/graphics/p5-Image-PNG-QRCode/pkg-plist
@@ -0,0 +1,5 @@
+bin/qrpng
+%%SITE_ARCH%%/Image/PNG/QRCode.pm
+%%SITE_ARCH%%/Image/PNG/QRCode.pod
+%%SITE_ARCH%%/auto/Image/PNG/QRCode/QRCode.so
+%%PERL5_MAN3%%/Image::PNG::QRCode.3.gz