aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-OpenGL
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-06 20:27:42 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-06 20:27:42 +0000
commita7fb7328a9d9f71af79cb3e6d82f1e2945207bb0 (patch)
tree7d0400af0043885e6bb204344e9858a2c2a4cd77 /graphics/p5-OpenGL
parent27f74870e70ce0e2322159f35cd75e0c7c5084a7 (diff)
downloadports-a7fb7328a9d9f71af79cb3e6d82f1e2945207bb0.tar.gz
ports-a7fb7328a9d9f71af79cb3e6d82f1e2945207bb0.zip
add p5-OpenGL 0.54
Perl module to display 3D data using OpenGL, GLU, GLUT, and GLX
Notes
Notes: svn path=/head/; revision=72644
Diffstat (limited to 'graphics/p5-OpenGL')
-rw-r--r--graphics/p5-OpenGL/Makefile24
-rw-r--r--graphics/p5-OpenGL/distinfo1
-rw-r--r--graphics/p5-OpenGL/files/patch-Makefile.PL11
-rw-r--r--graphics/p5-OpenGL/pkg-comment1
-rw-r--r--graphics/p5-OpenGL/pkg-descr4
-rw-r--r--graphics/p5-OpenGL/pkg-plist6
6 files changed, 47 insertions, 0 deletions
diff --git a/graphics/p5-OpenGL/Makefile b/graphics/p5-OpenGL/Makefile
new file mode 100644
index 000000000000..7dd02b14cad7
--- /dev/null
+++ b/graphics/p5-OpenGL/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# Ports collection makefile for: p5-OpenGL
+# Date created: Jan 7, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= OpenGL
+PORTVERSION= 0.54
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/I/IL/ILYAZ/modules
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+USE_MESA= yes
+
+post-patch:
+ @${PERL} -pi -e "s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g" ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-OpenGL/distinfo b/graphics/p5-OpenGL/distinfo
new file mode 100644
index 000000000000..9da1abb5eeff
--- /dev/null
+++ b/graphics/p5-OpenGL/distinfo
@@ -0,0 +1 @@
+MD5 (OpenGL-0.54.tar.gz) = ff53886f6fc0d81ddde0e40725c8e33b
diff --git a/graphics/p5-OpenGL/files/patch-Makefile.PL b/graphics/p5-OpenGL/files/patch-Makefile.PL
new file mode 100644
index 000000000000..acfd539ac55c
--- /dev/null
+++ b/graphics/p5-OpenGL/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Wed Jun 20 16:39:13 2001
++++ Makefile.PL Thu Oct 10 22:51:15 2002
+@@ -17,7 +17,7 @@
+
+ $pm_lib = (grep /^X11$/, @ARGV) ? '' : '-lopengl';
+
+-$libs = "-lGLU -lGLUT -lGLX $pm_lib -lMesaGLU -lMesaGLUT -lMesaGLX -lglut";
++$libs = "-lglut %%PTHREAD_LIBS%%";
+
+ @libs = findlib->ext("$libdirs $libs");
+
diff --git a/graphics/p5-OpenGL/pkg-comment b/graphics/p5-OpenGL/pkg-comment
new file mode 100644
index 000000000000..53211e4fc253
--- /dev/null
+++ b/graphics/p5-OpenGL/pkg-comment
@@ -0,0 +1 @@
+Perl module to display 3D data using OpenGL, GLU, GLUT, and GLX
diff --git a/graphics/p5-OpenGL/pkg-descr b/graphics/p5-OpenGL/pkg-descr
new file mode 100644
index 000000000000..57c4bad5a234
--- /dev/null
+++ b/graphics/p5-OpenGL/pkg-descr
@@ -0,0 +1,4 @@
+This module provides access to most of the OpenGL 1.0, 1.1, and 1.2 APIs.
+Some amount of GLU is supported (I'm not quite sure what version it works
+out to), and GLUT should be completely supported up to API version 3. A
+small portion of GLX and X11 is supported, as an alternative to GLUT.
diff --git a/graphics/p5-OpenGL/pkg-plist b/graphics/p5-OpenGL/pkg-plist
new file mode 100644
index 000000000000..330b9eaac86a
--- /dev/null
+++ b/graphics/p5-OpenGL/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/OpenGL.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/OpenGL.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/OpenGL.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL