aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-OpenGL
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /graphics/p5-OpenGL
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'graphics/p5-OpenGL')
-rw-r--r--graphics/p5-OpenGL/Makefile2
-rw-r--r--graphics/p5-OpenGL/pkg-plist15
2 files changed, 8 insertions, 9 deletions
diff --git a/graphics/p5-OpenGL/Makefile b/graphics/p5-OpenGL/Makefile
index 0cbfaab72217..e16bc22862cd 100644
--- a/graphics/p5-OpenGL/Makefile
+++ b/graphics/p5-OpenGL/Makefile
@@ -3,7 +3,7 @@
PORTNAME= OpenGL
PORTVERSION= 0.66
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:CHM
diff --git a/graphics/p5-OpenGL/pkg-plist b/graphics/p5-OpenGL/pkg-plist
index 48fe136a09ec..ff0f1e50ef04 100644
--- a/graphics/p5-OpenGL/pkg-plist
+++ b/graphics/p5-OpenGL/pkg-plist
@@ -1,11 +1,10 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/OpenGL.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/OpenGL.pod
-%%SITE_PERL%%/%%PERL_ARCH%%/OpenGL/Array.pod
-%%SITE_PERL%%/%%PERL_ARCH%%/OpenGL/Config.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/OpenGL/Tessellation.pod
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/OpenGL.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenGL/autosplit.ix
+%%SITE_ARCH%%/OpenGL.pm
+%%SITE_ARCH%%/OpenGL.pod
+%%SITE_ARCH%%/OpenGL/Array.pod
+%%SITE_ARCH%%/OpenGL/Config.pm
+%%SITE_ARCH%%/OpenGL/Tessellation.pod
+%%SITE_ARCH%%/auto/OpenGL/OpenGL.so
+%%SITE_ARCH%%/auto/OpenGL/autosplit.ix
%%PERL5_MAN3%%/Array.3.gz
%%PERL5_MAN3%%/OpenGL.3.gz
%%PERL5_MAN3%%/Tessellation.3.gz