aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-SWF-File
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-05-20 10:50:01 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-05-20 10:50:01 +0000
commit05dc097def15a05420c9a279f25673495c8629ca (patch)
tree62c8e17efb5b14cab412d7b529da66308d2705c8 /graphics/p5-SWF-File
parent9bd89d3ca4b9c4d1dbeec7f633268a3e2e8db3dc (diff)
downloadports-05dc097def15a05420c9a279f25673495c8629ca.tar.gz
ports-05dc097def15a05420c9a279f25673495c8629ca.zip
Add p5-SWF-File 0.22, manipulating Flash movie (SWF) files.
Notes
Notes: svn path=/head/; revision=81541
Diffstat (limited to 'graphics/p5-SWF-File')
-rw-r--r--graphics/p5-SWF-File/Makefile34
-rw-r--r--graphics/p5-SWF-File/distinfo1
-rw-r--r--graphics/p5-SWF-File/pkg-descr10
-rw-r--r--graphics/p5-SWF-File/pkg-plist15
4 files changed, 60 insertions, 0 deletions
diff --git a/graphics/p5-SWF-File/Makefile b/graphics/p5-SWF-File/Makefile
new file mode 100644
index 000000000000..5e968b77f8f8
--- /dev/null
+++ b/graphics/p5-SWF-File/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: SWF-File
+# Date created: 20 May 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SWF-File
+PORTVERSION= 0.22
+CATEGORIES= graphics www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/Y/YS/YSAS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Manipulating Flash movie (SWF) files
+
+BUILD_DEPENDS= ${SITE_PERL}/Data/TemporaryBag.pm:${PORTSDIR}/devel/p5-Data-TemporaryBag
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SWF::BinStream.3 SWF::BinStream::Codec.3 \
+ SWF::BinStream::Codec::Zlib.3 SWF::BinStream::File.3 \
+ SWF::Element.3 SWF::File.3 SWF::Parser.3
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f |\
+ ${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//'
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-SWF-File/distinfo b/graphics/p5-SWF-File/distinfo
new file mode 100644
index 000000000000..beaba196f48c
--- /dev/null
+++ b/graphics/p5-SWF-File/distinfo
@@ -0,0 +1 @@
+MD5 (SWF-File-0.22.tar.gz) = 34fdcb70debfe9d87ab24a6743027289
diff --git a/graphics/p5-SWF-File/pkg-descr b/graphics/p5-SWF-File/pkg-descr
new file mode 100644
index 000000000000..682f0355a072
--- /dev/null
+++ b/graphics/p5-SWF-File/pkg-descr
@@ -0,0 +1,10 @@
+SWF modules are manipulating Macromedia Flash movie (SWF) files.
+This package contains:
+
+SWF::File module can be used to make SWF movie.
+SWF::Parser module provides a parser for SWF file.
+
+WWW: http://search.cpan.org/dist/SWF-File/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/graphics/p5-SWF-File/pkg-plist b/graphics/p5-SWF-File/pkg-plist
new file mode 100644
index 000000000000..3a0c9e6d0bc3
--- /dev/null
+++ b/graphics/p5-SWF-File/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/File/.packlist
+bin/dumpswf.plx
+%%SITE_PERL%%/SWF/BinStream.pm
+%%SITE_PERL%%/SWF/BinStream/Codec.pod
+%%SITE_PERL%%/SWF/BinStream/Codec/Zlib.pm
+%%SITE_PERL%%/SWF/BinStream/File.pm
+%%SITE_PERL%%/SWF/Element.pm
+%%SITE_PERL%%/SWF/Element.pod
+%%SITE_PERL%%/SWF/File.pm
+%%SITE_PERL%%/SWF/Parser.pm
+@dirrm %%SITE_PERL%%/SWF/BinStream/Codec
+@dirrm %%SITE_PERL%%/SWF/BinStream
+@unexec rmdir %D/%%SITE_PERL%%/SWF 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/File
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF 2>/dev/null || true