aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-ming
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /graphics/p5-ming
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403913
Diffstat (limited to 'graphics/p5-ming')
-rw-r--r--graphics/p5-ming/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/p5-ming/Makefile b/graphics/p5-ming/Makefile
index 658bde4fc54f..a87e533f20df 100644
--- a/graphics/p5-ming/Makefile
+++ b/graphics/p5-ming/Makefile
@@ -24,7 +24,8 @@ OPTIONS_DEFINE= EXAMPLES
CONFIGURE_ARGS= --enable-perl
GNU_CONFIGURE= yes
-USES= autoreconf bison gmake libtool localbase perl5
+USES= autoreconf bison gmake libtool localbase perl5 shebangfix
+SHEBANG_FILES= examples/*.cgi
PORTEXAMPLES= *
@@ -39,7 +40,6 @@ post-patch:
@${REINPLACE_CMD} -e '/ming_is_compiled()/ s|^|#|; /LIBS/d' ${WRKSRC}/Makefile.PL
@${REINPLACE_CMD} -e 's|\.3pm|.3|g' ${WRKSRC}/Makefile.PL ${WRKSRC}/mkdoc
@${REINPLACE_CMD} -e 's|GvCV(\(.*\)) = \(.*\);|GvCV_set(\1, \2);|' ${WRKSRC}/Exports.c
- @${REINPLACE_CMD} -e '1 s|/usr/bin/perl|${PERL}|' ${WRKSRC}/examples/*.cgi
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/SWF/SWF.so