aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-ming
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-15 07:47:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-15 07:47:04 +0000
commite02e79b5b4e5f8316109f17448c983935c2f6b7f (patch)
tree2f1d33326a03faffadd4159d11ca8a689c85fc98 /graphics/p5-ming
parentcc61336dab963bd883130808553972a7ab291f6e (diff)
downloadports-e02e79b5b4e5f8316109f17448c983935c2f6b7f.tar.gz
ports-e02e79b5b4e5f8316109f17448c983935c2f6b7f.zip
- Update to 0.4.4
- Fix build with Perl 5.14 - Remove distinfo: no need for a slave port - Take maintainership Changes: https://github.com/libming/libming/blob/master/NEWS
Notes
Notes: svn path=/head/; revision=291423
Diffstat (limited to 'graphics/p5-ming')
-rw-r--r--graphics/p5-ming/Makefile95
-rw-r--r--graphics/p5-ming/distinfo4
-rw-r--r--graphics/p5-ming/files/patch-Makefile.PL4
-rw-r--r--graphics/p5-ming/files/patch-Makefile.in6
-rw-r--r--graphics/p5-ming/files/patch-perl_swf.h12
-rw-r--r--graphics/p5-ming/pkg-plist28
6 files changed, 85 insertions, 64 deletions
diff --git a/graphics/p5-ming/Makefile b/graphics/p5-ming/Makefile
index d6a8633f7c0d..2a955b52813e 100644
--- a/graphics/p5-ming/Makefile
+++ b/graphics/p5-ming/Makefile
@@ -9,52 +9,65 @@ PORTNAME= ming
PORTREVISION= 0
CATEGORIES= graphics perl5
PKGNAMEPREFIX= p5-
-PKGNAMESUFFIX=
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Perl5 module for Ming which allows you to create Flash 4/5 movies
-SLAVE_PORT= p5
-MASTERDIR= ${.CURDIR}/../../graphics/ming
-PLIST= ${.CURDIR}/pkg-plist
-CONFIGURE_ARGS+= --enable-perl
-INSTALL_WRKSRC= ${WRKSRC}/perl_ext
+CONFIGURE_ARGS= --enable-perl
+INSTALL_WRKSRC= ${WRKSRC}/perl_ext
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+PATCH_WRKSRC= ${WRKSRC}/perl_ext
PATCHDIR= ${.CURDIR}/files
+PLIST= ${.CURDIR}/pkg-plist
USE_PERL5= yes
-MAN3= SWF.3 \
- SWF::Action.3 \
- SWF::BinaryData.3 \
- SWF::Bitmap.3 \
- SWF::Blur.3 \
- SWF::BrowserFont.3 \
- SWF::Button.3 \
- SWF::ButtonRecord.3 \
- SWF::CXform.3 \
- SWF::Character.3 \
- SWF::Constants.3 \
- SWF::DisplayItem.3 \
- SWF::Fill.3 \
- SWF::Filter.3 \
- SWF::FilterMatrix.3 \
- SWF::Font.3 \
- SWF::FontCharacter.3 \
- SWF::FontCollection.3 \
- SWF::Gradient.3 \
- SWF::InitAction.3 \
- SWF::Matrix.3 \
- SWF::Morph.3 \
- SWF::Movie.3 \
- SWF::MovieClip.3 \
- SWF::PrebuiltClip.3 \
- SWF::Shadow.3 \
- SWF::Shape.3 \
- SWF::Sound.3 \
- SWF::SoundInstance.3 \
- SWF::SoundStream.3 \
- SWF::Sprite.3 \
- SWF::Text.3 \
- SWF::TextField.3 \
- SWF::VideoStream.3
+MASTERDIR= ${.CURDIR}/../../graphics/ming
+SLAVEPORT= p5
+
+MAN3= SWF.3 \
+ SWF::Action.3 \
+ SWF::BinaryData.3 \
+ SWF::Bitmap.3 \
+ SWF::Blur.3 \
+ SWF::BrowserFont.3 \
+ SWF::Button.3 \
+ SWF::ButtonRecord.3 \
+ SWF::CXform.3 \
+ SWF::Character.3 \
+ SWF::Constants.3 \
+ SWF::DisplayItem.3 \
+ SWF::Fill.3 \
+ SWF::Filter.3 \
+ SWF::FilterMatrix.3 \
+ SWF::Font.3 \
+ SWF::FontCharacter.3 \
+ SWF::FontCollection.3 \
+ SWF::Gradient.3 \
+ SWF::InitAction.3 \
+ SWF::Matrix.3 \
+ SWF::Morph.3 \
+ SWF::Movie.3 \
+ SWF::MovieClip.3 \
+ SWF::PrebuiltClip.3 \
+ SWF::Shadow.3 \
+ SWF::Shape.3 \
+ SWF::Sound.3 \
+ SWF::SoundInstance.3 \
+ SWF::SoundStream.3 \
+ SWF::Sprite.3 \
+ SWF::Text.3 \
+ SWF::TextField.3 \
+ SWF::VideoStream.3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\.3pm|.3|g' ${PATCH_WRKSRC}/Makefile.PL ${PATCH_WRKSRC}/mkdoc
+ @${REINPLACE_CMD} -e 's|GvCV(\(.*\)) = \(.*\);|GvCV_set(\1, \2);|' ${PATCH_WRKSRC}/Exports.c
+ @${REINPLACE_CMD} -e '1 s|/usr/bin/perl|${PERL}|' ${PATCH_WRKSRC}/examples/*.cgi
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}/
+ cd ${INSTALL_WRKSRC}/examples/ && ${INSTALL_DATA} *.cgi ${EXAMPLESDIR}/
+.endif
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/p5-ming/distinfo b/graphics/p5-ming/distinfo
deleted file mode 100644
index 03ee73b1f621..000000000000
--- a/graphics/p5-ming/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-SHA256 (ming-0.3.0.tar.gz) = 820afbafc8697dabb34415eb86b2c589625449709f4434446c323c4d14391cd9
-SIZE (ming-0.3.0.tar.gz) = 287330
-SHA256 (ming-perl-0.3.0.tar.gz) = 44bbcec7f41f33fcf402d0e43bdf7aa61d567ab098247f114674a8786d98e2b5
-SIZE (ming-perl-0.3.0.tar.gz) = 49783
diff --git a/graphics/p5-ming/files/patch-Makefile.PL b/graphics/p5-ming/files/patch-Makefile.PL
index 85e3a921e587..7ef2bf8160c1 100644
--- a/graphics/p5-ming/files/patch-Makefile.PL
+++ b/graphics/p5-ming/files/patch-Makefile.PL
@@ -1,5 +1,5 @@
---- perl_ext/Makefile.PL.orig 2011-08-07 14:41:33.558563705 -0400
-+++ perl_ext/Makefile.PL 2011-08-07 14:44:13.341563378 -0400
+--- Makefile.PL.orig 2011-10-26 14:33:18.000000000 +0800
++++ Makefile.PL 2011-11-20 17:28:21.555225857 +0800
@@ -146,11 +146,9 @@
clean => {
FILES => "@do_clean",
diff --git a/graphics/p5-ming/files/patch-Makefile.in b/graphics/p5-ming/files/patch-Makefile.in
index 5d6451da783e..410714cc29ce 100644
--- a/graphics/p5-ming/files/patch-Makefile.in
+++ b/graphics/p5-ming/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- perl_ext/Makefile.in.orig 2011-08-07 21:32:30.000000000 +0000
-+++ perl_ext/Makefile.in 2011-08-07 21:32:48.000000000 +0000
-@@ -391,7 +391,7 @@
+--- Makefile.in.orig 2011-10-26 15:30:21.000000000 +0800
++++ Makefile.in 2011-11-20 17:27:39.085225614 +0800
+@@ -431,7 +431,7 @@
$(MAKE) -f Makefile.perl
install: Makefile.perl
diff --git a/graphics/p5-ming/files/patch-perl_swf.h b/graphics/p5-ming/files/patch-perl_swf.h
new file mode 100644
index 000000000000..d8fe92d25b44
--- /dev/null
+++ b/graphics/p5-ming/files/patch-perl_swf.h
@@ -0,0 +1,12 @@
+--- perl_swf.h.orig 2011-10-26 14:33:18.000000000 +0800
++++ perl_swf.h 2011-11-20 18:01:38.397227987 +0800
+@@ -66,5 +66,9 @@
+ void swf_stash_refcnt_inc(SV *sv_key, SV *sv_value);
+ void swf_stash_refcnt_dec(SV *sv_key);
+
++#ifndef GvCV_set
++#define GvCV_set(gv, cv) (GvCV(gv) = cv)
++#endif
++
+ #endif /* PERL_SWF_H_INCLUDED */
+
diff --git a/graphics/p5-ming/pkg-plist b/graphics/p5-ming/pkg-plist
index 15d70062f473..723e9f81a77e 100644
--- a/graphics/p5-ming/pkg-plist
+++ b/graphics/p5-ming/pkg-plist
@@ -35,19 +35,19 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/SWF.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/SWF.so
-%%PORTDOCS%%%%EXAMPLESDIR%%/action.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/alphafill.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/animation.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/glyph.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/jpegfill.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/keypress.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/morph.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/shape.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/sound.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/sprite.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/text.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/textfield.cgi
-%%PORTDOCS%%%%EXAMPLESDIR%%/video.cgi
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/action.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/alphafill.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/glyph.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jpegfill.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/keypress.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morph.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shape.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sound.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sprite.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textfield.cgi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/video.cgi
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/SWF