aboutsummaryrefslogtreecommitdiff
path: root/graphics/partio
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-12-04 07:30:31 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-12-04 07:30:31 +0000
commit53b147910f9c0b867bc80b24f68f69c7d447cd22 (patch)
tree5473049ff042cd1c1bfdb054776b5061a5f6734e /graphics/partio
parent8bc091981154d39883bc8a0134e1519b620fbbcd (diff)
Notes
Diffstat (limited to 'graphics/partio')
-rw-r--r--graphics/partio/Makefile21
-rw-r--r--graphics/partio/distinfo6
2 files changed, 19 insertions, 8 deletions
diff --git a/graphics/partio/Makefile b/graphics/partio/Makefile
index 62889ed2bee2..0daf8762e1a5 100644
--- a/graphics/partio/Makefile
+++ b/graphics/partio/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= partio
-PORTVERSION= 1.13.0
+PORTVERSION= 1.13.2
DISTVERSIONPREFIX= v
CATEGORIES= graphics math
@@ -23,7 +23,11 @@ USE_XORG= xi xmu
USE_GITHUB= yes
GH_ACCOUNT= wdas
-OPTIONS_DEFINE= DOCS DOXYGEN EXAMPLES
+PORTDOCS= *
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= DOCS DOXYGEN EXAMPLES PYQT
+PYQT_DESC= Install PyQt-based auxiliary tools
# DOCS must be selected for PORTDOCS to work
DOXYGEN_IMPLIES= DOCS
@@ -32,12 +36,16 @@ DOXYGEN_ALL_TARGET= all doc
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
-PORTDOCS= *
-PORTEXAMPLES= *
+PYQT_USES= pyqt:5 python
+PYQT_USE= PYQT=core,gui,widgets
+PYQT_PLIST_FILES= bin/partinspect
post-patch:
@${REINPLACE_CMD} -e 's,OpenGL::OpenGL,$${OPENGL_LIBRARIES},' \
${WRKSRC}/src/tools/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's,^from Qt,from PyQt5,' \
+ ${WRKSRC}/src/tools/partinspect.py
+ @${REINPLACE_CMD} -e '/^install/d' ${WRKSRC}/src/tests/CMakeLists.txt
post-patch-DOCS-off:
@${REINPLACE_CMD} -e '/add_subdirectory(src\/doc)/d' \
@@ -45,7 +53,7 @@ post-patch-DOCS-off:
# Remove those files that don't yet work
post-install:
- ${RM} ${STAGEDIR}${PREFIX}/bin/partedit ${STAGEDIR}${PREFIX}/bin/partinspect
+ ${RM} ${STAGEDIR}${PREFIX}/bin/partedit
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -55,4 +63,7 @@ post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/src/data && ${INSTALL_DATA} * ${STAGEDIR}${EXAMPLESDIR}
+post-install-PYQT-off:
+ cd ${STAGEDIR}${PREFIX} && ${RM} ${PYQT_PLIST_FILES}
+
.include <bsd.port.mk>
diff --git a/graphics/partio/distinfo b/graphics/partio/distinfo
index a360fd3c5576..202eedbf46ca 100644
--- a/graphics/partio/distinfo
+++ b/graphics/partio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598285132
-SHA256 (wdas-partio-v1.13.0_GH0.tar.gz) = a894f2edee2f6c5b186c7563e2f96bb778c71346667c78e0f67583233cd7f3d6
-SIZE (wdas-partio-v1.13.0_GH0.tar.gz) = 333259
+TIMESTAMP = 1600362217
+SHA256 (wdas-partio-v1.13.2_GH0.tar.gz) = c03cd4880eb9562d655b47fe2cf525856babafab884897c9b78f1817edfcca35
+SIZE (wdas-partio-v1.13.2_GH0.tar.gz) = 335102