aboutsummaryrefslogtreecommitdiff
path: root/graphics/pcl-pointclouds/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-24 08:12:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-24 08:14:57 +0000
commit7406d45d49bb84c8062dbc56845622c0ddbaf791 (patch)
tree417d67c3665e728f9666271ae4377d834587d500 /graphics/pcl-pointclouds/Makefile
parent39955faf6ead97567917837d75d10b96e59a86ee (diff)
downloadports-7406d45d49bb84c8062dbc56845622c0ddbaf791.tar.gz
ports-7406d45d49bb84c8062dbc56845622c0ddbaf791.zip
math/vtk9: Update 9.1.0 -> 9.2.2
Diffstat (limited to 'graphics/pcl-pointclouds/Makefile')
-rw-r--r--graphics/pcl-pointclouds/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/pcl-pointclouds/Makefile b/graphics/pcl-pointclouds/Makefile
index 00511605899e..0b5962b04a65 100644
--- a/graphics/pcl-pointclouds/Makefile
+++ b/graphics/pcl-pointclouds/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pcl
DISTVERSION= 1.12.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics math
MASTER_SITES= https://github.com/PointCloudLibrary/${PORTNAME}/releases/download/${PORTNAME}-${DISTVERSION}/
PKGNAMESUFFIX= -pointclouds
@@ -59,7 +59,7 @@ PLIST_SUB= SHL3=${DISTVERSION} SHL2=${DISTVERSION:R}
DATADIR= ${PREFIX}/share/${PORTNAME}-${DISTVERSION:R} # match the directory where the project installs .cmake files
OPTIONS_DEFINE= OPENGL PNG QHULL QT5 VTK
-OPTIONS_DEFAULT= PNG # QHULL is disabled due to conflicts qhull8 vs. qhull
+OPTIONS_DEFAULT= PNG VTK # QHULL is disabled due to conflicts qhull8 vs. qhull
OPTIONS_SUB= yes
OPENGL_CMAKE_BOOL= WITH_OPENGL # it finds OpenGL, but no binaries are linked with it: https://github.com/PointCloudLibrary/pcl/issues/2641
@@ -81,7 +81,8 @@ VTK_DESC= Build VTK visualizations
VTK_USES= gl qt:5
VTK_USE= GL=gl,glu QT=core,gui,opengl,widgets,buildtools:build,qmake:build
VTK_CMAKE_BOOL= WITH_VTK
-VTK_CMAKE_ON= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-9.1
-VTK_LIB_DEPENDS= libvtkCommonCore-9.1.so:math/vtk9
+VTK_CMAKE_ON= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-${VTK_VER}
+VTK_LIB_DEPENDS= libvtkCommonCore-${VTK_VER}.so:math/vtk${VTK_VER:R}
+.include <../../math/vtk9/Makefile.version>
.include <bsd.port.mk>