aboutsummaryrefslogtreecommitdiff
path: root/graphics/pcl-pointclouds/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-12 17:50:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-12 17:52:31 +0000
commit7d358135911720a1b8664744348227aa6c7a2989 (patch)
tree2f42dd9b56e83b1bdf412bb30653e58ea6bba926 /graphics/pcl-pointclouds/Makefile
parentac474d8c91b5771c50811fe1493a2b5fa8fbc190 (diff)
downloadports-7d358135911720a1b8664744348227aa6c7a2989.tar.gz
ports-7d358135911720a1b8664744348227aa6c7a2989.zip
graphics/pcl-pointclouds: Correct LIB_DEPENDS
1. For graphics/png, binaries are linked with libpng16.so, not libpng.so. 2. libexpat.so, libtiff.so, libjpeg.so are induced by VTK. PCL doesn't depend on them.
Diffstat (limited to 'graphics/pcl-pointclouds/Makefile')
-rw-r--r--graphics/pcl-pointclouds/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/graphics/pcl-pointclouds/Makefile b/graphics/pcl-pointclouds/Makefile
index d101a789cd15..297a0d9f47c8 100644
--- a/graphics/pcl-pointclouds/Makefile
+++ b/graphics/pcl-pointclouds/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pcl
DISTVERSION= 1.13.1
+PORTREVISION= 1
CATEGORIES= graphics math
MASTER_SITES= https://github.com/PointCloudLibrary/${PORTNAME}/releases/download/${PORTNAME}-${DISTVERSION}/
PKGNAMESUFFIX= -pointclouds
@@ -18,14 +19,12 @@ NOT_FOR_ARCHS= armv6 armv7
NOT_FOR_ARCHS_REASON= common/include/pcl/pcl_macros.h:420:4: error: aligned_malloc not supported on your platform
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
- libexpat.so:textproc/expat2 \
libflann_cpp.so:math/flann \
libfreetype.so:print/freetype2 \
liblz4.so:archivers/liblz4 \
- libpcap.so:net/libpcap \
- libtiff.so:graphics/tiff
+ libpcap.so:net/libpcap
-USES= cmake:testing compiler:c++14-lang eigen:3 jpeg localbase:ldflags python xorg
+USES= cmake:testing compiler:c++14-lang eigen:3 localbase:ldflags python xorg
USE_XORG= x11 xext xt ice sm
USE_LDCONFIG= yes
@@ -55,7 +54,7 @@ OPENGL_USES= gl
OPENGL_USE= GL=gl,glu
PNG_CMAKE_BOOL= WITH_PNG
-PNG_LIB_DEPENDS= libpng.so:graphics/png
+PNG_LIB_DEPENDS= libpng16.so:graphics/png
QHULL_DESC= Include convex-hull operations
QHULL_CMAKE_BOOL= WITH_QHULL