aboutsummaryrefslogtreecommitdiff
path: root/graphics/pcl-pointclouds/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-27 06:42:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-27 06:42:39 +0000
commit93d4c539c9b9060fb4cd99f4e2efda0d4bc2597d (patch)
tree8328c9026e520936cb2525e3e49298000542e912 /graphics/pcl-pointclouds/Makefile
parent5608abf3cc39a567971702d96b60aa8826700c93 (diff)
downloadports-93d4c539c9b9060fb4cd99f4e2efda0d4bc2597d.tar.gz
ports-93d4c539c9b9060fb4cd99f4e2efda0d4bc2597d.zip
graphics/pcl-pointclouds: Fix VTK option and switch to VTK-9.1
Diffstat (limited to 'graphics/pcl-pointclouds/Makefile')
-rw-r--r--graphics/pcl-pointclouds/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/graphics/pcl-pointclouds/Makefile b/graphics/pcl-pointclouds/Makefile
index 2c56b75b7ee6..6c4cbb72addf 100644
--- a/graphics/pcl-pointclouds/Makefile
+++ b/graphics/pcl-pointclouds/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pcl
DISTVERSION= 1.12.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics math
MASTER_SITES= https://github.com/PointCloudLibrary/${PORTNAME}/releases/download/${PORTNAME}-${DISTVERSION}/
PKGNAMESUFFIX= -pointclouds
@@ -69,12 +69,15 @@ QHULL_DESC= Include convex-hull operations
QHULL_CMAKE_BOOL= WITH_QHULL
QHULL_LIB_DEPENDS= libqhull_r.so:math/qhull8
-QT5_CMAKE_BOOL= WITH_QT
+QT5_CMAKE_ON= -DWITH_QT=QT5
+QT5_CMAKE_OFF= -DWITH_QT=NO
QT5_BROKEN= WITH_QT doesn't do anything, should be used by apps, but apps is also broken: see https://github.com/PointCloudLibrary/pcl/issues/2642
-VTK_DESC= Build VTK-Visualizations
+VTK_DESC= Build VTK visualizations
+VTK_USES= gl qt:5
+VTK_USE= GL=gl,glu QT=core,gui,opengl,widgets,buildtools_build,qmake_build
VTK_CMAKE_BOOL= WITH_VTK
-VTK_LIB_DEPENDS= libvtkCommonCore-8.2.so:math/vtk8
-VTK_BROKEN= VTK has missing ompxx symbols: https://gitlab.kitware.com/vtk/vtk/issues/17444
+VTK_CMAKE_ON= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-9.1
+VTK_LIB_DEPENDS= libvtkCommonCore-9.1.so:math/vtk9
.include <bsd.port.mk>