aboutsummaryrefslogtreecommitdiff
path: root/graphics/pcl-pointclouds
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-28 17:29:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-28 17:29:41 +0000
commit3ee3aef4b13fb5d7174bad5481cd38ca13f74afa (patch)
tree7138c061a8202b88c8d5d070bd111c020f0186ba /graphics/pcl-pointclouds
parent402c40fb8997c5311a442ac385a8c36b62183a87 (diff)
downloadports-3ee3aef4b13fb5d7174bad5481cd38ca13f74afa.tar.gz
ports-3ee3aef4b13fb5d7174bad5481cd38ca13f74afa.zip
graphics/pcl-pointclouds: fix build with GCC-based architectures
PR: 236099 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=494167
Diffstat (limited to 'graphics/pcl-pointclouds')
-rw-r--r--graphics/pcl-pointclouds/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/pcl-pointclouds/Makefile b/graphics/pcl-pointclouds/Makefile
index f17ca9f80a74..5d0096ae6294 100644
--- a/graphics/pcl-pointclouds/Makefile
+++ b/graphics/pcl-pointclouds/Makefile
@@ -55,12 +55,16 @@ VTK_CMAKE_BOOL= WITH_VTK
VTK_LIB_DEPENDS= libvtkCommonCore-8.1.so:math/vtk8
VTK_BROKEN= VTK has missing ompxx symbols: https://gitlab.kitware.com/vtk/vtk/issues/17444
+.if !exists(/usr/lib/libstdc++.so)
# use clang from ports because cmake can't find OpenMP with base clang, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=223678
# This should also be an port option, but PCL fails to build w/out OpenMP: https://github.com/PointCloudLibrary/pcl/issues/2638
BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
CPP= clang-cpp${LLVM_DEFAULT}
CC= clang${LLVM_DEFAULT}
CXX= clang++${LLVM_DEFAULT}
+.else
+USE_GCC= yes
+.endif
post-patch: # 10 doesn't have std::sqrt, switching to ::sqrt from math.h
@${GREP} -rl std::sqrt ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e 's|::std::sqrt|::sqrt|g ; s|std::sqrt|::sqrt|g'