aboutsummaryrefslogtreecommitdiff
path: root/graphics/pcl-pointclouds
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-03-08 21:56:36 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-03-08 21:56:36 +0000
commite1d56a9db2541dd41f1907a5a19a686a326831cc (patch)
tree6a5120e4890360e5d98bb4a63ff86cfc80e8392f /graphics/pcl-pointclouds
parent0c69caeef6092fbf32d6330958bbb88f74c02443 (diff)
downloadports-e1d56a9db2541dd41f1907a5a19a686a326831cc.tar.gz
ports-e1d56a9db2541dd41f1907a5a19a686a326831cc.zip
Drop dependency on devel/openmp
- Drop if devel/llvm* was used as a substitute Approved by: yuri, rene (earlier version) Differential Revision: https://reviews.freebsd.org/D23020
Notes
Notes: svn path=/head/; revision=528082
Diffstat (limited to 'graphics/pcl-pointclouds')
-rw-r--r--graphics/pcl-pointclouds/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/graphics/pcl-pointclouds/Makefile b/graphics/pcl-pointclouds/Makefile
index 34b9381254a2..28eb894efa7a 100644
--- a/graphics/pcl-pointclouds/Makefile
+++ b/graphics/pcl-pointclouds/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pcl
DISTVERSIONPREFIX= ${PORTNAME}-
DISTVERSION= 1.10.0
+PORTREVISION= 1
CATEGORIES= graphics math
PKGNAMESUFFIX= -pointclouds
@@ -23,7 +24,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libpcap.so:net/libpcap \
libtiff.so:graphics/tiff
-USES= cmake compiler eigen:3 jpeg python xorg
+USES= cmake compiler:c++14-lang eigen:3 jpeg python xorg
LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= PointCloudLibrary
@@ -59,17 +60,6 @@ VTK_BROKEN= VTK has missing ompxx symbols: https://gitlab.kitware.com/vtk/vtk/i
.include <bsd.port.pre.mk>
-.if ${CHOSEN_COMPILER_TYPE} == clang
-# use clang from ports because cmake can't find OpenMP with base clang, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=223678
-# This should also be an port option, but PCL fails to build w/out OpenMP: https://github.com/PointCloudLibrary/pcl/issues/2638
-BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
-CPP= clang-cpp${LLVM_DEFAULT}
-CC= clang${LLVM_DEFAULT}
-CXX= clang++${LLVM_DEFAULT}
-.else
-USE_GCC= yes
-.endif
-
post-patch: # 10 doesn't have std::sqrt, switching to ::sqrt from math.h
@${GREP} -rl std::sqrt ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e 's|::std::sqrt|::sqrt|g ; s|std::sqrt|::sqrt|g'