aboutsummaryrefslogtreecommitdiff
path: root/graphics/pdfpc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-10-30 14:04:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-10-30 14:04:36 +0000
commit3c862c513007a1302bf025292249523bd8fc02e7 (patch)
tree83c6ea1358dfdf02874985d54c100934f903cceb /graphics/pdfpc
parent48fc012063815228a65ce48f60da3ce813898ada (diff)
downloadports-3c862c513007a1302bf025292249523bd8fc02e7.tar.gz
ports-3c862c513007a1302bf025292249523bd8fc02e7.zip
Update to v4.1
Notes
Notes: svn path=/head/; revision=453176
Diffstat (limited to 'graphics/pdfpc')
-rw-r--r--graphics/pdfpc/Makefile2
-rw-r--r--graphics/pdfpc/distinfo6
-rw-r--r--graphics/pdfpc/files/patch-src_CMakeLists.txt25
3 files changed, 29 insertions, 4 deletions
diff --git a/graphics/pdfpc/Makefile b/graphics/pdfpc/Makefile
index 7e0520d095b3..378746c97d64 100644
--- a/graphics/pdfpc/Makefile
+++ b/graphics/pdfpc/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= pdfpc
-DISTVERSION= 4.0.8-2
+DISTVERSION= 4.1
CATEGORIES= graphics
DISTVERSIONPREFIX= v
diff --git a/graphics/pdfpc/distinfo b/graphics/pdfpc/distinfo
index 0c49473bd032..df7bd7926867 100644
--- a/graphics/pdfpc/distinfo
+++ b/graphics/pdfpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506414416
-SHA256 (pdfpc-pdfpc-v4.0.8-2_GH0.tar.gz) = 5dcd87da548fd1994f97a6b980209c096de0952b375b61524aeb48d2fd3c19a6
-SIZE (pdfpc-pdfpc-v4.0.8-2_GH0.tar.gz) = 91138
+TIMESTAMP = 1509370570
+SHA256 (pdfpc-pdfpc-v4.1_GH0.tar.gz) = aee684cc4b6cd8f2f83196ebd42608b9917104c9b1572985797daf1ae68e5454
+SIZE (pdfpc-pdfpc-v4.1_GH0.tar.gz) = 95802
diff --git a/graphics/pdfpc/files/patch-src_CMakeLists.txt b/graphics/pdfpc/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..cd75fe6bde88
--- /dev/null
+++ b/graphics/pdfpc/files/patch-src_CMakeLists.txt
@@ -0,0 +1,25 @@
+--- src/CMakeLists.txt.orig 2017-10-30 08:51:03 UTC
++++ src/CMakeLists.txt
+@@ -50,8 +50,22 @@ include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+
++link_directories(
++ ${GOBJECT_LIBRARY_DIRS}
++ ${GIO_LIBRARY_DIRS}
++ ${GEE_LIBRARY_DIRS}
++ ${POPPLER_LIBRARY_DIRS}
++ ${GTK_LIBRARY_DIRS}
++ ${GTHREAD_LIBRARY_DIRS}
++ ${PANGOCAIRO_LIBRARY_DIRS}
++ ${GSTREAMER_LIBRARY_DIRS}
++ ${GSTINTERFACES_LIBRARY_DIRS}
++ ${GSTVIDEO_LIBRARY_DIRS}
++)
++
+ if(${WITH_X11})
+ include_directories(${X11_INCLUDE_DIRS})
++ link_directories(${X11_LIBRARY_DIRS})
+ set(ADDITIONAL_LIBS ${X11_LIBRARIES})
+ endif()
+