aboutsummaryrefslogtreecommitdiff
path: root/graphics/pear-Image_Canvas/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-21 20:55:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-21 20:55:43 +0000
commit36a96502fdc61734708b43069bb1d22b971aa0f1 (patch)
tree928b1a418ae68a9018f84a0b14800877dcf75d82 /graphics/pear-Image_Canvas/Makefile
parentc9e533e2d896d9059e57cf5d333737542f90adc8 (diff)
downloadports-36a96502fdc61734708b43069bb1d22b971aa0f1.tar.gz
ports-36a96502fdc61734708b43069bb1d22b971aa0f1.zip
Notes
Diffstat (limited to 'graphics/pear-Image_Canvas/Makefile')
-rw-r--r--graphics/pear-Image_Canvas/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/graphics/pear-Image_Canvas/Makefile b/graphics/pear-Image_Canvas/Makefile
new file mode 100644
index 000000000000..528609252a1e
--- /dev/null
+++ b/graphics/pear-Image_Canvas/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: pear-Image_Canvas
+# Date created: 21 Oct 2005
+# Whom: Simun Mikecin <numisemis@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image_Canvas
+PORTVERSION= 0.2.2
+CATEGORIES= graphics www pear
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= An OO PEAR common interface to image drawing
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${PEARDIR}/Image/Color.php:${PORTSDIR}/graphics/pear-Image_Color
+
+USE_PHP= gd
+USE_REINPLACE= yes
+
+CATEGORY= Image
+FILES= Canvas.php Canvas/Color.php Canvas/GD.php \
+ Canvas/ImageMap.php Canvas/PDF.php Canvas/SVG.php \
+ Canvas/Tool.php Canvas/WithMap.php Canvas/Fonts/fontmap.txt \
+ Canvas/Fonts/README Canvas/GD/JPG.php Canvas/GD/PNG.php
+
+TESTS= canvas_body.php gradients.php imagemap.php jpg.php \
+ lineends.php pdf.php pear-icon.png png.php README svg.php \
+ text.php
+
+DOCS= ChangeLog README examples/canvas.php examples/pear-icon.png
+
+LATEST_LINK= pear-Image_Canvas
+
+post-patch:
+.for file in ${FILES}
+ @${REINPLACE_CMD} -e "s|@package_version@|${DISTVERSION}|" ${WRKSRC}/${file}
+.endfor
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+
+.include <bsd.port.post.mk>