aboutsummaryrefslogtreecommitdiff
path: root/graphics/pear-Image_Graph
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-03 20:15:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-03 20:15:53 +0000
commit23b48aa72c18e30af77fea0f4e135caff920e908 (patch)
tree4ab1c06c45bc1fd3d23d58583a683d28eae43091 /graphics/pear-Image_Graph
parentb8c4f08b40603e7b059828edbe7035e023141492 (diff)
downloadports-23b48aa72c18e30af77fea0f4e135caff920e908.tar.gz
ports-23b48aa72c18e30af77fea0f4e135caff920e908.zip
- Update to 0.7.1
PR: ports/87787 Submitted by: Simun Mikecin <numisemis@yahoo.com> Approved by: maintainer timeout (14 days)
Notes
Notes: svn path=/head/; revision=147155
Diffstat (limited to 'graphics/pear-Image_Graph')
-rw-r--r--graphics/pear-Image_Graph/Makefile156
-rw-r--r--graphics/pear-Image_Graph/distinfo4
-rw-r--r--graphics/pear-Image_Graph/files/pkg-message.in12
3 files changed, 108 insertions, 64 deletions
diff --git a/graphics/pear-Image_Graph/Makefile b/graphics/pear-Image_Graph/Makefile
index 7ea806746ac3..a49d6f893600 100644
--- a/graphics/pear-Image_Graph/Makefile
+++ b/graphics/pear-Image_Graph/Makefile
@@ -6,37 +6,29 @@
#
PORTNAME= Image_Graph
-PORTVERSION= 0.3.0
+PORTVERSION= 0.7.1
CATEGORIES= graphics www pear
MAINTAINER= nick@foobar.org
COMMENT= An OO PEAR graph rendering package
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
-RUN_DEPENDS= ${PEARDIR}/Image/Color.php:${PORTSDIR}/graphics/pear-Image_Color \
- ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
+ ${PEARDIR}/Image/Canvas.php:${PORTSDIR}/graphics/pear-Image_Canvas
-# TODO: add PDFLIB support as soon as the FreeBSD port of PHP supports it
-
-USE_PHP= gd ming
USE_REINPLACE= yes
-PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_FILES= pkg-message
-
CATEGORY= Image
-FILES= Graph.php Graph/Axis.php Graph/Color.php \
- Graph/Common.php Graph/Config.php Graph/Constants.php \
- Graph/DataPreprocessor.php Graph/DataSelector.php \
- Graph/Dataset.php Graph/Driver.php Graph/Element.php \
+FILES= Graph.php Graph/Axis.php Graph/Common.php Graph/Config.php \
+ Graph/Constants.php Graph/DataPreprocessor.php \
+ Graph/DataSelector.php Graph/Dataset.php Graph/Element.php \
Graph/Fill.php Graph/Font.php Graph/Grid.php \
Graph/Layout.php Graph/Legend.php Graph/Logo.php \
Graph/Marker.php Graph/Plot.php Graph/Plotarea.php \
Graph/Simple.php Graph/Title.php Graph/Tool.php \
Graph/Axis/Category.php Graph/Axis/Logarithmic.php \
Graph/Axis/Radar.php Graph/Axis/Marker/Area.php \
- Graph/Axis/Marker/Line.php \
- Graph/DataPreprocessor/Array.php \
+ Graph/Axis/Marker/Line.php Graph/DataPreprocessor/Array.php \
Graph/DataPreprocessor/Currency.php \
Graph/DataPreprocessor/Date.php \
Graph/DataPreprocessor/Formatted.php \
@@ -44,21 +36,19 @@ FILES= Graph.php Graph/Axis.php Graph/Color.php \
Graph/DataPreprocessor/NumberText.php \
Graph/DataPreprocessor/RomanNumerals.php \
Graph/DataPreprocessor/Sequential.php \
+ Graph/Dataset/Function.php Graph/Dataset/Random.php \
+ Graph/Dataset/Sequential.php Graph/Dataset/Trivial.php \
+ Graph/Dataset/VectorFunction.php \
Graph/DataSelector/EveryNthPoint.php \
- Graph/DataSelector/NoZeros.php Graph/Dataset/Function.php \
- Graph/Dataset/Random.php Graph/Dataset/Sequential.php \
- Graph/Dataset/Trivial.php Graph/Dataset/VectorFunction.php \
- Graph/Driver/GD.php Graph/Driver/PDFlib.php \
- Graph/Driver/SVG.php Graph/Driver/SWF.php \
- Graph/Driver/GD/GIF.php Graph/Driver/GD/JPG.php \
- Graph/Driver/GD/PNG.php Graph/Driver/GD/WBMP.php \
+ Graph/DataSelector/NoZeros.php Graph/DataSelector/Values.php \
Graph/Figure/Circle.php Graph/Figure/Ellipse.php \
Graph/Figure/Polygon.php Graph/Figure/Rectangle.php \
Graph/Fill/Array.php Graph/Fill/Gradient.php \
- Graph/Fill/Image.php Graph/Font/Extended.php \
- Graph/Font/TTF.php Graph/Font/Vertical.php \
- Graph/Grid/Bars.php Graph/Grid/Lines.php \
- Graph/Grid/Polar.php Graph/Layout/Horizontal.php \
+ Graph/Fill/Image.php Graph/Grid/Bars.php \
+ Graph/Grid/Lines.php Graph/Grid/Polar.php \
+ Graph/Images/Icons/pinpoint.png \
+ Graph/Images/Icons/pinpointr.png Graph/Images/Maps/README \
+ Graph/Layout/Horizontal.php \
Graph/Layout/Matrix.php Graph/Layout/Vertical.php \
Graph/Line/Array.php Graph/Line/Dashed.php \
Graph/Line/Dotted.php Graph/Line/Formatted.php \
@@ -69,39 +59,109 @@ FILES= Graph.php Graph/Axis.php Graph/Color.php \
Graph/Marker/Diamond.php Graph/Marker/Icon.php \
Graph/Marker/Pinpoint.php Graph/Marker/Plus.php \
Graph/Marker/Pointing.php Graph/Marker/ReversePinpoint.php \
- Graph/Marker/Triangle.php Graph/Marker/Value.php \
- Graph/Marker/Pointing/Angular.php \
+ Graph/Marker/Star.php Graph/Marker/Triangle.php \
+ Graph/Marker/Value.php Graph/Marker/Pointing/Angular.php \
Graph/Marker/Pointing/Radial.php Graph/Plot/Area.php \
Graph/Plot/Band.php Graph/Plot/Bar.php \
Graph/Plot/BoxWhisker.php Graph/Plot/CandleStick.php \
Graph/Plot/Dot.php Graph/Plot/Impulse.php \
- Graph/Plot/Line.php Graph/Plot/Pie.php \
+ Graph/Plot/Line.php Graph/Plot/Odo.php Graph/Plot/Pie.php \
Graph/Plot/Radar.php Graph/Plot/Step.php \
- Graph/Plot/Smoothed/Area.php \
- Graph/Plot/Smoothed/Bezier.php \
- Graph/Plot/Smoothed/Line.php Graph/Plot/Smoothed/Radar.php \
+ Graph/Plot/Fit/Line.php Graph/Plot/Smoothed/Area.php \
+ Graph/Plot/Smoothed/Bezier.php Graph/Plot/Smoothed/Line.php \
+ Graph/Plot/Smoothed/Radar.php \
Graph/Plotarea/Element.php Graph/Plotarea/Map.php \
- Graph/Plotarea/Radar.php \
- Graph/Fonts/fontmap.txt
+ Graph/Plotarea/Radar.php
TESTS= freetype.php gd.php README axis/category.php \
axis/intersection.php axis/intersection_secondary_axis.php \
axis/inversion.php axis/labelinterval.php \
- axis/logarithmic.php driver/driver_body.php driver/gif.php \
- driver/gradients.php driver/jpg.php driver/pear-icon.png \
- driver/png.php driver/svg.php driver/text.php \
- driver/wbmp.php plot/area.php plot/bar.php plot/impulse.php \
- plot/line.php plot/step.php
+ axis/logarithmic.php plot/area.php plot/bar.php \
+ plot/impulse.php plot/line.php plot/step.php \
+ plot/horizontal/area.php plot/horizontal/bar.php \
+ plot/horizontal/impulse.php plot/horizontal/line.php \
+ plot/horizontal/step.php
-DOCS= ChangeLog colors.txt Drivers.txt LICENSE README examples/barchart1.php \
- examples/drivers1.php examples/drivers2.php examples/linechart1.php \
- examples/piechart1.php examples/images/audi.png examples/images/bmw.png \
- examples/images/coins.png examples/images/mercedes.png \
+DOCS= ChangeLog colors.txt LICENSE README examples/antialias.php \
+ examples/axis_direction.php \
+ examples/category_axis_explanation.php \
+ examples/color_chart.php \
+ examples/customize.php \
+ examples/datapreprocessor.php \
+ examples/double_category_axis.php \
+ examples/driver_filepdf.php \
+ examples/driver_pdf.php \
+ examples/driver_png_svg.php \
+ examples/driver_swf01.php \
+ examples/driver_swf02.php \
+ examples/driver_swf03.php \
+ examples/frontpage_sample.php \
+ examples/gradient_fill_area.php \
+ examples/gradient_pie.php \
+ examples/horizontal.php \
+ examples/gradient_step.php \
+ examples/html_image_map.php \
+ examples/imagemap.png \
+ examples/image_fill.php \
+ examples/index.html \
+ examples/layout_matrix.php \
+ examples/line_break.php \
+ examples/logo_graph.php \
+ examples/log_axis.php \
+ examples/log_axis_intersect.php \
+ examples/manual_labels.php \
+ examples/misc01.php \
+ examples/misc02.php \
+ examples/misc03.php \
+ examples/misc04.php \
+ examples/misc05.php \
+ examples/misc06.php \
+ examples/multiple_plots.php \
+ examples/negative_values.php \
+ examples/plot_all.php \
+ examples/plot_area.php \
+ examples/plot_all_horizontal.php \
+ examples/plot_all_horizontal_invert.php \
+ examples/plot_area_smooth.php \
+ examples/plot_area_stack.php \
+ examples/plot_band.php \
+ examples/plot_bar.php \
+ examples/plot_bar_horizontal.php \
+ examples/plot_bar_multiple.php \
+ examples/plot_bar_stacked.php \
+ examples/plot_bar_stacked100pct.php \
+ examples/plot_bar_stacked_horizontal.php \
+ examples/plot_bar_stacked_negative.php \
+ examples/plot_boxwhisker.php \
+ examples/plot_candlestick.php \
+ examples/plot_impulse.php \
+ examples/plot_line.php \
+ examples/plot_impulse_stacked.php \
+ examples/plot_line_smooth.php \
+ examples/plot_map.php \
+ examples/plot_odo.php \
+ examples/plot_pie.php \
+ examples/plot_pie_rotate.php \
+ examples/plot_radar.php \
+ examples/plot_radar_smooth.php \
+ examples/plot_scatter.php \
+ examples/plot_scatter_linefit.php \
+ examples/plot_step.php \
+ examples/secondary_axis.php \
+ examples/simple.php \
+ examples/simple_graph.php \
+ examples/small_pie_plot.php \
+ examples/vector_function.php \
+ examples/data/colors.txt \
+ examples/images/audi-tt-coupe.jpg \
+ examples/images/audi.png \
+ examples/images/bmw.png \
+ examples/images/coins.png \
+ examples/images/mercedes.png \
+ examples/images/modify.jpg \
+ examples/images/mountain.jpg \
examples/images/porsche.png
-FONTDIR= ${PEARDIR}/${CATEGORY}/Graph/Fonts
-
-PLIST_FILES+= share/pear/${CATEGORY}/Graph/Fonts/fontmap.txt-dist
LATEST_LINK= pear-Image_Graph
post-patch:
@@ -112,8 +172,4 @@ post-patch:
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
-post-install-script:
- @${CP} ${WRKSRC}/Graph/Fonts/fontmap.txt ${FONTDIR}/fontmap.txt-dist
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>
diff --git a/graphics/pear-Image_Graph/distinfo b/graphics/pear-Image_Graph/distinfo
index 645d5714b0fe..706dc2d9cccb 100644
--- a/graphics/pear-Image_Graph/distinfo
+++ b/graphics/pear-Image_Graph/distinfo
@@ -1,2 +1,2 @@
-MD5 (PEAR/Image_Graph-0.3.0.tgz) = c2603540777bdbc30e02a0908ae5c629
-SIZE (PEAR/Image_Graph-0.3.0.tgz) = 145705
+MD5 (PEAR/Image_Graph-0.7.1.tgz) = 2492103af6a37f856459fe0e0e72ba86
+SIZE (PEAR/Image_Graph-0.7.1.tgz) = 363754
diff --git a/graphics/pear-Image_Graph/files/pkg-message.in b/graphics/pear-Image_Graph/files/pkg-message.in
deleted file mode 100644
index fea2111e9481..000000000000
--- a/graphics/pear-Image_Graph/files/pkg-message.in
+++ /dev/null
@@ -1,12 +0,0 @@
-------------------------------------------------------------------
-In order to render fonts correctly, Image_Graph requires TrueType fonts to
-be installed in its fonts directory. In order to link all the TrueType
-fonts currently installed on your system to the Image_Graph directory, you
-should execute the following command:
-
-sh -c ' \
-for i in `locate \*.\[Tt\]\[Tt\]\[Ff\]`; do \
- ln -s $i %%PREFIX%%/share/pear/Image/Graph/Fonts; \
-done'
-
-------------------------------------------------------------------