aboutsummaryrefslogtreecommitdiff
path: root/graphics/pecl-imagick
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2020-10-25 11:34:11 +0000
committerMartin Matuska <mm@FreeBSD.org>2020-10-25 11:34:11 +0000
commit137ece184887553ca1a436aaab272cd31511f1d0 (patch)
treee0ecea3c0e3bf3b3d8b30715d25dd16a75612bf2 /graphics/pecl-imagick
parent70444fd8af3625d1fbffa97e45728c953c76da5c (diff)
downloadports-137ece184887553ca1a436aaab272cd31511f1d0.tar.gz
ports-137ece184887553ca1a436aaab272cd31511f1d0.zip
graphics/pecl-imagick: use official patches for PHP 8 compat
PR: 218974 Submitted by: Dima Panov <fluffy@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=553258
Diffstat (limited to 'graphics/pecl-imagick')
-rw-r--r--graphics/pecl-imagick/Makefile7
-rw-r--r--graphics/pecl-imagick/distinfo8
-rw-r--r--graphics/pecl-imagick/files/patch-imagick__class.c12
-rw-r--r--graphics/pecl-imagick/files/patch-imagick__helpers.c12
-rw-r--r--graphics/pecl-imagick/files/patch-php__imagick.h23
-rw-r--r--graphics/pecl-imagick/files/patch-php__imagick__defs.h13
6 files changed, 13 insertions, 62 deletions
diff --git a/graphics/pecl-imagick/Makefile b/graphics/pecl-imagick/Makefile
index 6b814a48444f..6c25598c731f 100644
--- a/graphics/pecl-imagick/Makefile
+++ b/graphics/pecl-imagick/Makefile
@@ -3,9 +3,14 @@
PORTNAME= imagick
PORTVERSION= 3.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
+PATCH_SITES= https://github.com/Imagick/imagick/commit/
+PATCHFILES+= e1a8d8a99f8eeab13574fcba20c85660a210e350.diff:-p1 \
+ ef46023bfba719183a8dcf880c1aa14cf77c006c.diff:-p1 \
+ 6160bd9617f6c4fc59b7db4ab77460ec085d3169.diff:-p1
+
MAINTAINER= mm@FreeBSD.org
COMMENT?= PHP wrapper to the ImageMagick/GraphicsMagick library version 6
diff --git a/graphics/pecl-imagick/distinfo b/graphics/pecl-imagick/distinfo
index 455b40d966ba..6e50f1b98d29 100644
--- a/graphics/pecl-imagick/distinfo
+++ b/graphics/pecl-imagick/distinfo
@@ -1,3 +1,9 @@
-TIMESTAMP = 1560062706
+TIMESTAMP = 1603625525
SHA256 (PECL/imagick-3.4.4.tgz) = 8dd5aa16465c218651fc8993e1faecd982e6a597870fd4b937e9ece02d567077
SIZE (PECL/imagick-3.4.4.tgz) = 253434
+SHA256 (PECL/e1a8d8a99f8eeab13574fcba20c85660a210e350.diff) = f3f6ce0b0c11925c29664c2f4944b77ea800c61987906dcb73c488e75e445a15
+SIZE (PECL/e1a8d8a99f8eeab13574fcba20c85660a210e350.diff) = 10010
+SHA256 (PECL/ef46023bfba719183a8dcf880c1aa14cf77c006c.diff) = 3deedb123ae262275ce8b7dbc00c30932c503b502de79e78d38930a3ad7e4299
+SIZE (PECL/ef46023bfba719183a8dcf880c1aa14cf77c006c.diff) = 406
+SHA256 (PECL/6160bd9617f6c4fc59b7db4ab77460ec085d3169.diff) = 80101cd5240a0e530d7c436ec74685a3eb4b78adae00b8ca276e7f0215a3016e
+SIZE (PECL/6160bd9617f6c4fc59b7db4ab77460ec085d3169.diff) = 469
diff --git a/graphics/pecl-imagick/files/patch-imagick__class.c b/graphics/pecl-imagick/files/patch-imagick__class.c
deleted file mode 100644
index 5127fbc9a81b..000000000000
--- a/graphics/pecl-imagick/files/patch-imagick__class.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- imagick_class.c.orig 2020-10-25 08:02:54 UTC
-+++ imagick_class.c
-@@ -12006,7 +12006,9 @@ PHP_METHOD(imagick, setprogressmonitor)
-
- callback = (php_imagick_callback *) emalloc(sizeof(php_imagick_callback));
-
-+#if PHP_VERSION_ID < 80000
- TSRMLS_SET_CTX(callback->thread_ctx);
-+#endif
- //We can't free the previous callback as we can't guarantee that
- //ImageMagick won't use it at some point. There is no 'unbind' function
- //for previously set 'MagickSetImageProgressMonitor'
diff --git a/graphics/pecl-imagick/files/patch-imagick__helpers.c b/graphics/pecl-imagick/files/patch-imagick__helpers.c
deleted file mode 100644
index ea05fbc49e65..000000000000
--- a/graphics/pecl-imagick/files/patch-imagick__helpers.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- imagick_helpers.c.orig 2020-10-25 08:02:44 UTC
-+++ imagick_helpers.c
-@@ -113,7 +113,9 @@ MagickBooleanType php_imagick_progress_monitor_callabl
- #endif
- fci.param_count = 2;
- fci.params = zargs;
-+#if PHP_VERSION_ID < 80000
- fci.no_separation = 0;
-+#endif
- #if PHP_VERSION_ID < 70100
- fci.symbol_table = NULL;
- #endif
diff --git a/graphics/pecl-imagick/files/patch-php__imagick.h b/graphics/pecl-imagick/files/patch-php__imagick.h
deleted file mode 100644
index 8ca8e715fccf..000000000000
--- a/graphics/pecl-imagick/files/patch-php__imagick.h
+++ /dev/null
@@ -1,23 +0,0 @@
---- php_imagick.h.orig 2019-05-02 15:26:00 UTC
-+++ php_imagick.h
-@@ -47,5 +47,20 @@
- extern zend_module_entry imagick_module_entry;
- #define phpext_imagick_ptr &imagick_module_entry
-
-+#if PHP_VERSION_ID >= 80000
-+#ifndef TSRMLS_C
-+#define TSRMLS_C
-+#endif
-+#ifndef TSRMLS_CC
-+#define TSRMLS_CC
-+#endif
-+#ifndef TSRMLS_D
-+#define TSRMLS_D
-+#endif
-+#ifndef TSRMLS_DC
-+#define TSRMLS_DC
-+#endif
-+#endif
-+
- #endif /* PHP_IMAGICK_H */
-
diff --git a/graphics/pecl-imagick/files/patch-php__imagick__defs.h b/graphics/pecl-imagick/files/patch-php__imagick__defs.h
deleted file mode 100644
index c7776e4f81ce..000000000000
--- a/graphics/pecl-imagick/files/patch-php__imagick__defs.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- php_imagick_defs.h.orig 2020-10-25 08:13:09 UTC
-+++ php_imagick_defs.h
-@@ -20,6 +20,10 @@
- #ifndef PHP_IMAGICK_DEFS_H /* PHP_IMAGICK_DEFS_H */
- # define PHP_IMAGICK_DEFS_H
-
-+#ifndef HAVE_LOCALE_H
-+#define HAVE_LOCALE_H
-+#endif
-+
- /* Include magic wand header */
- #if defined (IM_MAGICKWAND_HEADER_STYLE_SEVEN)
- # include <MagickWand/MagickWand.h>