aboutsummaryrefslogtreecommitdiff
path: root/graphics/pfstools
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-07-14 01:45:43 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-07-14 01:45:43 +0000
commit196663b90d07f8753079902ecef708246e4d0b11 (patch)
tree684b850db4b08226ced584e8735a838007281323 /graphics/pfstools
parent1d5371a0c63369ffa15e40740cb31dccf9b3c750 (diff)
downloadports-196663b90d07f8753079902ecef708246e4d0b11.tar.gz
ports-196663b90d07f8753079902ecef708246e4d0b11.zip
* Fix qt option build
* Changed OCTAVE USES to option helper PR: 220247 Submitted by: Iouri V. Ivliev <fbsd@any.com.ru> (maintainer) Reported by: Jov <amutu@amutu.com> Reviewed by: lifanov (mentor), matthew (mentor), matt Approved by: lifanov (mentor) Differential Revision: https://reviews.freebsd.org/D11495
Notes
Notes: svn path=/head/; revision=445722
Diffstat (limited to 'graphics/pfstools')
-rw-r--r--graphics/pfstools/Makefile4
-rw-r--r--graphics/pfstools/files/patch-src-filter-pfswb.cpp8
-rw-r--r--graphics/pfstools/files/patch-src-pfs-pfs.h9
3 files changed, 16 insertions, 5 deletions
diff --git a/graphics/pfstools/Makefile b/graphics/pfstools/Makefile
index a84dcc6d226e..b0c6f3b961cb 100644
--- a/graphics/pfstools/Makefile
+++ b/graphics/pfstools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pfstools
PORTVERSION= 1.8.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF
@@ -60,6 +60,7 @@ OCTAVE_CONFIGURE_ENABLE= octave
OCTAVE_PATCH_DEPENDS= octave-config:math/octave
OCTAVE_BUILD_DEPENDS= mkoctfile:math/octave
OCTAVE_RUN_DEPENDS= octave:math/octave
+OCTAVE_USES= shebangfix
.include <bsd.port.options.mk>
@@ -72,7 +73,6 @@ PLIST_SUB+= \
OCTAVE_BASE=${OCTAVE_BASE} \
OCTAVE_SITE_M=${OCTAVE_SITE_M:S|^${OCTAVE_BASE}/||} \
OCTAVE_SITE_OCT=${OCTAVE_SITE_OCT:S|^${OCTAVE_BASE}/||}
-USES+= shebangfix
SHEBANG_FILES= src/octave/*
SHEBANG_LANG+= octave
octave_OLD_CMD?=/usr/bin/octave
diff --git a/graphics/pfstools/files/patch-src-filter-pfswb.cpp b/graphics/pfstools/files/patch-src-filter-pfswb.cpp
index 708f10297a72..e579100e1852 100644
--- a/graphics/pfstools/files/patch-src-filter-pfswb.cpp
+++ b/graphics/pfstools/files/patch-src-filter-pfswb.cpp
@@ -1,6 +1,6 @@
---- src/filter/pfswb.cpp.orig 2016-02-12 17:10:27 UTC
+--- src/filter/pfswb.cpp.orig 2016-08-12 19:10:44 UTC
+++ src/filter/pfswb.cpp
-@@ -0,0 +1,297 @@
+@@ -0,0 +1,299 @@
+/**
+ * @file pfswb.cpp
+ * @brief Adjust white balance in RGB color space
@@ -184,10 +184,12 @@
+ float nmin = 1e20, nmax = -1e20;
+ for (int i=s; i--; )
+ {
-+ float const &l = ((*Y)(i)-amin)*k+min;
++ float const l = ((*Y)(i)-amin)*k+min;
+ if (nmin > l) nmin = l;
+ if (nmax < l) nmax = l;
+ (*Y)(i) = l;
++ (*X)(i) *= k;
++ (*Z)(i) *= k;
+ }
+ VERBOSE_STR << "restored luminance range: " << nmin << ":" << nmax << std::endl;
+ }
diff --git a/graphics/pfstools/files/patch-src-pfs-pfs.h b/graphics/pfstools/files/patch-src-pfs-pfs.h
index 4a40523f84be..2003c7ad0c51 100644
--- a/graphics/pfstools/files/patch-src-pfs-pfs.h
+++ b/graphics/pfstools/files/patch-src-pfs-pfs.h
@@ -43,3 +43,12 @@
}
~Exception() {};
+@@ -590,7 +596,7 @@ namespace pfs
+ *
+ * @return text description of the cause for the exception
+ */
+- const char* getMessage()
++ const char* getMessage() const
+ {
+ return msg;
+ }