aboutsummaryrefslogtreecommitdiff
path: root/graphics/pgplot
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2013-05-30 14:25:02 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2013-05-30 14:25:02 +0000
commit995f7958a6e56ede35852a8a952bfead499c5653 (patch)
tree747988f618bb9ca73a860193cb25ca0870bada8a /graphics/pgplot
parent06e6d4a461526ff048dfea0c39b9c081f6b1d922 (diff)
downloadports-995f7958a6e56ede35852a8a952bfead499c5653.tar.gz
ports-995f7958a6e56ede35852a8a952bfead499c5653.zip
Minor style changes and clean-up, including: use shebangfix and remove
a redundant patch [1] Submitted by: J. Marino [1]
Notes
Notes: svn path=/head/; revision=319430
Diffstat (limited to 'graphics/pgplot')
-rw-r--r--graphics/pgplot/Makefile26
-rw-r--r--graphics/pgplot/files/patch-aa16
2 files changed, 11 insertions, 31 deletions
diff --git a/graphics/pgplot/Makefile b/graphics/pgplot/Makefile
index 1532f2df4448..8b15b96a7c2a 100644
--- a/graphics/pgplot/Makefile
+++ b/graphics/pgplot/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pgplot
-# Date created: 21 December 1996
-# Whom: jmz
-#
+# Created by: jmz
# $FreeBSD$
-#
PORTNAME= pgplot
PORTVERSION= 5.2.2
@@ -13,23 +9,25 @@ MASTER_SITES= ftp://ftp.astro.caltech.edu/pub/pgplot/
DISTNAME= ${PORTNAME}${PORTVERSION:R}
MAINTAINER= bf@FreeBSD.org
-COMMENT= A C/FORTRAN library for drawing graphs on a variety of display devices
+COMMENT= C/FORTRAN library for drawing graphs on a variety of display devices
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
MAKE_JOBS_UNSAFE= yes
+USES= shebangfix
USE_FORTRAN= yes
USE_LDCONFIG= yes
USE_XORG= x11 xproto xt
MAKE_ENV= SSP_CFLAGS=
+SHEBANG_FILES= makehtml maketex
SUFFIXES= flib clib bin
WRKSRC= ${WRKDIR}/${PORTNAME}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !empty(ARCH:M*64*)
+.if ${ARCH:M*64*}
EXTRA_PATCHES += ${FILESDIR}/drivers_64bit_patch
.endif
@@ -37,7 +35,7 @@ EXTRA_PATCHES += ${FILESDIR}/drivers_64bit_patch
PORTDATA= grfont.dat
.endif
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
DOCS= cpg/cpgplot.doc pgplot-routines.tex pgplot.doc pgplot.html \
readme.pgdisp rgb.txt
SUFFIXES+= doc
@@ -45,14 +43,12 @@ PORTDOCS= ${DOCS:C|.*/||}
USE_PERL5_BUILD= yes
.endif
-.ifndef(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
EXAMPLES= Makefile.demo cpg/cpgdemo.c examples/pgdemo*.f
PORTEXAMPLES= ${EXAMPLES:C|.*/||}
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/bin/perl|${PERL}|' \
- ${WRKSRC}/makehtml ${WRKSRC}/maketex
@${REINPLACE_CMD} -e 's|png_ptr->jmpbuf|png_jmpbuf(png_ptr)|' \
${WRKSRC}/drivers/pndriv.c
@${REINPLACE_CMD} -e 's|/usr/local/pgplot|${DATADIR}|g' \
@@ -78,12 +74,12 @@ do-install:
@${MKDIR} ${DATADIR}
@cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDATA} ${DATADIR}
.endif
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}; ${CP} pgdispd/aaaread.me readme.pgdisp; \
${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.ifndef(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@cd ${WRKSRC}; ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
.endif
@@ -99,4 +95,4 @@ check test: build
PGPLOT_DIR="${WRKSRC}" PGPLOT_DEV="/xwin" ${WRKSRC}/${DEMO}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/pgplot/files/patch-aa b/graphics/pgplot/files/patch-aa
deleted file mode 100644
index 3088fc808213..000000000000
--- a/graphics/pgplot/files/patch-aa
+++ /dev/null
@@ -1,16 +0,0 @@
---- makehtml~ Wed Feb 26 22:54:09 1997
-+++ makehtml Mon Oct 12 22:52:01 1998
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/perl
-+#!/usr/bin/perl
-
- $, = ' '; # set output field separator
- $\ = "\n"; # set output record separator
---- maketex~ Tue Apr 16 23:51:24 1996
-+++ maketex Mon Oct 12 22:52:14 1998
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/perl
-+#!/usr/bin/perl
-
- $, = ' '; # set output field separator
- $\ = "\n"; # set output record separator