aboutsummaryrefslogtreecommitdiff
path: root/graphics/pho
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-09-11 09:10:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-09-11 09:10:19 +0000
commit35a180fa5336fc8e14960e82aa47717e8ee5824f (patch)
tree8986585db55ca0bf7276a29539dde792c7a33272 /graphics/pho
parente2e084dc7cd5be4576eeda11187a9dc169b3deb7 (diff)
downloadports-35a180fa5336fc8e14960e82aa47717e8ee5824f.tar.gz
ports-35a180fa5336fc8e14960e82aa47717e8ee5824f.zip
Teach pho to skip further options handling (previously, it was impossible to
view files which names start with `-'). Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=172769
Diffstat (limited to 'graphics/pho')
-rw-r--r--graphics/pho/Makefile2
-rw-r--r--graphics/pho/files/patch-options34
2 files changed, 35 insertions, 1 deletions
diff --git a/graphics/pho/Makefile b/graphics/pho/Makefile
index 553cdea4eb4a..1a7622ece07b 100644
--- a/graphics/pho/Makefile
+++ b/graphics/pho/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pho
DISTVERSION= 0.9.5-pre4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://shallowsky.com/software/pho/
diff --git a/graphics/pho/files/patch-options b/graphics/pho/files/patch-options
new file mode 100644
index 000000000000..8c887d5edf77
--- /dev/null
+++ b/graphics/pho/files/patch-options
@@ -0,0 +1,34 @@
+--- gmain.c.orig Mon Jul 25 12:18:05 2005
++++ gmain.c Mon Sep 11 16:05:05 2006
+@@ -643,9 +643,11 @@
+
+ int main(int argc, char** argv)
+ {
++ int options = 1;
++
+ while (argc > 1)
+ {
+- if (argv[1][0] == '-') {
++ if (argv[1][0] == '-' && options) {
+ if (argv[1][1] == 'd')
+ gDebug = 1;
+ else if (argv[1][1] == 'h')
+@@ -656,6 +658,8 @@
+ gMakeNewWindows = 1;
+ else if (argv[1][1] == 'p')
+ gPresentationMode = 1;
++ else if (argv[1][1] == '-')
++ options = 0;
+ else Usage();
+ }
+ else {
+--- pho.c.orig Mon Mar 21 07:28:03 2005
++++ pho.c Mon Sep 11 16:05:05 2006
+@@ -439,6 +439,7 @@
+ printf("\t-d: Debug messages\n");
+ printf("\t-h: Help: Print this summary\n");
+ printf("\t-v: Verbose help: Print a summary of key bindings\n");
++ printf("\t--: Assume no more options are given\n");
+ exit(1);
+ }
+