aboutsummaryrefslogtreecommitdiff
path: root/graphics/pho
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-10-30 09:54:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-10-30 09:54:54 +0000
commit65417819daeb2fd92b809cfdd9414dd54849b9e2 (patch)
tree61a7ca1e824da3c139ab8ab92d10f3b424ad7d2c /graphics/pho
parentcc6b305ce6d5fa63d87ebc2943ffd3b7ddb7d253 (diff)
downloadports-65417819daeb2fd92b809cfdd9414dd54849b9e2.tar.gz
ports-65417819daeb2fd92b809cfdd9414dd54849b9e2.zip
Update to version 0.9.5.1.
Notes
Notes: svn path=/head/; revision=202418
Diffstat (limited to 'graphics/pho')
-rw-r--r--graphics/pho/Makefile8
-rw-r--r--graphics/pho/distinfo6
-rw-r--r--graphics/pho/files/patch-options24
3 files changed, 18 insertions, 20 deletions
diff --git a/graphics/pho/Makefile b/graphics/pho/Makefile
index ea2f25da268f..f1bb66254c9b 100644
--- a/graphics/pho/Makefile
+++ b/graphics/pho/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pho
-DISTVERSION= 0.9.5-pre4
-PORTREVISION= 3
+DISTVERSION= 0.9.5.1
CATEGORIES= graphics
MASTER_SITES= http://shallowsky.com/software/pho/
@@ -34,9 +33,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|make|${GMAKE}|g; \
s|$$(INSTALL) \(pho \)|${INSTALL_PROGRAM} \1|; \
s|$$(INSTALL) \(pho.1\)|${INSTALL_MAN} \1|; \
- s|-g -O2|${CFLAGS}|; s|pho xpho$$|pho|' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|^G${BAD_GTK}FLAGS|#&|' ${WRKSRC}/Makefile
+ s|-g -O|${CFLAGS}|; s|pho xpho$$|pho|; \
+ s|^G${BAD_GTK}FLAGS|#&|' ${WRKSRC}/Makefile
MAN1= pho.1
PLIST_FILES= bin/pho
diff --git a/graphics/pho/distinfo b/graphics/pho/distinfo
index 3eab5f97ac42..a29d3cd1f893 100644
--- a/graphics/pho/distinfo
+++ b/graphics/pho/distinfo
@@ -1,3 +1,3 @@
-MD5 (pho-0.9.5-pre4.tar.gz) = e46701e31abce43b42a54da8c9fe67df
-SHA256 (pho-0.9.5-pre4.tar.gz) = addd5529ca32a2bc4d0bd039b7ea980ed54bb7c4819e60ed1bcd55c0b7466023
-SIZE (pho-0.9.5-pre4.tar.gz) = 79301
+MD5 (pho-0.9.5.1.tar.gz) = 0605e354788a098674004f7c9380fce5
+SHA256 (pho-0.9.5.1.tar.gz) = 7d7bd932852f5615ed0dc05c94d35d0e0ebc80b6455ed72a09debefc725e2eb8
+SIZE (pho-0.9.5.1.tar.gz) = 66765
diff --git a/graphics/pho/files/patch-options b/graphics/pho/files/patch-options
index 8c887d5edf77..0f6287632a6d 100644
--- a/graphics/pho/files/patch-options
+++ b/graphics/pho/files/patch-options
@@ -1,27 +1,27 @@
--- gmain.c.orig Mon Jul 25 12:18:05 2005
+++ gmain.c Mon Sep 11 16:05:05 2006
-@@ -643,9 +643,11 @@
+@@ -668,6 +668,7 @@
int main(int argc, char** argv)
{
+ int options = 1;
-+
+ /* Initialize some defaults from environment variables,
+ * before reading cmdline args.
+ */
+@@ -681,8 +682,11 @@
+
while (argc > 1)
{
- if (argv[1][0] == '-') {
+- CheckArg(argv[1][1]);
+ if (argv[1][0] == '-' && options) {
- if (argv[1][1] == 'd')
- gDebug = 1;
- else if (argv[1][1] == 'h')
-@@ -656,6 +658,8 @@
- gMakeNewWindows = 1;
- else if (argv[1][1] == 'p')
- gPresentationMode = 1;
-+ else if (argv[1][1] == '-')
-+ options = 0;
- else Usage();
++ if (argv[1][1] != '-')
++ CheckArg(argv[1][1]);
++ else
++ options = 0;
}
else {
+ PhoImage* img = NewPhoImage(argv[1]);
--- pho.c.orig Mon Mar 21 07:28:03 2005
+++ pho.c Mon Sep 11 16:05:05 2006
@@ -439,6 +439,7 @@