aboutsummaryrefslogtreecommitdiff
path: root/graphics/pho
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-01-22 23:06:28 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-01-22 23:06:28 +0000
commit6d303173a5c3ef91a43a7dc076e760dd3e126c93 (patch)
treebfd449bacfd4100db6d620844d9a4b0c1ea3f3d8 /graphics/pho
parent5f1cd1084619b8afb26b3b2cd80fc332f525aeeb (diff)
downloadports-6d303173a5c3ef91a43a7dc076e760dd3e126c93.tar.gz
ports-6d303173a5c3ef91a43a7dc076e760dd3e126c93.zip
graphics/pho: the port had been modernized (+)
- Convert somewhat cluttered `post-patch' target to a regular patch - Install the manpage under ${PREFIX}/share/man per new world order - Chase HTTP/1.1 301 Moved Permanently redirect in the MASTER_SITES
Diffstat (limited to 'graphics/pho')
-rw-r--r--graphics/pho/Makefile9
-rw-r--r--graphics/pho/files/patch-Makefile22
2 files changed, 24 insertions, 7 deletions
diff --git a/graphics/pho/Makefile b/graphics/pho/Makefile
index bd8cbe8d7c24..e492d0283015 100644
--- a/graphics/pho/Makefile
+++ b/graphics/pho/Makefile
@@ -2,7 +2,7 @@ PORTNAME= pho
PORTVERSION= 1.0
PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://shallowsky.com/software/pho/
+MASTER_SITES= ${WWW}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Lightweight image viewer
@@ -12,17 +12,12 @@ LICENSE= GPLv2
USES= gmake gnome pkgconfig
USE_GNOME= gtk20
-MAKE_ARGS= INSTALLPREFIX="${STAGEDIR}${PREFIX}"
ALL_TARGET= ${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+PLIST_FILES= bin/${PORTNAME} share/man/man1/${PORTNAME}.1.gz
post-patch:
- @${REINPLACE_CMD} -e 's|make|$$(MAKE)| ; \
- /bin/s|$$(INSTALL)|${INSTALL_PROGRAM}| ; \
- /man/s|$$(INSTALL)|${INSTALL_MAN}| ; \
- /CFLAGS/s|-g ||' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|-Wall -g -O2 ||' ${WRKSRC}/exif/Makefile
.include <bsd.port.mk>
diff --git a/graphics/pho/files/patch-Makefile b/graphics/pho/files/patch-Makefile
new file mode 100644
index 000000000000..80202ca0ddd7
--- /dev/null
+++ b/graphics/pho/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig 2020-09-26 16:16:24 UTC
++++ Makefile
+@@ -4,7 +4,7 @@ VERSION = 1.0
+
+ # Locate the gtk/gdk libraries (thanks to nev for this!)
+ GTKFLAGS := $(shell pkg-config --cflags gtk+-2.0 gdk-2.0 2> /dev/null)
+-CFLAGS += -g -Wall -pedantic -DVERSION='"$(VERSION)"' $(GTKFLAGS)
++CFLAGS += -Wall -pedantic -DVERSION='"$(VERSION)"' $(GTKFLAGS)
+
+ XLIBS := $(shell pkg-config --libs gtk+-2.0 > /dev/null)
+ GLIBS := $(shell pkg-config --libs gtk+-2.0 gdk-2.0)
+@@ -57,8 +57,8 @@ deb: pho
+ dpkg-buildpackage -rfakeroot
+
+ install: pho
+- $(INSTALL) pho $(INSTALLPREFIX)/bin/pho
+- $(INSTALL) doc/pho.1 $(INSTALLPREFIX)/man/man1/pho.1
++ $(BSD_INSTALL_PROGRAM) pho $(DESTDIR)$(PREFIX)/bin
++ $(BSD_INSTALL_MAN) doc/pho.1 $(DESTDIR)$(PREFIX)/share/man/man1
+
+ clean:
+ rm -f *.[oas] *.ld core* pho pho-*.tar.gz *.rpm *.tar.gz