aboutsummaryrefslogtreecommitdiff
path: root/graphics/pho
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-15 22:04:50 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-15 22:04:50 +0000
commitce08573f3f07f7da4caaeddaa6808a33c0e7a284 (patch)
tree2c6e8ed18c89180378309d65d205dd46086ddfa3 /graphics/pho
parent1c98d40f2a0718482ba2790335aeb2eccaa5ae75 (diff)
downloadports-ce08573f3f07f7da4caaeddaa6808a33c0e7a284.tar.gz
ports-ce08573f3f07f7da4caaeddaa6808a33c0e7a284.zip
Update to version 0.9.6.
Notes
Notes: svn path=/head/; revision=239617
Diffstat (limited to 'graphics/pho')
-rw-r--r--graphics/pho/Makefile17
-rw-r--r--graphics/pho/distinfo6
-rw-r--r--graphics/pho/files/patch-options20
3 files changed, 22 insertions, 21 deletions
diff --git a/graphics/pho/Makefile b/graphics/pho/Makefile
index f4c170880f07..633db1fade03 100644
--- a/graphics/pho/Makefile
+++ b/graphics/pho/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pho
-DISTVERSION= 0.9.5.1
-PORTREVISION= 2
+DISTVERSION= 0.9.6
CATEGORIES= graphics
MASTER_SITES= http://shallowsky.com/software/pho/
@@ -16,9 +15,10 @@ COMMENT= A lightweight image viewer
USE_GMAKE= yes
MAKE_ARGS= INSTALLPREFIX="${PREFIX}"
+ALL_TARGET= pho
WANT_GNOME= yes
-OPTIONS= GTK1 "Build with legacy GTK version (1.2.x)" Off
+OPTIONS= GTK1 "Build with legacy GTK version (1.2.x)" off
.include <bsd.port.pre.mk>
@@ -31,11 +31,12 @@ BAD_GTK= 1
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|make|${GMAKE}|g; \
- s|$$(INSTALL) \(pho \)|${INSTALL_PROGRAM} \1|; \
- s|$$(INSTALL) \(pho.1\)|${INSTALL_MAN} \1|; \
- s|-g -O|${CFLAGS}|; s|pho xpho$$|pho|; \
- s|^G${BAD_GTK}FLAGS|#&|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|make|${GMAKE}| ; \
+ s|$$(INSTALL) \(pho \)|${INSTALL_PROGRAM} \1| ; \
+ s|$$(INSTALL) \(pho.1\)|${INSTALL_MAN} \1| ; \
+ s|-g -Wall|${CFLAGS}|; s|^G${BAD_GTK}FLAGS|#&|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-Wall -g -O2 ||' ${WRKSRC}/exif/Makefile
MAN1= pho.1
PLIST_FILES= bin/pho
diff --git a/graphics/pho/distinfo b/graphics/pho/distinfo
index a29d3cd1f893..c641c610e567 100644
--- a/graphics/pho/distinfo
+++ b/graphics/pho/distinfo
@@ -1,3 +1,3 @@
-MD5 (pho-0.9.5.1.tar.gz) = 0605e354788a098674004f7c9380fce5
-SHA256 (pho-0.9.5.1.tar.gz) = 7d7bd932852f5615ed0dc05c94d35d0e0ebc80b6455ed72a09debefc725e2eb8
-SIZE (pho-0.9.5.1.tar.gz) = 66765
+MD5 (pho-0.9.6.tar.gz) = a219de8f2da9be0f857c357ea1b9e09f
+SHA256 (pho-0.9.6.tar.gz) = b45cce219016f011976d0a6c211337956c650bf06125ccb489f88427d5a24ffb
+SIZE (pho-0.9.6.tar.gz) = 94587
diff --git a/graphics/pho/files/patch-options b/graphics/pho/files/patch-options
index 0f6287632a6d..49b94db39da4 100644
--- a/graphics/pho/files/patch-options
+++ b/graphics/pho/files/patch-options
@@ -8,20 +8,20 @@
/* Initialize some defaults from environment variables,
* before reading cmdline args.
*/
-@@ -681,8 +682,11 @@
+@@ -877,8 +877,11 @@
while (argc > 1)
{
-- if (argv[1][0] == '-') {
-- CheckArg(argv[1][1]);
-+ if (argv[1][0] == '-' && options) {
-+ if (argv[1][1] != '-')
-+ CheckArg(argv[1][1]);
-+ else
-+ options = 0;
- }
+- if (argv[1][0] == '-')
+- CheckArg(argv[1]);
++ if (argv[1][0] == '-' && options)
++ if (strcmp(argv[1], "--"))
++ CheckArg(argv[1]);
++ else
++ options = 0;
else {
- PhoImage* img = NewPhoImage(argv[1]);
+ AddImage(argv[1]);
+ }
--- pho.c.orig Mon Mar 21 07:28:03 2005
+++ pho.c Mon Sep 11 16:05:05 2006
@@ -439,6 +439,7 @@