aboutsummaryrefslogtreecommitdiff
path: root/graphics/photoflow
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-28 19:24:51 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-28 19:24:51 +0000
commitd5349047c8baf0e6cd6c811c144e538d0118fdc7 (patch)
tree7fe526bec7546c1fc6f9eb6bca9f4b8242ad2953 /graphics/photoflow
parent0d2e60d7e807fff5c6eea3ecf304528e0099f7c4 (diff)
downloadports-d5349047c8baf0e6cd6c811c144e538d0118fdc7.tar.gz
ports-d5349047c8baf0e6cd6c811c144e538d0118fdc7.zip
Notes
Diffstat (limited to 'graphics/photoflow')
-rw-r--r--graphics/photoflow/Makefile4
-rw-r--r--graphics/photoflow/files/patch-src_CMakeLists.txt2
-rw-r--r--graphics/photoflow/files/patch-src_external_rawspeed_src_librawspeed_common_Mutex.h17
3 files changed, 22 insertions, 1 deletions
diff --git a/graphics/photoflow/Makefile b/graphics/photoflow/Makefile
index 393a9bbbb98a..2f27acb24415 100644
--- a/graphics/photoflow/Makefile
+++ b/graphics/photoflow/Makefile
@@ -29,6 +29,10 @@ GH_TAGNAME= da84a071
USE_GNOME= atkmm cairomm glib20 glibmm gtk20 gtkmm24 libsigc++20 pangomm
CMAKE_OFF= BUNDLED_LENSFUN
+#Disable optimization for the builder CPU when building official packages
+.if defined(PACKAGE_BUILDING)
+CMAKE_ON= BINARY_PACKAGE_BUILD
+.endif
LDFLAGS+= -lexecinfo
diff --git a/graphics/photoflow/files/patch-src_CMakeLists.txt b/graphics/photoflow/files/patch-src_CMakeLists.txt
index 6f1de5a8e0ee..db2db8c359ce 100644
--- a/graphics/photoflow/files/patch-src_CMakeLists.txt
+++ b/graphics/photoflow/files/patch-src_CMakeLists.txt
@@ -5,7 +5,7 @@
#SET(GMIC_FLAGS "-Wno-error=c++11-narrowing -Dgmic_build -Dcimg_use_vt100 -Dcimg_use_fftw3 -Dcimg_use_tiff -Dcimg_use_zlib -Dcimg_display=0 -Dcimg_use_fftw3_singlethread -fpermissive")
ELSE(MINGW)
- SET(GMIC_FLAGS "-std=gnu++11 -march=nocona -mno-sse3 -mtune=generic -Wno-error=narrowing -Dgmic_build -Dcimg_use_vt100 -Dgmic_is_parallel -Dcimg_use_fftw3 -Dcimg_use_tiff -Dcimg_use_zlib -Dcimg_display=0 -fno-ipa-sra -fpermissive")
-+ SET(GMIC_FLAGS "-std=gnu++11 -march=nocona -mno-sse3 -mtune=generic -Wno-error=narrowing -Dgmic_build -Dcimg_use_vt100 -Dgmic_is_parallel -Dcimg_use_fftw3 -Dcimg_use_tiff -Dcimg_use_zlib -Dcimg_display=0 -fpermissive")
++ SET(GMIC_FLAGS "-std=gnu++11 -Wno-error=narrowing -Dgmic_build -Dcimg_use_vt100 -Dgmic_is_parallel -Dcimg_use_fftw3 -Dcimg_use_tiff -Dcimg_use_zlib -Dcimg_display=0 -fpermissive")
ENDIF(MINGW)
set(COMPILE_FLAGS " ${GMIC_FLAGS} -I${CMAKE_SOURCE_DIR}/src/dt -DLIBRAW_NODLL -DINSTALL_PREFIX='\"${INSTALL_PREFIX}\"' ")
diff --git a/graphics/photoflow/files/patch-src_external_rawspeed_src_librawspeed_common_Mutex.h b/graphics/photoflow/files/patch-src_external_rawspeed_src_librawspeed_common_Mutex.h
new file mode 100644
index 000000000000..58aa7df32518
--- /dev/null
+++ b/graphics/photoflow/files/patch-src_external_rawspeed_src_librawspeed_common_Mutex.h
@@ -0,0 +1,17 @@
+--- src/external/rawspeed/src/librawspeed/common/Mutex.h.orig 2019-08-13 19:14:10 UTC
++++ src/external/rawspeed/src/librawspeed/common/Mutex.h
+@@ -77,12 +77,12 @@ class CAPABILITY("mutex") Mutex final { (public)
+ // Acquire/lock this mutex exclusively. Only one thread can have exclusive
+ // access at any one time. Write operations to guarded data require an
+ // exclusive lock.
+- void __attribute__((const)) Lock() const ACQUIRE() {
++ void Lock() ACQUIRE() {
+ // NOP, since there is no mutex. only here to still check for proper locking
+ }
+
+ // Release/unlock an exclusive mutex.
+- void __attribute__((const)) Unlock() const RELEASE() {
++ void Unlock() RELEASE() {
+ // NOP, since there is no mutex. only here to still check for proper locking
+ }
+