aboutsummaryrefslogtreecommitdiff
path: root/graphics/php-facedetect
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2020-10-25 08:26:15 +0000
committerMartin Matuska <mm@FreeBSD.org>2020-10-25 08:26:15 +0000
commit81e579d3bb4d853522dbf390f925f082fb93c2e9 (patch)
tree69c7fabca68598fa55c76c1a2a6b6e27c7684371 /graphics/php-facedetect
parentd721fc5febd63ed50e79ce8fd0a8c227ce739027 (diff)
downloadports-81e579d3bb4d853522dbf390f925f082fb93c2e9.tar.gz
ports-81e579d3bb4d853522dbf390f925f082fb93c2e9.zip
graphics/php-facedetect: unbreak build with PHP 8
Notes
Notes: svn path=/head/; revision=553246
Diffstat (limited to 'graphics/php-facedetect')
-rw-r--r--graphics/php-facedetect/Makefile2
-rw-r--r--graphics/php-facedetect/files/patch-facedetect.c4
-rw-r--r--graphics/php-facedetect/files/patch-php__facedetect.h14
3 files changed, 17 insertions, 3 deletions
diff --git a/graphics/php-facedetect/Makefile b/graphics/php-facedetect/Makefile
index b53320521305..4165c742e5de 100644
--- a/graphics/php-facedetect/Makefile
+++ b/graphics/php-facedetect/Makefile
@@ -3,7 +3,7 @@
PORTNAME= facedetect
PORTVERSION= 1.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
diff --git a/graphics/php-facedetect/files/patch-facedetect.c b/graphics/php-facedetect/files/patch-facedetect.c
index a72e9f6169af..4cd817e3b4f6 100644
--- a/graphics/php-facedetect/files/patch-facedetect.c
+++ b/graphics/php-facedetect/files/patch-facedetect.c
@@ -1,5 +1,5 @@
---- facedetect.c.orig 2018-05-02 21:46:34.553339000 +0000
-+++ facedetect.c 2018-05-02 21:46:52.704512000 +0000
+--- facedetect.c.orig 2011-12-28 16:18:09 UTC
++++ facedetect.c
@@ -25,6 +25,7 @@
#include <opencv/cv.h>
diff --git a/graphics/php-facedetect/files/patch-php__facedetect.h b/graphics/php-facedetect/files/patch-php__facedetect.h
new file mode 100644
index 000000000000..8d7e22461d40
--- /dev/null
+++ b/graphics/php-facedetect/files/patch-php__facedetect.h
@@ -0,0 +1,14 @@
+--- php_facedetect.h.orig 2020-10-25 08:22:36 UTC
++++ php_facedetect.h
+@@ -32,5 +32,11 @@ PHP_FUNCTION(face_count);
+ extern zend_module_entry facedetect_module_entry;
+ #define phpext_facedetect_ptr &facedetect_module_entry
+
++#if PHP_VERSION_ID >= 80000
++#ifndef TSRMLS_CC
++#define TSRMLS_CC
++#endif
++#endif
++
+ #endif
+