aboutsummaryrefslogtreecommitdiff
path: root/graphics/php-facedetect
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2020-10-25 12:07:16 +0000
committerMartin Matuska <mm@FreeBSD.org>2020-10-25 12:07:16 +0000
commita0c3b8ab77588d4f707938ad1527c6aa7d2f3226 (patch)
treeb7ae6b06af8daebd15be086c77f6a5eb1f990698 /graphics/php-facedetect
parentc1b930253ee9b5c9b4bbf3dcc88ccb9d73f275a4 (diff)
downloadports-a0c3b8ab77588d4f707938ad1527c6aa7d2f3226.tar.gz
ports-a0c3b8ab77588d4f707938ad1527c6aa7d2f3226.zip
Update graphics/php-facedetect to git commit 2a8974b
- fixes for PHP 8 - support for OpenCV 4.5
Notes
Notes: svn path=/head/; revision=553262
Diffstat (limited to 'graphics/php-facedetect')
-rw-r--r--graphics/php-facedetect/Makefile4
-rw-r--r--graphics/php-facedetect/distinfo5
-rw-r--r--graphics/php-facedetect/files/patch-facedetect.c10
-rw-r--r--graphics/php-facedetect/files/patch-php__facedetect.h14
4 files changed, 5 insertions, 28 deletions
diff --git a/graphics/php-facedetect/Makefile b/graphics/php-facedetect/Makefile
index 4165c742e5de..c1a0e3b0ccfd 100644
--- a/graphics/php-facedetect/Makefile
+++ b/graphics/php-facedetect/Makefile
@@ -3,7 +3,7 @@
PORTNAME= facedetect
PORTVERSION= 1.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
@@ -17,7 +17,7 @@ LIB_DEPENDS= libopencv_objdetect.so:graphics/opencv
USE_GITHUB= yes
GH_ACCOUNT= infusion
GH_PROJECT= PHP-Facedetect
-GH_TAGNAME= 4b1dfe1
+GH_TAGNAME= 2a8974b
LIBS+= -lopencv_core
diff --git a/graphics/php-facedetect/distinfo b/graphics/php-facedetect/distinfo
index e053111a4c48..4826bde52a9c 100644
--- a/graphics/php-facedetect/distinfo
+++ b/graphics/php-facedetect/distinfo
@@ -1,2 +1,3 @@
-SHA256 (infusion-PHP-Facedetect-1.1-4b1dfe1_GH0.tar.gz) = bd628c0072750172a9234676a3a9b555ca5f46fc2f402c1ff49d8b984669e45a
-SIZE (infusion-PHP-Facedetect-1.1-4b1dfe1_GH0.tar.gz) = 2968
+TIMESTAMP = 1603627339
+SHA256 (infusion-PHP-Facedetect-1.1-2a8974b_GH0.tar.gz) = 344e928acb6c6b3228832d5333456ab99454b313bd49034d2abc9e9cc55893ea
+SIZE (infusion-PHP-Facedetect-1.1-2a8974b_GH0.tar.gz) = 4895
diff --git a/graphics/php-facedetect/files/patch-facedetect.c b/graphics/php-facedetect/files/patch-facedetect.c
deleted file mode 100644
index 4cd817e3b4f6..000000000000
--- a/graphics/php-facedetect/files/patch-facedetect.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- facedetect.c.orig 2011-12-28 16:18:09 UTC
-+++ facedetect.c
-@@ -25,6 +25,7 @@
-
- #include <opencv/cv.h>
- #include <opencv/highgui.h>
-+#include <opencv2/core/version.hpp>
-
- /* {{{ facedetect_functions[]
- *
diff --git a/graphics/php-facedetect/files/patch-php__facedetect.h b/graphics/php-facedetect/files/patch-php__facedetect.h
deleted file mode 100644
index 8d7e22461d40..000000000000
--- a/graphics/php-facedetect/files/patch-php__facedetect.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- php_facedetect.h.orig 2020-10-25 08:22:36 UTC
-+++ php_facedetect.h
-@@ -32,5 +32,11 @@ PHP_FUNCTION(face_count);
- extern zend_module_entry facedetect_module_entry;
- #define phpext_facedetect_ptr &facedetect_module_entry
-
-+#if PHP_VERSION_ID >= 80000
-+#ifndef TSRMLS_CC
-+#define TSRMLS_CC
-+#endif
-+#endif
-+
- #endif
-