aboutsummaryrefslogtreecommitdiff
path: root/graphics/php-geos
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-08 16:59:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-08 16:59:51 +0000
commit2c46cded70c17426ea85b2adb351d7c7e437ba2a (patch)
treed0d1941f70dacd44ab483758d2905ca1f2cde5ff /graphics/php-geos
parent1af4119d7840484b5cc397c9d1bd7c62e6b897be (diff)
downloadports-2c46cded70c17426ea85b2adb351d7c7e437ba2a.tar.gz
ports-2c46cded70c17426ea85b2adb351d7c7e437ba2a.zip
Fix build with PHP 7.4 and unbreak this port
Notes
Notes: svn path=/head/; revision=519384
Diffstat (limited to 'graphics/php-geos')
-rw-r--r--graphics/php-geos/Makefile1
-rw-r--r--graphics/php-geos/files/patch-geos.c20
2 files changed, 20 insertions, 1 deletions
diff --git a/graphics/php-geos/Makefile b/graphics/php-geos/Makefile
index fbba974042e9..17a1cf606744 100644
--- a/graphics/php-geos/Makefile
+++ b/graphics/php-geos/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= swig3.0:devel/swig30
LIB_DEPENDS= libgeos_c.so:graphics/geos
USES= localbase:ldflags php:ext
-IGNORE_WITH_PHP= 74
WRKSRC= ${WRKDIR}/php-${PORTNAME}
diff --git a/graphics/php-geos/files/patch-geos.c b/graphics/php-geos/files/patch-geos.c
new file mode 100644
index 000000000000..46a2599d97ce
--- /dev/null
+++ b/graphics/php-geos/files/patch-geos.c
@@ -0,0 +1,20 @@
+--- geos.c.orig 2016-12-24 10:53:24 UTC
++++ geos.c
+@@ -863,7 +863,7 @@ PHP_METHOD(Geometry, buffer)
+ GEOS_PHP_ZVAL data;
+ HashTable *style;
+ zend_string *key;
+- ulong index;
++ zend_ulong index;
+
+ this = (GEOSGeometry*)getRelay(getThis(), Geometry_ce_ptr);
+
+@@ -956,7 +956,7 @@ PHP_METHOD(Geometry, offsetCurve)
+ GEOS_PHP_ZVAL data;
+ HashTable *style;
+ zend_string *key;
+- ulong index;
++ zend_ulong index;
+
+ this = (GEOSGeometry*)getRelay(getThis(), Geometry_ce_ptr);
+