aboutsummaryrefslogtreecommitdiff
path: root/graphics/php5-gd
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-06-09 14:25:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-06-09 14:25:41 +0000
commitf2fc9d6de460a59d2ca4633a80086dc32e24c086 (patch)
tree2ac32e924ca63b881b3775b37ea4a9ca3a11cc2c /graphics/php5-gd
parent6828ea7d03181d2c9cef8349278476494f34aeaa (diff)
downloadports-f2fc9d6de460a59d2ca4633a80086dc32e24c086.tar.gz
ports-f2fc9d6de460a59d2ca4633a80086dc32e24c086.zip
Notes
Diffstat (limited to 'graphics/php5-gd')
-rw-r--r--graphics/php5-gd/Makefile1
-rw-r--r--graphics/php5-gd/files/patch-libgd_webpimg.c29
2 files changed, 30 insertions, 0 deletions
diff --git a/graphics/php5-gd/Makefile b/graphics/php5-gd/Makefile
index 2972d3162575..e4ad86b5221c 100644
--- a/graphics/php5-gd/Makefile
+++ b/graphics/php5-gd/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= graphics
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/graphics/php5-gd/files/patch-libgd_webpimg.c b/graphics/php5-gd/files/patch-libgd_webpimg.c
new file mode 100644
index 000000000000..d1d74cd0e7a6
--- /dev/null
+++ b/graphics/php5-gd/files/patch-libgd_webpimg.c
@@ -0,0 +1,29 @@
+Adjust to libvpx 1.4.0 until the code is removed.
+
+https://chromium.googlesource.com/webm/libvpx/+/9cdaa3d%5E!/
+https://bitbucket.org/libgd/gd-libgd/commits/824a3aa
+
+--- libgd/webpimg.c.orig 2013-06-25 09:58:23 UTC
++++ libgd/webpimg.c
+@@ -711,14 +711,14 @@ static WebPResult VPXEncode(const uint8*
+ codec_ctl(&enc, VP8E_SET_STATIC_THRESHOLD, 0);
+ codec_ctl(&enc, VP8E_SET_TOKEN_PARTITIONS, 2);
+
+- vpx_img_wrap(&img, IMG_FMT_I420,
++ vpx_img_wrap(&img, VPX_IMG_FMT_I420,
+ y_width, y_height, 16, (uint8*)(Y));
+- img.planes[PLANE_Y] = (uint8*)(Y);
+- img.planes[PLANE_U] = (uint8*)(U);
+- img.planes[PLANE_V] = (uint8*)(V);
+- img.stride[PLANE_Y] = y_stride;
+- img.stride[PLANE_U] = uv_stride;
+- img.stride[PLANE_V] = uv_stride;
++ img.planes[VPX_PLANE_Y] = (uint8*)(Y);
++ img.planes[VPX_PLANE_U] = (uint8*)(U);
++ img.planes[VPX_PLANE_V] = (uint8*)(V);
++ img.stride[VPX_PLANE_Y] = y_stride;
++ img.stride[VPX_PLANE_U] = uv_stride;
++ img.stride[VPX_PLANE_V] = uv_stride;
+
+ res = vpx_codec_encode(&enc, &img, 0, 1, 0, VPX_DL_BEST_QUALITY);
+