aboutsummaryrefslogtreecommitdiff
path: root/graphics/piglit
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-11-11 23:23:27 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-11-11 23:23:27 +0000
commit05d1fb7868304e2cfa6f6f7b54e96b0d6be57dbb (patch)
treec7159a26676613376bc537b1ce1787dfcd56180e /graphics/piglit
parenta7cf6ca226ce17bc73120f5f1ca54b95629a44b8 (diff)
downloadports-05d1fb7868304e2cfa6f6f7b54e96b0d6be57dbb.tar.gz
ports-05d1fb7868304e2cfa6f6f7b54e96b0d6be57dbb.zip
graphics/piglit: track graphics/wayland dependency
CMake Error at CMakeLists.txt:162 (message): Wayland support requires xkbcommon. Failed to find xkbcommon library. PR: 227509 Reported by: antoine (via exp-run)
Notes
Notes: svn path=/head/; revision=484786
Diffstat (limited to 'graphics/piglit')
-rw-r--r--graphics/piglit/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/graphics/piglit/Makefile b/graphics/piglit/Makefile
index e9d7f6cf2458..cc5e6ca9b6fc 100644
--- a/graphics/piglit/Makefile
+++ b/graphics/piglit/Makefile
@@ -44,6 +44,13 @@ SUB_FILES= pkg-message
DATADIR= ${PREFIX}/lib/piglit
PORTDATA= *
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS WAYLAND
+
+WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
+
+post-patch-WAYLAND-off:
+ @${REINPLACE_CMD} -e '/pkg_check_modules.*wayland/d' \
+ ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>