aboutsummaryrefslogtreecommitdiff
path: root/graphics/pinta
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-12-22 08:30:24 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-12-22 08:30:24 +0000
commit5ff2e13ce3a4b9fef39740742bc83adbf3a5d9fe (patch)
treeefc1672d8a0dc35948f8681a477f37fcbe53b746 /graphics/pinta
parent2c9d52b48faabaedfdb3563b49aa76f9164be126 (diff)
downloadports-5ff2e13ce3a4b9fef39740742bc83adbf3a5d9fe.tar.gz
ports-5ff2e13ce3a4b9fef39740742bc83adbf3a5d9fe.zip
[RESSURECT] graphics/pinta: Simple Gtk# Paint Program
Pinta is a drawing/editing program modeled after Paint.NET. Its goal is to provide a simplified alternative to GIMP for casual users. WWW: http://pinta-project.com/ PR: 242010 Requested by: OlivierW <olivierw1+bugzilla-freebsd hotmail com> Submitted by: OlivierW <olivierw1+bugzilla-freebsd hotmail com> (based on)
Notes
Notes: svn path=/head/; revision=520607
Diffstat (limited to 'graphics/pinta')
-rw-r--r--graphics/pinta/Makefile31
-rw-r--r--graphics/pinta/distinfo3
-rw-r--r--graphics/pinta/pkg-descr4
-rw-r--r--graphics/pinta/pkg-plist73
4 files changed, 111 insertions, 0 deletions
diff --git a/graphics/pinta/Makefile b/graphics/pinta/Makefile
new file mode 100644
index 000000000000..48fbd400bd20
--- /dev/null
+++ b/graphics/pinta/Makefile
@@ -0,0 +1,31 @@
+# Created by: Alexander Kojevnikov <alexander@kojevnikov.com>
+# $FreeBSD$
+
+PORTNAME= pinta
+PORTVERSION= 1.5
+CATEGORIES= graphics
+MASTER_SITES= https://github.com/PintaProject/Pinta/releases/download/${PORTVERSION}/
+
+MAINTAINER= olivierw1+bugzilla-freebsd@hotmail.com
+COMMENT= Simple Gtk\# Paint Program
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/license-mit.txt
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/mono-addins.pc:devel/mono-addins \
+ intltool-update:textproc/intltool
+RUN_DEPENDS= mono-addins>0:devel/mono-addins
+
+USES= desktop-file-utils gmake gnome mono pkgconfig gettext-tools:build
+USE_GNOME= gtksharp20
+
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_CONFIGURE_ENABLE= nls
+
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/pinta/distinfo b/graphics/pinta/distinfo
new file mode 100644
index 000000000000..6cf4f04d8113
--- /dev/null
+++ b/graphics/pinta/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1573996717
+SHA256 (pinta-1.5.tar.gz) = e8f902c3d196cd17a94e7c8c58e929d3cf03812444355efe5db79c129ee472a7
+SIZE (pinta-1.5.tar.gz) = 1298484
diff --git a/graphics/pinta/pkg-descr b/graphics/pinta/pkg-descr
new file mode 100644
index 000000000000..ce2cf6996de2
--- /dev/null
+++ b/graphics/pinta/pkg-descr
@@ -0,0 +1,4 @@
+Pinta is a drawing/editing program modeled after Paint.NET. Its goal is to
+provide a simplified alternative to GIMP for casual users.
+
+WWW: http://pinta-project.com/
diff --git a/graphics/pinta/pkg-plist b/graphics/pinta/pkg-plist
new file mode 100644
index 000000000000..a84208184dec
--- /dev/null
+++ b/graphics/pinta/pkg-plist
@@ -0,0 +1,73 @@
+bin/pinta
+lib/pinta/Pinta.Core.dll
+lib/pinta/Pinta.Effects.dll
+lib/pinta/Pinta.Gui.Widgets.dll
+lib/pinta/Pinta.Resources.dll
+lib/pinta/Pinta.Tools.dll
+lib/pinta/Pinta.exe
+man/man1/pinta.1.gz
+share/applications/pinta.desktop
+share/icons/hicolor/16x16/apps/pinta.png
+share/icons/hicolor/22x22/apps/pinta.png
+share/icons/hicolor/24x24/apps/pinta.png
+share/icons/hicolor/32x32/apps/pinta.png
+share/icons/hicolor/96x96/apps/pinta.png
+share/icons/hicolor/scalable/apps/pinta.svg
+%%NLS%%share/locale/af/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/az/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/br/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/bs/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/da/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/de/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/el/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/en_AU/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/en_CA/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/es/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/et/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/fil/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/fo/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/he/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/hi/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/hy/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/id/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/it/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/la/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/th/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/pinta.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/pinta.mo
+share/pixmaps/pinta.xpm