aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixie
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-11 04:04:42 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:42 +0000
commita29889b72a6957b90c6636dea7517e028a4dfab9 (patch)
treeabaac74159aea2d3ab995704029b8bee1712febd /graphics/pixie
parent2ae65f787181af6f9d5556e85e8f6867f52be117 (diff)
downloadports-a29889b72a6957b90c6636dea7517e028a4dfab9.tar.gz
ports-a29889b72a6957b90c6636dea7517e028a4dfab9.zip
graphics/pixie: make compatible with OpenEXR/Imath 3.0
Diffstat (limited to 'graphics/pixie')
-rw-r--r--graphics/pixie/Makefile16
-rw-r--r--graphics/pixie/files/patch-Makefile.am12
-rw-r--r--graphics/pixie/files/patch-acinclude.m4 (renamed from graphics/pixie/files/patch-configure)15
-rw-r--r--graphics/pixie/files/patch-src_openexr_openexr.cpp10
4 files changed, 41 insertions, 12 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index 4f29fc6d5a75..f52623372cae 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pixie
PORTVERSION= 2.2.6
-PORTREVISION= 29
+PORTREVISION= 30
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Pixie%20${PORTVERSION}
DISTNAME= Pixie-src-${PORTVERSION}
@@ -20,11 +20,12 @@ BROKEN_riscv64= fails to compile: ri/atomic.h:149:9: use of undeclared identifi
BROKEN_FreeBSD_11_powerpc64= fails to compile on powerpc64 elfv1: ../common/mathSpec.h:548:37: error: 'max' was not declared in this scope
BROKEN_FreeBSD_12_powerpc64= fails to compile on powerpc64 elfv1: ../common/mathSpec.h:548:37: error: 'max' was not declared in this scope
-LIB_DEPENDS= libIlmImf.so:graphics/openexr \
+LIB_DEPENDS= libOpenEXR.so:graphics/openexr \
+ libImath.so:math/Imath \
libtiff.so:graphics/tiff \
libfltk_gl.so:x11-toolkits/fltk
-USES= bison compiler:c++0x gl libtool pathfix tar:tgz
+USES= autoreconf bison compiler:c++0x gl libtool pathfix tar:tgz
USE_GL= glu
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include/pixie \
@@ -44,7 +45,7 @@ USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
PORTDOCS= *
CFLAGS+= -fPIC
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/Imath
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS
@@ -52,12 +53,9 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e '/test/s|==|=|g ; \
s|-lpthread|-pthread|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/^SUBDIRS/s|doc||g ; \
- /^install-data-am:/s|install-nobase_docDATA||g' \
- ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^includedir/s|=.*$$|= @includedir@|g' \
- ${WRKSRC}/src/ri/Makefile.in \
- ${WRKSRC}/src/sdr/Makefile.in
+ ${WRKSRC}/src/ri/Makefile.am \
+ ${WRKSRC}/src/sdr/Makefile.am
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/pixie/files/patch-Makefile.am b/graphics/pixie/files/patch-Makefile.am
new file mode 100644
index 000000000000..a43e4d055af0
--- /dev/null
+++ b/graphics/pixie/files/patch-Makefile.am
@@ -0,0 +1,12 @@
+--- Makefile.am.orig 2021-04-11 03:59:19 UTC
++++ Makefile.am
+@@ -1,8 +1,6 @@
+-SUBDIRS = src doc
++SUBDIRS = src
+
+ man_MANS = man/rndr.1 man/sdrc.1 man/sdrinfo.1 man/texmake.1
+-
+-nobase_doc_DATA = AUTHORS ChangeLog COPYING DEVNOTES LICENSE NEWS README
+
+ shader_DATA = shaders/*
+
diff --git a/graphics/pixie/files/patch-configure b/graphics/pixie/files/patch-acinclude.m4
index c423707d783f..475f06a4f077 100644
--- a/graphics/pixie/files/patch-configure
+++ b/graphics/pixie/files/patch-acinclude.m4
@@ -1,6 +1,15 @@
---- configure.orig
-+++ configure
-@@ -18418,10 +18418,10 @@
+--- acinclude.m4.orig 2008-05-03 05:22:57 UTC
++++ acinclude.m4
+@@ -45,7 +45,7 @@ AC_ARG_ENABLE(openexr-threads,[ --enable-openexr-thre
+ if test "x$enable_static_openexr" == "xyes"; then
+ OPENEXR_LIBS="$X_LIBS $openexr_static_libs"
+ else
+- OPENEXR_LIBS="$X_LIBS -lIlmImf -lImath -lIex -lHalf -lz"
++ OPENEXR_LIBS="$X_LIBS -lOpenEXR -lIex -lImath -lz"
+ fi
+
+ AC_MSG_CHECKING(for OpenEXR)
+@@ -142,10 +142,10 @@ AC_ARG_ENABLE(static-fltk,[ --enable-static-fltk Spec
if test x$FLTK_CONFIG != xno ; then
if test x$STATIC_FLTK != xtrue ; then
FLTK_CXXFLAGS="`$FLTK_CONFIG --use-gl --cxxflags`"
diff --git a/graphics/pixie/files/patch-src_openexr_openexr.cpp b/graphics/pixie/files/patch-src_openexr_openexr.cpp
new file mode 100644
index 000000000000..4944ea95056c
--- /dev/null
+++ b/graphics/pixie/files/patch-src_openexr_openexr.cpp
@@ -0,0 +1,10 @@
+--- src/openexr/openexr.cpp.orig 2008-11-26 05:21:13 UTC
++++ src/openexr/openexr.cpp
+@@ -35,6 +35,7 @@
+ #include <string.h>
+ #include <math.h>
+
++#include <ImfFrameBuffer.h>
+ #include <ImfOutputFile.h>
+ #include <ImfChannelList.h>
+ #include <ImfStringAttribute.h>