aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixmap
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>1995-02-19 03:22:36 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>1995-02-19 03:22:36 +0000
commit3f47621e5848d1918896fd15c11c5fe49c1d78af (patch)
treecadae344febd381cae78b46f7255cbd80d39ab2e /graphics/pixmap
parentcbe3a2704096d4577af448cb31802d9fc8fe4e32 (diff)
downloadports-3f47621e5848d1918896fd15c11c5fe49c1d78af.tar.gz
ports-3f47621e5848d1918896fd15c11c5fe49c1d78af.zip
Notes
Diffstat (limited to 'graphics/pixmap')
-rw-r--r--graphics/pixmap/Makefile31
-rw-r--r--graphics/pixmap/files/patch-aa19
-rw-r--r--graphics/pixmap/files/patch-ab19
-rw-r--r--graphics/pixmap/pkg-comment1
-rw-r--r--graphics/pixmap/pkg-descr3
-rw-r--r--graphics/pixmap/pkg-plist20
6 files changed, 93 insertions, 0 deletions
diff --git a/graphics/pixmap/Makefile b/graphics/pixmap/Makefile
new file mode 100644
index 000000000000..5e595be2f217
--- /dev/null
+++ b/graphics/pixmap/Makefile
@@ -0,0 +1,31 @@
+USE_IMAKE= yes
+DISTNAME= pixmap
+LIB_DEPENDS= Xpm\\.3\\.:${PORTSDIR}/graphics/xpm
+MASTER_SITES= ftp://ftp.x.org/pub/R6untarred/contrib/programs/
+
+.if !defined(MASTER_SITE_OVERRIDE)
+
+fetch: pre-fetch
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @(cd ${DISTDIR}; \
+ for file in ${DISTFILES}; do \
+ if [ ! -f $$file -a ! -f `basename $$file` ]; then \
+ echo ">> $$file doesn't seem to exist on this system."; \
+ echo ">> Attempting to fetch it from a master site."; \
+ for site in ${MASTER_SITES}; do \
+ if ${NCFTP} -c ${NCFTPFLAGS} $${site}$${file} >$$file; then \
+ break; \
+ fi \
+ done; \
+ if [ ! -f $$file -a ! -f `basename $$file` ]; then \
+ echo ">> Couldn't fetch it - please try to retreive this";\
+ echo ">> port manually into ${DISTDIR} and try again."; \
+ exit 1; \
+ fi; \
+ fi \
+ done)
+.endif
+
+pre-patch:
+ @(cd ${WRKDIR}; mv pub/R6untarred/contrib/programs/pixmap .)
+.include <bsd.port.mk>
diff --git a/graphics/pixmap/files/patch-aa b/graphics/pixmap/files/patch-aa
new file mode 100644
index 000000000000..765204c28418
--- /dev/null
+++ b/graphics/pixmap/files/patch-aa
@@ -0,0 +1,19 @@
+*** Pixmap.h~ Fri May 13 04:03:29 1994
+--- Pixmap.h Sun Feb 19 03:35:48 1995
+***************
+*** 69,75 ****
+ #include <X11/Xmu/Converters.h>
+ #include <X11/Xos.h>
+ #include <X11/Xfuncproto.h>
+! #include "xpm.h"
+
+ /* Resources:
+
+--- 69,75 ----
+ #include <X11/Xmu/Converters.h>
+ #include <X11/Xos.h>
+ #include <X11/Xfuncproto.h>
+! #include <X11/xpm.h>
+
+ /* Resources:
+
diff --git a/graphics/pixmap/files/patch-ab b/graphics/pixmap/files/patch-ab
new file mode 100644
index 000000000000..81f93dbc54fe
--- /dev/null
+++ b/graphics/pixmap/files/patch-ab
@@ -0,0 +1,19 @@
+*** SelFile/SelFile.c~ Mon May 30 04:02:59 1994
+--- SelFile/SelFile.c Sun Feb 19 03:40:43 1995
+***************
+*** 46,52 ****
+ /* BSD 4.3 errno.h does not declare errno */
+ extern int errno;
+ extern int sys_nerr;
+! extern char *sys_errlist[];
+
+ #include <sys/param.h>
+ #include <X11/cursorfont.h>
+--- 46,52 ----
+ /* BSD 4.3 errno.h does not declare errno */
+ extern int errno;
+ extern int sys_nerr;
+! /* extern char *sys_errlist[];*/
+
+ #include <sys/param.h>
+ #include <X11/cursorfont.h>
diff --git a/graphics/pixmap/pkg-comment b/graphics/pixmap/pkg-comment
new file mode 100644
index 000000000000..663594d7ad55
--- /dev/null
+++ b/graphics/pixmap/pkg-comment
@@ -0,0 +1 @@
+Pixmap is a pixmap editor based on XPM library \ No newline at end of file
diff --git a/graphics/pixmap/pkg-descr b/graphics/pixmap/pkg-descr
new file mode 100644
index 000000000000..4b986fc2caa3
--- /dev/null
+++ b/graphics/pixmap/pkg-descr
@@ -0,0 +1,3 @@
+The pixmap program is a tool for creating or editing rectangular images
+made up of colored pixels, i.e., pixmaps. Pixmaps are intensively used in
+X to define window backgrounds, icon images, etc.
diff --git a/graphics/pixmap/pkg-plist b/graphics/pixmap/pkg-plist
new file mode 100644
index 000000000000..d0d18c5341e8
--- /dev/null
+++ b/graphics/pixmap/pkg-plist
@@ -0,0 +1,20 @@
+@cd /usr/X11R6
+@mode 755
+bin/pixmap
+@mode 444
+lib/X11/app-defaults/Pixmap
+lib/X11/Pixmap/Down
+lib/X11/Pixmap/FlipHoriz
+lib/X11/Pixmap/FlipVert
+lib/X11/Pixmap/Fold
+lib/X11/Pixmap/Left
+lib/X11/Pixmap/Right
+lib/X11/Pixmap/RotateLeft
+lib/X11/Pixmap/RotateRight
+lib/X11/Pixmap/Stipple
+lib/X11/Pixmap/Up
+lib/X11/Pixmap/Term
+lib/X11/Pixmap/Excl
+man/man1/pixmap.1.gz
+@mode 644
+lib/libXgnu.a