aboutsummaryrefslogtreecommitdiff
path: root/graphics/plasma-kmod
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-31 04:05:26 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-31 04:05:26 +0000
commit3896bfc1ff2e64a75f52ad01a302d5c5cbcd0330 (patch)
tree82606120f41b62356229fbf72b5f274fff667623 /graphics/plasma-kmod
parent67fc8379f6687707e8aa716e013c3831d59bf9bc (diff)
downloadports-3896bfc1ff2e64a75f52ad01a302d5c5cbcd0330.tar.gz
ports-3896bfc1ff2e64a75f52ad01a302d5c5cbcd0330.zip
Add plasma-kmod 0.1, a plasma-effect screensaver kernel module.
PR: 24614 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Notes
Notes: svn path=/head/; revision=40635
Diffstat (limited to 'graphics/plasma-kmod')
-rw-r--r--graphics/plasma-kmod/Makefile26
-rw-r--r--graphics/plasma-kmod/distinfo1
-rw-r--r--graphics/plasma-kmod/pkg-comment1
-rw-r--r--graphics/plasma-kmod/pkg-descr8
-rw-r--r--graphics/plasma-kmod/pkg-message5
-rw-r--r--graphics/plasma-kmod/pkg-plist1
6 files changed, 42 insertions, 0 deletions
diff --git a/graphics/plasma-kmod/Makefile b/graphics/plasma-kmod/Makefile
new file mode 100644
index 000000000000..11f8d5987ea1
--- /dev/null
+++ b/graphics/plasma-kmod/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: plasma-kmod
+# Date created: 24 January 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plasma
+PORTVERSION= 0.1
+CATEGORIES= graphics
+MASTER_SITES= http://ukug.uk.freebsd.org/~greid/
+PKGNAMESUFFIX= -kmod
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+.if !exists(/usr/src/sys/dev/syscons/syscons.h)
+BROKEN= "Requires kernel source (/usr/src/sys) to build"
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/plasma_saver.ko ${PREFIX}/lib
+
+post-install:
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/graphics/plasma-kmod/distinfo b/graphics/plasma-kmod/distinfo
new file mode 100644
index 000000000000..4a03ea266dec
--- /dev/null
+++ b/graphics/plasma-kmod/distinfo
@@ -0,0 +1 @@
+MD5 (plasma-0.1.tar.gz) = 24267c076384eb48bccbb9f81a482adc
diff --git a/graphics/plasma-kmod/pkg-comment b/graphics/plasma-kmod/pkg-comment
new file mode 100644
index 000000000000..3c40d42c44b1
--- /dev/null
+++ b/graphics/plasma-kmod/pkg-comment
@@ -0,0 +1 @@
+A plasma-effect screensaver kernel module
diff --git a/graphics/plasma-kmod/pkg-descr b/graphics/plasma-kmod/pkg-descr
new file mode 100644
index 000000000000..3ac152b05d3b
--- /dev/null
+++ b/graphics/plasma-kmod/pkg-descr
@@ -0,0 +1,8 @@
+plasma is a FreeBSD kernel module screensaver which displays a moving
+plasma effect. You are advised that the code is quite resource-greedy
+and that you probably don't want to run it on anything but a desktop
+workstation. It's a quick hack, so comments/constructive criticism is
+appreciated. MAINTAINER is the author of this port.
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/graphics/plasma-kmod/pkg-message b/graphics/plasma-kmod/pkg-message
new file mode 100644
index 000000000000..2ef68c37d15e
--- /dev/null
+++ b/graphics/plasma-kmod/pkg-message
@@ -0,0 +1,5 @@
+
+The plasma_saver.ko module has been installed to %%PREFIX%%/lib. You
+may wish to add this to your kern.module_path sysctl string or copy it
+to another location.
+
diff --git a/graphics/plasma-kmod/pkg-plist b/graphics/plasma-kmod/pkg-plist
new file mode 100644
index 000000000000..a27c9ce30023
--- /dev/null
+++ b/graphics/plasma-kmod/pkg-plist
@@ -0,0 +1 @@
+lib/plasma_saver.ko