aboutsummaryrefslogtreecommitdiff
path: root/graphics/plasma-kmod
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2012-04-19 21:28:59 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2012-04-19 21:28:59 +0000
commite01c1892b37d12436285e8ec4fb60678a9fafb63 (patch)
tree7aef0919f62ab2fd3651bf6c47400e84c209730f /graphics/plasma-kmod
parentb07e109b5249b179451e6fbb598502309b3e4deb (diff)
downloadports-e01c1892b37d12436285e8ec4fb60678a9fafb63.tar.gz
ports-e01c1892b37d12436285e8ec4fb60678a9fafb63.zip
Do not round up the angle to avoid an out-of-boundary condition.
Notes
Notes: svn path=/head/; revision=295129
Diffstat (limited to 'graphics/plasma-kmod')
-rw-r--r--graphics/plasma-kmod/Makefile2
-rw-r--r--graphics/plasma-kmod/files/patch-plasma_saver.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/plasma-kmod/Makefile b/graphics/plasma-kmod/Makefile
index fcd775951ece..21a4f9eb7a6a 100644
--- a/graphics/plasma-kmod/Makefile
+++ b/graphics/plasma-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= plasma
PORTVERSION= 0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics kld
MASTER_SITES= SF/futurebsd/futurebsd/${PORTNAME}
PKGNAMESUFFIX= -kmod
diff --git a/graphics/plasma-kmod/files/patch-plasma_saver.c b/graphics/plasma-kmod/files/patch-plasma_saver.c
index 69bc3c854f32..df7ec0479f30 100644
--- a/graphics/plasma-kmod/files/patch-plasma_saver.c
+++ b/graphics/plasma-kmod/files/patch-plasma_saver.c
@@ -42,7 +42,7 @@
/* theta now > 0, < 2pi, look up in table */
- apos = (int)((theta/TWO_PI)*90.0);
-+ apos = fdiv(fdiv(theta * SCALE, TWO_PI) * 90, SCALE);
++ apos = fdiv(theta * SCALE, TWO_PI) * 90 / SCALE;
return((neg) ? -aprsinv[apos] : aprsinv[apos]);
}