aboutsummaryrefslogtreecommitdiff
path: root/graphics/png/Makefile
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-10-16 19:42:23 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-10-16 21:21:17 +0000
commit9f4f89ec947067351dee8e6887d268e92ec0f317 (patch)
tree087c9a4ada90bb574e7f3ca0b0c2d36082037ebf /graphics/png/Makefile
parent9e03d9958ec94c454641adc956fd3b40188fc925 (diff)
downloadports-9f4f89ec947067351dee8e6887d268e92ec0f317.tar.gz
ports-9f4f89ec947067351dee8e6887d268e92ec0f317.zip
Diffstat (limited to 'graphics/png/Makefile')
-rw-r--r--graphics/png/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 9a088e442f44..566dd86d9111 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -1,11 +1,9 @@
PORTNAME= png
-PORTVERSION= 1.6.37
-PORTREVISION= 1
+DISTVERSION= 1.6.38
CATEGORIES= graphics
-MASTER_SITES= SF/lib${PORTNAME}/lib${PORTNAME}16/${PORTVERSION} \
- ftp://ftp.simplesystems.org/pub/lib${PORTNAME}/${PORTNAME}/src/lib${PORTNAME}16/
-PATCH_SITES= SF/apng/lib${PORTNAME}/lib${PORTNAME}16/
-DISTNAME= lib${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/lib${PORTNAME}/lib${PORTNAME}16/${DISTVERSION}/
+PATCH_SITES= SF/lib${PORTNAME}-apng/lib${PORTNAME}16/${DISTVERSION}/
+DISTNAME= lib${PORTNAME}-${DISTVERSION}
MAINTAINER= desktop@FreeBSD.org
COMMENT= Library for manipulating PNG images
@@ -17,23 +15,22 @@ LICENSE_NAME= libpng License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USE_CSTD= gnu89
-USES= cpe libtool tar:xz
+USES= cmake:testing cpe pathfix tar:xz
CPE_PRODUCT= libpng
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
-INSTALL_TARGET= install-strip
-TEST_TARGET= check-TESTS
USE_LDCONFIG= yes
+CMAKE_OFF= PNG_TESTS
+CMAKE_TESTING_ON= PNG_TESTS
+
OPTIONS_DEFINE= APNG SIMD
OPTIONS_DEFAULT=APNG
OPTIONS_DEFAULT_aarch64= SIMD
OPTIONS_DEFAULT_amd64= SIMD
OPTIONS_DEFAULT_powerpc64le= SIMD
+
APNG_DESC=Enable Animated PNG support
-SIMD_CONFIGURE_OFF= --enable-hardware-optimizations=no
-SIMD_CONFIGURE_ON= --enable-hardware-optimizations=yes
+
+SIMD_CMAKE_BOOL= PNG_HARDWARE_OPTIMIZATIONS
.include <bsd.port.options.mk>
@@ -43,7 +40,7 @@ CFLAGS+= -maltivec -mvsx
.endif
.if ${PORT_OPTIONS:MAPNG} || make(makesum)
-PATCHFILES= ${DISTNAME}-apng.patch.gz
+PATCHFILES= ${DISTNAME}-apng.patch.gz:-p1
.endif
.include <bsd.port.mk>