aboutsummaryrefslogtreecommitdiff
path: root/graphics/png2html
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-14 03:40:07 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-14 03:40:07 +0000
commit1d452080ef303a7e6e18aba6746db95236cec108 (patch)
tree81fe1e841aa903489e476b66708d678067a84d94 /graphics/png2html
parent50444721a96d80425f590e24e76bea8d0c82235f (diff)
downloadports-1d452080ef303a7e6e18aba6746db95236cec108.tar.gz
ports-1d452080ef303a7e6e18aba6746db95236cec108.zip
Initial import of png2html version 1.0.
Takes a PNG image and transorms it into HTML. PR: 14835 Submitted by: Chris D. Faulhaber <jedgar@fxp.org>
Notes
Notes: svn path=/head/; revision=23110
Diffstat (limited to 'graphics/png2html')
-rw-r--r--graphics/png2html/Makefile26
-rw-r--r--graphics/png2html/distinfo1
-rw-r--r--graphics/png2html/files/patch-aa19
-rw-r--r--graphics/png2html/pkg-comment1
-rw-r--r--graphics/png2html/pkg-descr7
-rw-r--r--graphics/png2html/pkg-plist1
6 files changed, 55 insertions, 0 deletions
diff --git a/graphics/png2html/Makefile b/graphics/png2html/Makefile
new file mode 100644
index 000000000000..e508e66083a7
--- /dev/null
+++ b/graphics/png2html/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: png2html
+# Version required: 1.0
+# Date created: 11 November 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= png2html-1.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.engr.mun.ca/~holden/
+
+MAINTAINER= jedgar@fxp.org
+
+LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png
+BUILD_DEPENDS= webpng:${PORTSDIR}/graphics/gd
+
+do-configure:
+ @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig
+ @${SED} -e 's|CHANGE_ME|${PREFIX}|' \
+ < ${WRKSRC}/Makefile.orig > ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/png2html ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/png2html/distinfo b/graphics/png2html/distinfo
new file mode 100644
index 000000000000..3dfa599d5fbb
--- /dev/null
+++ b/graphics/png2html/distinfo
@@ -0,0 +1 @@
+MD5 (png2html-1.0.tar.gz) = 21c0b58618d1cbe5d2420719e411915d
diff --git a/graphics/png2html/files/patch-aa b/graphics/png2html/files/patch-aa
new file mode 100644
index 000000000000..15e2d33c1ca0
--- /dev/null
+++ b/graphics/png2html/files/patch-aa
@@ -0,0 +1,19 @@
+--- Makefile.orig Thu Nov 11 11:27:38 1999
++++ Makefile Thu Nov 11 19:00:05 1999
+@@ -1,12 +1,14 @@
+ # Makefile for png2html, (c) 1999 Geoff Holden
+
+ CC = gcc
+-CFLAGS = -O2 -Wall -lpng -lgd
++INCLUDES= -ICHANGE_ME/include/gd
++LDFLAGS = -LCHANGE_ME/lib
++LIBS = -lpng -lgd
+
+ all: png2html
+
+ png2html:
+- $(CC) -o png2html png2html.c $(CFLAGS)
++ $(CC) -o png2html png2html.c $(CFLAGS) $(INCLUDES) $(LDFLAGS) $(LIBS)
+
+ clean:
+ rm -f *~ png2html
diff --git a/graphics/png2html/pkg-comment b/graphics/png2html/pkg-comment
new file mode 100644
index 000000000000..e14ddd4fe6d0
--- /dev/null
+++ b/graphics/png2html/pkg-comment
@@ -0,0 +1 @@
+Takes a PNG image and transforms it into HTML
diff --git a/graphics/png2html/pkg-descr b/graphics/png2html/pkg-descr
new file mode 100644
index 000000000000..8a89e9c3efa8
--- /dev/null
+++ b/graphics/png2html/pkg-descr
@@ -0,0 +1,7 @@
+png2html takes a PNG image and transforms it into a
+Web page with the use of a text file.
+
+WWW: http://www.engr.mun.ca/~holden/png2html.html
+
+- Chris D. Faulhaber
+jedgar@fxp.org
diff --git a/graphics/png2html/pkg-plist b/graphics/png2html/pkg-plist
new file mode 100644
index 000000000000..6b201808fa7b
--- /dev/null
+++ b/graphics/png2html/pkg-plist
@@ -0,0 +1 @@
+bin/png2html