aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngcheck/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-15 16:44:17 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-15 16:44:17 +0000
commit59feecdb4afaae478640514e50a3396e01f292ad (patch)
tree967c26e896867fd601a4667f05679ccfc85d7447 /graphics/pngcheck/Makefile
parent82760709f4c7f10ec279fb5d76c66ec2f72593b5 (diff)
Notes
Diffstat (limited to 'graphics/pngcheck/Makefile')
-rw-r--r--graphics/pngcheck/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/graphics/pngcheck/Makefile b/graphics/pngcheck/Makefile
index 5d6b978bc853..d67a21b69e3f 100644
--- a/graphics/pngcheck/Makefile
+++ b/graphics/pngcheck/Makefile
@@ -8,20 +8,25 @@
PORTNAME= pngcheck
PORTVERSION= 1.99.3
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.libpng.org/pub/png/src/ \
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://swrinde.nde.swri.edu/pub/png/applications/
+MASTER_SITE_SUBDIR= png-mng
MAINTAINER= ports@FreeBSD.org
COMMENT= Checks the integrity of PNG images
MAKEFILE= Makefile.unx
+MAKE_ARGS= CC="${CC}" LD="${CC}" CFLAGS="${CFLAGS} -DUSE_ZLIB" LIBS="-lz"
+
+PORTDOCS= CHANGELOG README
+PLIST_FILES= bin/pngcheck
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pngcheck ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>