aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngcheck
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-07-04 05:52:25 +0000
committerWill Andrews <will@FreeBSD.org>2000-07-04 05:52:25 +0000
commit25643a2bd29c0f7e49238bd0c9ff2d35bfb91757 (patch)
tree181282e879328c09f9416fdcbad3ab83eaf020c0 /graphics/pngcheck
parentc80661571290241aff332288f8784b262fbbc4fd (diff)
downloadports-25643a2bd29c0f7e49238bd0c9ff2d35bfb91757.tar.gz
ports-25643a2bd29c0f7e49238bd0c9ff2d35bfb91757.zip
Add pngcheck, a PNG image integrity checker.
Notes
Notes: svn path=/head/; revision=30163
Diffstat (limited to 'graphics/pngcheck')
-rw-r--r--graphics/pngcheck/Makefile21
-rw-r--r--graphics/pngcheck/distinfo1
-rw-r--r--graphics/pngcheck/files/patch-aa21
-rw-r--r--graphics/pngcheck/pkg-comment1
-rw-r--r--graphics/pngcheck/pkg-descr10
-rw-r--r--graphics/pngcheck/pkg-plist1
6 files changed, 55 insertions, 0 deletions
diff --git a/graphics/pngcheck/Makefile b/graphics/pngcheck/Makefile
new file mode 100644
index 000000000000..3dd874679b27
--- /dev/null
+++ b/graphics/pngcheck/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: pngcheck
+# Date created: Tue 04 Jul 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= pngcheck
+PORTVERSION= 1.99.2
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.cdrom.com/pub/png/src/ \
+ ftp://swrinde.nde.swri.edu/pub/png/applications/
+
+MAINTAINER= ports@FreeBSD.org
+
+MAKEFILE= Makefile.unx
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pngcheck ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/pngcheck/distinfo b/graphics/pngcheck/distinfo
new file mode 100644
index 000000000000..e22cd0688bb8
--- /dev/null
+++ b/graphics/pngcheck/distinfo
@@ -0,0 +1 @@
+MD5 (pngcheck-1.99.2.tar.gz) = c62dcb47940001e6e74fb50baf570ad7
diff --git a/graphics/pngcheck/files/patch-aa b/graphics/pngcheck/files/patch-aa
new file mode 100644
index 000000000000..ba20f89a32b8
--- /dev/null
+++ b/graphics/pngcheck/files/patch-aa
@@ -0,0 +1,21 @@
+--- Makefile.unx Thu Nov 18 22:39:03 1999
++++ Makefile.unx.new Tue Jul 4 01:47:15 2000
+@@ -23,13 +23,13 @@
+ #ZLIB = -L$(ZPATH) -lz
+ ZLIB = $(ZPATH)/libz.a
+
+-INCS = $(ZINC)
+-LIBS = $(ZLIB)
++INCS =
++LIBS = -lz
+
+-CC = gcc
+-LD = gcc
++CC ?= gcc
++LD ?= $(CC)
+ RM = rm
+-CFLAGS = -O3 -Wall $(INCS) -DUSE_ZLIB
++CFLAGS += -Wall $(INCS) -DUSE_ZLIB
+ # [note that -Wall is a gcc-specific compilation flag ("all warnings on")]
+ O = .o
+ E =
diff --git a/graphics/pngcheck/pkg-comment b/graphics/pngcheck/pkg-comment
new file mode 100644
index 000000000000..9e1d17ea4054
--- /dev/null
+++ b/graphics/pngcheck/pkg-comment
@@ -0,0 +1 @@
+Checks the integrity of PNG images
diff --git a/graphics/pngcheck/pkg-descr b/graphics/pngcheck/pkg-descr
new file mode 100644
index 000000000000..e0752a736f76
--- /dev/null
+++ b/graphics/pngcheck/pkg-descr
@@ -0,0 +1,10 @@
+pngcheck is the official PNG tester and debugger. Originally
+designed simply to test the CRCs within a PNG image file (e.g.,
+to check for ASCII rather than binary transfer), it has since
+been extended to check and optionally print almost all the
+information about a PNG image and to verify that it conforms to
+the PNG specification. It also includes partial support for MNG animations.
+
+WWW: http://www.libpng.org/pub/png/apps/pngcheck.html
+
+- Will <andrews@technologist.com>
diff --git a/graphics/pngcheck/pkg-plist b/graphics/pngcheck/pkg-plist
new file mode 100644
index 000000000000..298c269454b1
--- /dev/null
+++ b/graphics/pngcheck/pkg-plist
@@ -0,0 +1 @@
+bin/pngcheck