aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngcheck
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-05 16:12:13 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-05 16:12:13 +0000
commit4f8a6ab4f12edcebdb09cc02fb1cf0dfd4301af5 (patch)
tree72d01ebdd7a76e528b59c01e63559cf75ab9d5d3 /graphics/pngcheck
parent195cae26f349a7518f2c824e71fc997d3d654d14 (diff)
downloadports-4f8a6ab4f12edcebdb09cc02fb1cf0dfd4301af5.tar.gz
ports-4f8a6ab4f12edcebdb09cc02fb1cf0dfd4301af5.zip
Notes
Diffstat (limited to 'graphics/pngcheck')
-rw-r--r--graphics/pngcheck/Makefile23
-rw-r--r--graphics/pngcheck/pkg-descr20
2 files changed, 29 insertions, 14 deletions
diff --git a/graphics/pngcheck/Makefile b/graphics/pngcheck/Makefile
index c1217cd76e4b..03f89944bf5f 100644
--- a/graphics/pngcheck/Makefile
+++ b/graphics/pngcheck/Makefile
@@ -3,26 +3,33 @@
PORTNAME= pngcheck
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/png-mng/${PORTNAME}/${PORTVERSION}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Checks the integrity of PNG images
+LICENSE= MIT GPLv2
+LICENSE_COMB= dual
+
MAKEFILE= Makefile.unx
MAKE_ARGS= CC="${CC}" LD="${CC}" CFLAGS="${CFLAGS} -DUSE_ZLIB" LIBS="-lz"
PORTDOCS= CHANGELOG README
-PLIST_FILES= bin/pngcheck
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+
+PLIST_FILES= bin/pngcheck \
+ bin/pngsplit \
+ bin/png-fix-IDAT-windowsize
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pngcheck ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+.for f in pngcheck pngsplit png-fix-IDAT-windowsize
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin/
+.endfor
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/graphics/pngcheck/pkg-descr b/graphics/pngcheck/pkg-descr
index feff3efe08c9..f965a4f898c5 100644
--- a/graphics/pngcheck/pkg-descr
+++ b/graphics/pngcheck/pkg-descr
@@ -1,8 +1,16 @@
-pngcheck is the official PNG tester and debugger. Originally
-designed simply to test the CRCs within a PNG image file (e.g.,
-to check for ASCII rather than binary transfer), it has since
-been extended to check and optionally print almost all the
-information about a PNG image and to verify that it conforms to
-the PNG specification. It also includes partial support for MNG animations.
+pngcheck verifies the integrity of PNG, JNG and MNG files
+(by checking the internal 32-bit CRCs [checksums] and decompressing
+the image data); it can optionally dump almost all of the chunk-level
+information in the image in human-readable form.
+For example, it can be used to print the basic statistics about an image
+(dimensions, bit depth, etc.); to list the color and transparency info
+in its palette (assuming it has one); or to extract the embedded text
+annotations. This is a command-line program with batch capabilities.
+
+pngsplit - break a PNG, MNG or JNG image into constituent chunks
+(numbered for easy reassembly)
+
+png-fix-IDAT-windowsize - fix minor zlib-header breakage caused by
+older libpng
WWW: http://www.libpng.org/pub/png/apps/pngcheck.html