aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngcrush
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-06-08 17:18:33 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-06-08 17:18:33 +0000
commitaa571ecdc5ad12d600063bc3201561b8a0e818ec (patch)
tree93abf36fba68f592dfaa0cd697883c241abfeaa9 /graphics/pngcrush
parent59a275ca574a48cd9c1382654805471b5af8808d (diff)
downloadports-aa571ecdc5ad12d600063bc3201561b8a0e818ec.tar.gz
ports-aa571ecdc5ad12d600063bc3201561b8a0e818ec.zip
Notes
Diffstat (limited to 'graphics/pngcrush')
-rw-r--r--graphics/pngcrush/Makefile5
-rw-r--r--graphics/pngcrush/distinfo4
-rw-r--r--graphics/pngcrush/files/patch-Makefile29
3 files changed, 33 insertions, 5 deletions
diff --git a/graphics/pngcrush/Makefile b/graphics/pngcrush/Makefile
index d3550416e8e4..92c62eb7c4eb 100644
--- a/graphics/pngcrush/Makefile
+++ b/graphics/pngcrush/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= pngcrush
-PORTVERSION= 1.7.51
+PORTVERSION= 1.7.59
CATEGORIES= graphics
-MASTER_SITES= SF/pmt/${PORTNAME}/old-versions/1.7/${PORTVERSION}/
+MASTER_SITES= SF/pmt/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-nolib
MAINTAINER= jsa@FreeBSD.org
@@ -13,7 +13,6 @@ COMMENT= Optimizer for PNG files
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_XZ= yes
-USE_GMAKE= yes
CFLAGS+= -DPNGCRUSH_COUNT_COLORS -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}" LD="${CC}" LDFLAGS="${LDFLAGS}"
diff --git a/graphics/pngcrush/distinfo b/graphics/pngcrush/distinfo
index b989393504d7..ff9163b8c013 100644
--- a/graphics/pngcrush/distinfo
+++ b/graphics/pngcrush/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pngcrush-1.7.51-nolib.tar.xz) = 78df26dd2c6fdb09e55078d173350bef62abb2ba51ccfe352f4be6f6b8cf7762
-SIZE (pngcrush-1.7.51-nolib.tar.xz) = 53912
+SHA256 (pngcrush-1.7.59-nolib.tar.xz) = 0dd7b7d0fb73e8ce9ada44ab1690613dc58c0800806bf3b06a411d69ffd37eb0
+SIZE (pngcrush-1.7.59-nolib.tar.xz) = 56532
diff --git a/graphics/pngcrush/files/patch-Makefile b/graphics/pngcrush/files/patch-Makefile
new file mode 100644
index 000000000000..aab7b3fb59ba
--- /dev/null
+++ b/graphics/pngcrush/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- ./Makefile.orig 2013-06-02 13:08:48.000000000 +0300
++++ ./Makefile 2013-06-02 13:10:53.000000000 +0300
+@@ -11,11 +11,11 @@
+ # macros --------------------------------------------------------------------
+
+ # uncomment these 2 lines only if you are using an external copy of libpng:
+-PNGINC = ${HOME}/include
+-PNGLIB = ${HOME}/lib
++#PNGINC = ${HOME}/include
++#PNGLIB = ${HOME}/lib
+ # uncomment these 2 lines only if you are using an external copy of zlib:
+-ZINC = ${HOME}/include
+-ZLIB = ${HOME}/lib
++#ZINC = ${HOME}/include
++#ZLIB = ${HOME}/lib
+
+ CC = gcc
+ LD = gcc
+@@ -31,8 +31,8 @@
+ PNGCRUSH = pngcrush
+
+ # LIBS = -lm
+-LIBS = -L$(PNGLIB) -lpng -lz -lm
+-# LIBS = -lpng -lz -lm
++#LIBS = -L$(PNGLIB) -lpng -lz -lm
++LIBS = -lpng -lz -lm
+ #LIBS = ${ZLIB}/libz.a -lm
+
+ # uncomment these 4 lines only if you are NOT using an external copy of zlib: