aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngnq
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-10 22:37:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-10 22:37:04 +0000
commitac281e3d684d58ef79f9364b8ff3deec252e1568 (patch)
tree96d108f45e1cf8c6df8dc4030382393ba6cedf03 /graphics/pngnq
parent2e29e6d4f2ae992a5a404555e164496c842be753 (diff)
downloadports-ac281e3d684d58ef79f9364b8ff3deec252e1568.tar.gz
ports-ac281e3d684d58ef79f9364b8ff3deec252e1568.zip
Pngnq is a tool for quantizing PNG images in RGBA format.
Pngnq is an adaptation by Stuart Coyle of Greg Roelf's pnqquant using Anthony Dekker's neuquant algorithm. The neuquant algorithm uses a neural network to optimise the color map selection. This is fast and quite accurate, giving good results on many types of images. WWW: http://pngnq.sourceforge.net/ PR: ports/134420 Submitted by: stb at lassitu.de
Notes
Notes: svn path=/head/; revision=233653
Diffstat (limited to 'graphics/pngnq')
-rw-r--r--graphics/pngnq/Makefile44
-rw-r--r--graphics/pngnq/distinfo3
-rw-r--r--graphics/pngnq/files/patch-pngcomp.c10
-rw-r--r--graphics/pngnq/pkg-descr10
4 files changed, 67 insertions, 0 deletions
diff --git a/graphics/pngnq/Makefile b/graphics/pngnq/Makefile
new file mode 100644
index 000000000000..326e0a52bbf0
--- /dev/null
+++ b/graphics/pngnq/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: pngnq
+# Date created: 10 May 2009
+# Whom: stb@lassitu.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= pngnq
+PORTVERSION= 0.5
+CATEGORIES= graphics
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= stb@lassitu.de
+COMMENT= A tool for quantizing PNG images in RGBA format
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+WRKSRC= ${WRKDIR}/${PORTVERSION}
+
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${LOCALBASE}/include -DVERSION='${PORTVERSION}'" \
+ LDFLAGS="-lpng -lz -lm -L${LOCALBASE}/lib"
+
+PORTDOCS= README LICENSE README.pngcomp
+PLIST_FILES= bin/pngcomp bin/pngnq
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= pngnq.1
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pngcomp ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/pngnq ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/pngnq.1 ${MAN1PREFIX}/man/man1
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/pngnq/distinfo b/graphics/pngnq/distinfo
new file mode 100644
index 000000000000..bfb218ee9332
--- /dev/null
+++ b/graphics/pngnq/distinfo
@@ -0,0 +1,3 @@
+MD5 (pngnq-0.5-src.tar.gz) = 14aff764008dfd55e816d3fe08636cb9
+SHA256 (pngnq-0.5-src.tar.gz) = c9f2f4239e07d23064176909cd59ef12d96573599a3fa29bed59fe554b769b92
+SIZE (pngnq-0.5-src.tar.gz) = 26115
diff --git a/graphics/pngnq/files/patch-pngcomp.c b/graphics/pngnq/files/patch-pngcomp.c
new file mode 100644
index 000000000000..9fd8e2c1e76a
--- /dev/null
+++ b/graphics/pngnq/files/patch-pngcomp.c
@@ -0,0 +1,10 @@
+--- pngcomp.c.orig 2007-11-12 13:59:38.000000000 +0100
++++ pngcomp.c 2009-05-10 15:07:38.000000000 +0200
+@@ -41,6 +41,7 @@
+ #include <string.h>
+ #include <math.h>
+ #include <ctype.h>
++#include <unistd.h>
+
+ #include "png.h"
+ #include "rwpng.h"
diff --git a/graphics/pngnq/pkg-descr b/graphics/pngnq/pkg-descr
new file mode 100644
index 000000000000..70b7aee6f1ef
--- /dev/null
+++ b/graphics/pngnq/pkg-descr
@@ -0,0 +1,10 @@
+Pngnq is a tool for quantizing PNG images in RGBA format.
+
+Pngnq is an adaptation by Stuart Coyle of Greg Roelf's pnqquant using
+Anthony Dekker's neuquant algorithm.
+
+The neuquant algorithm uses a neural network to optimise the color map
+selection. This is fast and quite accurate, giving good results on many
+types of images.
+
+WWW: http://pngnq.sourceforge.net/