aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngquant
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2018-11-18 19:20:27 +0000
committerAlex Kozlov <ak@FreeBSD.org>2018-11-18 19:20:27 +0000
commit0f9081d394f6ab4eb1036542b85e27d10712fad6 (patch)
tree1c9fd970c3eb43bf1a591230c835265f48803026 /graphics/pngquant
parent512585d9f2189b41267afaaefac34e5faac0f978 (diff)
downloadports-0f9081d394f6ab4eb1036542b85e27d10712fad6.tar.gz
ports-0f9081d394f6ab4eb1036542b85e27d10712fad6.zip
- Update to 2.12.2
- Update WWW
Notes
Notes: svn path=/head/; revision=485244
Diffstat (limited to 'graphics/pngquant')
-rw-r--r--graphics/pngquant/Makefile2
-rw-r--r--graphics/pngquant/distinfo6
-rw-r--r--graphics/pngquant/files/patch-configure32
-rw-r--r--graphics/pngquant/pkg-descr2
4 files changed, 21 insertions, 21 deletions
diff --git a/graphics/pngquant/Makefile b/graphics/pngquant/Makefile
index bf1e318d02c6..99f144b0cd81 100644
--- a/graphics/pngquant/Makefile
+++ b/graphics/pngquant/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pngquant
-PORTVERSION= 2.12.0
+PORTVERSION= 2.12.2
DISTVERSIONSUFFIX= -src
CATEGORIES= graphics
MASTER_SITES= http://pngquant.org/
diff --git a/graphics/pngquant/distinfo b/graphics/pngquant/distinfo
index 651891325d53..33c716dd85a4 100644
--- a/graphics/pngquant/distinfo
+++ b/graphics/pngquant/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1533123633
-SHA256 (pngquant-2.12.0-src.tar.gz) = 0e540c64bb58c05f2a05b4eaf1d3d165f0d3278500f15abfeac47f93f8fa8fa8
-SIZE (pngquant-2.12.0-src.tar.gz) = 143335
+TIMESTAMP = 1542566880
+SHA256 (pngquant-2.12.2-src.tar.gz) = bb031c48039ee73ea0e60709bb9ab80c55bfa3a5920b798ea37a03f2757b099c
+SIZE (pngquant-2.12.2-src.tar.gz) = 143404
diff --git a/graphics/pngquant/files/patch-configure b/graphics/pngquant/files/patch-configure
index db0cd6a43715..6b4551286869 100644
--- a/graphics/pngquant/files/patch-configure
+++ b/graphics/pngquant/files/patch-configure
@@ -95,16 +95,16 @@ Index: configure
echo "Cannot overwrite file $CONFIG! Please delete it."
exit 1
fi
-@@ -159,7 +159,7 @@
-
+@@ -160,7 +160,7 @@
find_pkgconfig() {
local LIBNAME=$1
-- if pkg-config --exists "$LIBNAME" &> /dev/null; then
-+ if pkg-config --exists "$LIBNAME" >/dev/null; then
- cflags "$(pkg-config --cflags "$LIBNAME")"
- lflags "$(pkg-config --libs "$LIBNAME")"
- LIBRARY_FOUND_VERSION=$(pkg-config --modversion "$LIBNAME")
-@@ -240,9 +240,13 @@
+ PKG_CONFIG=${PKG_CONFIG:-pkg-config}
+- if $PKG_CONFIG --exists "$LIBNAME" &> /dev/null; then
++ if $PKG_CONFIG --exists "$LIBNAME" > /dev/null; then
+ cflags "$($PKG_CONFIG --cflags "$LIBNAME")"
+ lflags "$($PKG_CONFIG --libs "$LIBNAME")"
+ LIBRARY_FOUND_VERSION=$($PKG_CONFIG --modversion "$LIBNAME")
+@@ -241,9 +241,13 @@
return 0
fi
@@ -121,7 +121,7 @@ Index: configure
return 0
fi
done
-@@ -299,12 +303,8 @@
+@@ -300,12 +304,8 @@
# SSE
if [ "$SSE" = 'auto' ]; then
SSE=0
@@ -136,7 +136,7 @@ Index: configure
fi
if [ "$SSE" -eq 1 ]; then
-@@ -327,9 +327,8 @@
+@@ -328,9 +328,8 @@
else
OPENMPFLAGS="-fopenmp"
fi
@@ -148,7 +148,7 @@ Index: configure
cflags "$OPENMPFLAGS"
lflags "$OPENMPFLAGS"
status "OpenMP" "yes"
-@@ -344,38 +343,35 @@
+@@ -345,38 +344,35 @@
fi
# Cocoa
@@ -199,7 +199,7 @@ Index: configure
SOLIBSUFFIX=dll
else
SOLIBSUFFIX=so
-@@ -416,7 +412,7 @@
+@@ -417,7 +413,7 @@
if echo "#include \"png.h\"
int main(){
return !png_create_write_struct(PNG_LIBPNG_VER_STRING, NULL, NULL, NULL);
@@ -208,7 +208,7 @@ Index: configure
status "libpng" "custom flags"
HAS_LIBPNG=1
fi
-@@ -427,7 +423,7 @@
+@@ -428,7 +424,7 @@
if [ -n "$PNGH" ]; then
PNGH_STRING=$(pngh_string "$PNGH")
PNGH_MAJMIN=$(pngh_majmin "$PNGH")
@@ -217,7 +217,7 @@ Index: configure
LIBPNGA=$(find_f "$LIBPNG_DIR" "libpng${PNGH_MAJMIN}.a")
if [ -z "$LIBPNGA" ]; then
LIBPNGA=$(find_f "$LIBPNG_DIR" "libpng.a")
-@@ -446,14 +442,19 @@
+@@ -447,14 +443,19 @@
if find_pkgconfig libpng; then
HAS_LIBPNG=1
else
@@ -242,7 +242,7 @@ Index: configure
if [ -n "$LIBPNGSO" ]; then
cflags "-I${PNGH%/*}"
lflags "-L${LIBPNGSO%/*} -lpng${PNGH_MAJMIN}"
-@@ -467,7 +468,7 @@
+@@ -468,7 +469,7 @@
fi
fi
if [ "$HAS_LIBPNG" -eq 0 ]; then
@@ -251,7 +251,7 @@ Index: configure
LIBPNG_CMD='`brew install libpng`'
else
LIBPNG_CMD='`apt-get install libpng16-dev` or `apt-get install libpng-dev` or `yum install libpng-devel`'
-@@ -534,6 +535,6 @@
+@@ -535,6 +536,6 @@
SOLIBSUFFIX = $SOLIBSUFFIX
STATICLIBDEPS = $STATICLIBDEPS
LIQSRCDIR = $LIQSRCDIR
diff --git a/graphics/pngquant/pkg-descr b/graphics/pngquant/pkg-descr
index b4f6da610b49..f740a37f838d 100644
--- a/graphics/pngquant/pkg-descr
+++ b/graphics/pngquant/pkg-descr
@@ -14,4 +14,4 @@ Features:
- Easy to integrate with shell scripts, GUIs and server-side software.
- Fast mode for processing large numbers of images.
-WWW: http://pngquant.org/
+WWW: https://pngquant.org/