aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngquant
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-02 16:52:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-02 16:52:20 +0000
commitcd3d09458cd805aad1c334fce9998af2164ce555 (patch)
tree36a9071387112bb8634936d2744412e313c761a6 /graphics/pngquant
parent82151969a7e765675a57233558f4e8009bc3bb07 (diff)
downloadports-cd3d09458cd805aad1c334fce9998af2164ce555.tar.gz
ports-cd3d09458cd805aad1c334fce9998af2164ce555.zip
add pngquant 0.95
convert 32-bit RGBA PNGs into 8-bit RGBA-palette PNGs PR: 34734 Submitted by: Alex Hayward <xelah@xelah.com>
Notes
Notes: svn path=/head/; revision=57221
Diffstat (limited to 'graphics/pngquant')
-rw-r--r--graphics/pngquant/Makefile31
-rw-r--r--graphics/pngquant/distinfo1
-rw-r--r--graphics/pngquant/files/patch-aa22
-rw-r--r--graphics/pngquant/pkg-comment1
-rw-r--r--graphics/pngquant/pkg-descr40
-rw-r--r--graphics/pngquant/pkg-plist4
6 files changed, 99 insertions, 0 deletions
diff --git a/graphics/pngquant/Makefile b/graphics/pngquant/Makefile
new file mode 100644
index 000000000000..e5b99d935962
--- /dev/null
+++ b/graphics/pngquant/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: pngcquant
+# Date created: Fri 08 Feb 2002
+# Whom: Alex Hayward <xelah@xelah.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pngquant
+PORTVERSION= 0.95
+CATEGORIES= graphics
+MASTER_SITES= http://www.libpng.org/pub/png/src/ \
+ ftp://ftp.libpng.org/pub/png/src/ \
+ ftp://swrinde.nde.swri.edu/pub/png/applications/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= png:${PORTSDIR}/graphics/png
+
+MAKEFILE= Makefile.unx
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pngquant ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/pngquant/distinfo b/graphics/pngquant/distinfo
new file mode 100644
index 000000000000..a961d24b84c4
--- /dev/null
+++ b/graphics/pngquant/distinfo
@@ -0,0 +1 @@
+MD5 (pngquant-0.95-src.tar.gz) = 2b4dadff5470e014904ec3d84ee00c0a
diff --git a/graphics/pngquant/files/patch-aa b/graphics/pngquant/files/patch-aa
new file mode 100644
index 000000000000..ce83ae938e47
--- /dev/null
+++ b/graphics/pngquant/files/patch-aa
@@ -0,0 +1,22 @@
+--- Makefile.unx.orig Fri Feb 8 17:55:47 2002
++++ Makefile.unx Fri Feb 8 17:57:53 2002
+@@ -1,13 +1,14 @@
+ # Makefile for pngquant
+ # GRR 20001222
+
+-CC=gcc
++CC?=gcc
++LD=$(CC)
+
+-PNGINC = ../libpng
+-PNGLIB = ../libpng
++PNGINC = /usr/local/include
++PNGLIB = /usr/local/lib
+
+-ZINC = ../zlib
+-ZLIB = ../zlib
++ZINC = /usr/include
++ZLIB = /usr/lib
+
+ CFLAGS = -O3 -Wall -I. -I$(PNGINC) -I$(ZINC)
+ #LDFLAGS = -L$(PNGLIB) -lpng -L$(ZLIB) -lz -lm
diff --git a/graphics/pngquant/pkg-comment b/graphics/pngquant/pkg-comment
new file mode 100644
index 000000000000..3476087c29dd
--- /dev/null
+++ b/graphics/pngquant/pkg-comment
@@ -0,0 +1 @@
+convert 32-bit RGBA PNGs into 8-bit RGBA-palette PNGs
diff --git a/graphics/pngquant/pkg-descr b/graphics/pngquant/pkg-descr
new file mode 100644
index 000000000000..47d9294728a1
--- /dev/null
+++ b/graphics/pngquant/pkg-descr
@@ -0,0 +1,40 @@
+pngquant is a simple tool with one purpose: convert 32-bit RGBA PNGs into
+8-bit RGBA-palette PNGs (or fewer than 8 bits, if you want), via quantization
+and either ordered or diffusion (Floyd-Steinberg) dithering. The fact that
+you can also use it on RGB or even palette images (e.g., to further color-
+reduce them to 16 colors or whatever) is just a nice little bonus.
+
+The current version is fully functional in the sense that it can do:
+
+ - nice reduction of all PNG image types to 256-color (or smaller) palette
+ - automatic optimization of tRNS chunks
+ - batch conversion of multiple files (e.g., "pngquant 256 *.png")
+ - Unix-style command-line filtering (e.g., "... | pngquant 16 | ...")
+
+...on at least Unix and Win32. It should be pretty easy to port to almost
+any other platform with a command-line interface and unstructured (stream-
+oriented) files, including VMS but probably not VM or MVS.
+
+It does still lack a few features:
+
+ - no ancillary chunk preservation (except gAMA)
+ - no preservation of significant-bits info after rescaling (sBIT chunk)
+ - no mapfile support
+ - no "native" handling of 16-bit-per-sample files or gray+alpha files
+ (i.e., all samples are truncated to 8 bits and all images are promoted
+ to RGBA before quantization)
+
+These issues will be addressed in a post-1.0 release.
+
+By the way, be sure to check "before" and "after" file sizes, preferably with
+pngcrush (http://pmt.sourceforge.net/pngcrush/); dithered palette images may
+be four times smaller to begin with, but they don't compress nearly as well
+as grayscale and truecolor images. Some images, such as Henri Sivonen's alpha
+button (http://www.pp.htv.fi/hsivone1/css-test/bitmapstyle.html), can be made
+smaller as full 32-bit RGBA images (4076 bytes in this case) than as either
+FS-dithered palette (4550 bytes) or ordered-dither palette (4482 bytes) images.
+
+WWW: http://www.libpng.org/pub/png/apps/pngquant.html
+
+Greg Roelofs
+newt@pobox.com
diff --git a/graphics/pngquant/pkg-plist b/graphics/pngquant/pkg-plist
new file mode 100644
index 000000000000..c80005184317
--- /dev/null
+++ b/graphics/pngquant/pkg-plist
@@ -0,0 +1,4 @@
+bin/pngquant
+%%PORTDOCS%%share/doc/pngquant/CHANGELOG
+%%PORTDOCS%%share/doc/pngquant/README
+%%PORTDOCS%%@dirrm share/doc/pngquant